Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
    Lars Olesen
    @lsolesen
    If I run the Netlify-CMS from the Netlify page it works.
    Nelson Amaya
    @nelsonamaya82_gitlab
    Hey everyone! I'm using GitLab to authenticate and deploy repositories in Netlify. I configured it directly from the Netlify Dashboard. Now I need to disconnect my GitLab repo from that Netlify account, but I don't have access to the Netlify account anymore. Is there a way to disconnect it directly from my Repo?
    Curt J. Sampson
    @0cjs
    @nelsonamaya82_gitlab A repo is a like a file; it's doesn't perform any actions, it's just data you move around. Are you wanting to disconnect your GitLab account from Netlify, so that Netlify no longer has access to anything made available via that account?
    suzumazesuzumaze....
    @suzumaze_twitter

    I could not deploy my production. status is building since yesterday. this site is simple static contents.
    deploy log is end with this.

    6:47:43 PM: Preparing Git Reference refs/heads/master
    6:47:44 PM: No build command found, continuing to publishing
    6:47:45 PM: Finished processing build request in 2.982765884s

    Is there something that is considered to be the cause of that?

    suzumazesuzumaze....
    @suzumaze_twitter
    I have solved the problem.
    I changed build image to Ubuntu Trusty 14.04.
    Thanks.
    echujon
    @echujon
    How do I customize my gatsby neltlify cms? I don't like the template or layout of the "Kaldi" website
    Melon Shake
    @rayjencode

    Hi, guys someone experience this issue?

    https://i.imgur.com/FVDjKIr.png

    vincent youmans
    @vinceyoumans
    I would like to put up a hugo/netlify site the is NOT! searched by spiders... its private stuff. So I set robotsTXT = false in config.toml. but is there more I can do?
    Schalk Venter
    @schalkventer
    I'm getting a CORS issue when hitting https://fake-weather.netlify.app/api/weather/uuia8be61cf-c0a6-4c5d-8edf-5cd992181f1a/2020/1/1 via JavaScript. Is there a way to set * (wildcard) CORS on Netlify?
    Misha Chitharanjan
    @mishac
    Is there a way to clear cached redirects? We had a problematic redirect in our _redirects file that I've since removed, but it's still redirecting
    the same path on our branch deploys works fine, so it's not something in our code at this point....I assume it must be netlify's cdn/webserver caching the redirect
    Curt J. Sampson
    @0cjs
    The first thing to do would be to check that you are getting a wrong redirect, and the cache time on it, from the production system. (You don't want to spend a bunch of time trying to solve something that's not actually happening because you guessed wrong.)
    Amy Groshek
    @amygroshek

    Anyone seen this kind of error in the CMS admin UI before?

    react_devtools_backend.js:2430 TypeError: Failed to fetch

    {type: "ENTRIES_FAILURE", error: "Failed to load entries", payload: "TypeError: Failed to fetch", meta: {…}}
    error: "Failed to load entries"
    meta: {collection: "config"}
    payload: "TypeError: Failed to fetch"
    type: "ENTRIES_FAILURE"
    __proto__: Object
    Vesnushki
    @Vesnushki
    hello, the community! I am new in Netlify. I wanted to host my test site but was unsuccessful. I don't know what is my mistake. Could somebody help me, please?
    Step to host site:
    1) Add to archive files css folder, img folder and index.html.
    2) Upload the archive to Netify
    3) Open the site URL
    ACT>> page not found message((
    logs from deploy details.
    12:38:15 PM: Creating deploy upload records
    12:38:15 PM: Starting post processing
    12:38:15 PM: Post processing - HTML
    12:38:15 PM: Post processing - header rules
    12:38:16 PM: Post processing - redirect rules
    12:38:16 PM: Post processing done
    12:38:16 PM: Site is live ✨
    matrixbot
    @matrixbot

    deankayton How everyone. Can anyone see what is wrong with my admin/config.yml? It doesn't produce the correct filename as I would expect (it always creates a .md file, so it is as if the slug does not exist at all).

    https://gitlab.com/dnk8n/research_db_docs/-/blob/master/mkdocs/docs/admin/config.yml

    You can see by history I have tried many things.

    matrixbot
    @matrixbot
    deankayton I think it was the spaces after all that. Current implementation works. I want to cry with joy / frustration at the same time.
    888ba8
    @888ba8
    Can someone help me with this? I am trying to use Staticrypt to make it work for all pages? https://stackoverflow.com/questions/65108232/staticrypt-netlify-cms-netliify-free-tier-gatsby-password-protect-single
    emile
    @emileswain

    Anyone else had this error with ncms.

    Warning: Failed prop type: invariant is not defined
        at x (http://localhost:3000/_next/static/chunks/1.js:468:66487)
        at l (http://localhost:3000/_next/static/chunks/1.js:460:53996)
        at http://localhost:3000/_next/static/chunks/1.js:426:189812
        at Connect(Component) (http://localhost:3000/_next/static/chunks/1.js:305:26272)
        at c (http://localhost:3000/_next/static/chunks/1.js:305:24194)

    I'm totally loast as to how to debug this efficiently given everything is obscured/minified.

    matrixbot
    @matrixbot
    zaclittleberry emile (Gitter) did you figure it out? My first approach would be to see if what's going into netlify cms could be wrong/unexpected, before trying to debug ncms itself. But you could probably run your own copy of the cms unminified if you wanted to dive in.
    emile
    @emileswain
    So i thought about running netlifycms locally, which i did, then i realised that the issue is that my admin.tsx is importing the netlify-cms-app from npm and subsequently its getting compiled into my project directly. more details on this particualr issue here netlify/netlify-cms#4676
    to be honest, things are working, but i really don't like having these errors/warning all over the place. I think that the issue is something to do with react validating proptypes on various objects. Unfortuantely everything is obsfucated so its impossible to track down.
    Mark Dunbavan
    @mdunbavan

    Hi, I'm using Netlify functions to send aws ses emails. The function fires locally perfectly and I get the email as expected but once I get this into production or into build the email does not get sent the first time but upon trying again it sends the previous email that I should have got, it feels like the functions fire but they are out of step and only ever sends the previous request not that current request.

    The gist is that a user enters their email, it sends the email to the lambda function, we then check it and send an AWS email with a magic sign in link to that email. Like I said above locally fine works as normal but in build env it only fires the second time and it is a step out each time

    Can anyone shed light into this at all?
    emile
    @emileswain

    (nextjs,custom widget) So, cms custom widget editor, i register a custom editor widget with cms.registerEditorComponent(BannerBlockEditorComponent); in its toPreview i return 'return <BannerBlock data={obj}></BannerBlock>' where banner block is basically a div with a button and an useCallback handler.

    In the cms preview the buttons callback doesn't work. So my question is, is it? or should it be possible to have a custom components javascript work? Its like the javascript for the preview iframe isn't being embedded.

    wongjustin98
    @wongjustin98
    Anyone had issues with getting publish_mode: editorial_mode working? I have been tearing my hair out for hours trying to get this simple feature to work. Deploying onto Github and used the netlify-cms template to create my repo.
    jrc2
    @jrc2
    What could have caused a 503 error on a Hugo site this morning?
    Nachum Barcohen
    @nabaco
    Hi guys, is it possible to run netlifyCMS without authentication?
    I have it running on a VPS where I have the site in a bare repo, and for I care I could handle the authentication through apache, is it possible to setup?
    Declan Naughton
    @declann
    Hi guys, if I push a lightweight json file to a github repo that gets mirrored to cdn, how long should I expect it to take updates to said file to get reflected in cdn? minutes or seconds - whats closer? Thanks!
    Sahil Dhanju
    @Vatyx
    What's the easiest way to learn about the latest version of hugo binrc can support?
    Cation
    @icatat
    Hi! I get this issues: TextHTTPError: Unauthorized when running netlify lm:setup. I tried logging in and out , uninstalling and reinstalling the cli and the .netlify package but nothing really work...any ideas?
    ChangKhao
    @ChangKhao
    Morning all, is there any way to add a SAML SSO for the hosted website?
    Caleb (he/him)
    @calebjasik:privacytools.io
    [m]
    howdy 👋
    Akshit Kr Nagpal
    @akshitkrnagpal
    Hey. Does anyone know why this redirection rule is not working for base url?
    [[redirects]]
    from = '*'
    to = 'https://example.com'
    status = 301
    This works for https://mywebsite.com/anything but not for https://mywebsite.com.
    Goncalo Oliveira
    @goncalo-oliveira
    Hi. Does anyone know if it's possible to use a git tag as a deploy context? I'm getting errors when trying this.
    git ref refs/heads/tag-name does not exist or you do not have permission
    Zak Hargreaves
    @ZakHargz
    Has anyone tried to use Auth0 with Git-Gateway / Implement their own backend that utilises this?
    gurachan
    @gurachan
    xD hello
    Andreas Richter
    @richtera
    We use git describe --tags in the build but we also clone some of the git repos using our own github token which we give to the build using an encrypted environment.
    David Bercovici
    @davidberco
    Hello Everybody,
    Does anybody knows how to stop deploying to the main domain?, for obvious reasons I want my client to see the changes just in the default subdomain (someword.netlify.app), after the reviews I can deploy to the main domain. (www.whatever.com).
    Does anybody found any docs for that? It seems simple but I can't find the documentation.
    Thanks in advance
    Caleb Jasik
    @jasikpark
    I would say the best way is if you have a dev branch that deploys, that you then merge into the main branch, which is what deploys to the main domain and the default netlify subdomain... So you would end up sending dev--someword.netlify.app to the client, which is probably the easiest way to do it.
    Jonathan
    @jonathanphz
    Having problems with Netlify forms and gatsby. Reading docs here: https://docs.netlify.com/forms/setup/#submit-javascript-rendered-forms-with-ajax
    In that example I see ...name inside the encode function. Where is that coming from? Doc typo?
    const handleSubmit = (event) => {
      event.preventDefault()
      fetch("/", {
        method: "POST",
        headers: { "Content-Type": "application/x-www-form-urlencoded" },
        body: encode({
          "form-name": event.target.getAttribute("name"),
          ...name
        })
      }).then(() => navigate("/thank-you/")).catch(error => alert(error))
    }
    Is this missing something?
    Colt Dorsey
    @coltdorsey
    fyi, if anyone has trouble with netlify not having access to package dependencies from private repositories AND those dependencies aren't needed for the site deployment, just reinstall those dependencies as optional dependencies and pass the --no-optional flag to your build command in the netlify toml.
    Simon Weiß
    @SimonCW

    Hi, I'm struggling to get netflify deploy previews to work with hugo. Either, links to posts are not clickable with this config:

    [context.deploy-preview]
    command = "hugo --gc --minify --buildFuture"

    Or, the theme doesn't render with this config

    [context.deploy-preview]
    command = "hugo --gc --minify --buildFuture -b $DEPLOY_PRIME_URL"

    I'm having the same settings for [context.branch-deploy] and pushing to a branch to look at the deploy preview.
    I'm using HUGO_VERSION = "0.87.0" and the ezhil theme

    Any help would be appreciated.

    BenEddi
    @BenEddi
    Hello, I use netlify-cms for my website, I used to add blog posts using the admin dashboard with no issues, but today I get the following error when I try to add a new blog post: API_ERROR: Update is not a fast forward, Could you help me resolve the issue please ? :pray:
    Curt J. Sampson
    @0cjs
    That's a Git issue, nothing to do with Netlify or your CMS.
    Shivam Rastogi
    @shivamsupr
    Hello, I use Netlify to test feature branches. The problem I'm currently facing is, not having CDN caching on the preview builds. Is there some way to enable this?
    Lukas M
    @lukasmrtvy
    Anyone is using vuepress netlifycms and netlify? I want to deploy vupress site from private repository and set access control to allow only certain people to view it. Ideas?