These are chat archives for 100GPing100/LoadingIndicators.WPF

20th
Feb 2015
Troy
@bbqchickenrobot
Feb 20 2015 01:00
Got controls compiling in my project and everything builds and runs but the loader doesn't show in the WPF form.....
Darnell Williams
@Seeker1437
Feb 20 2015 01:40
I just took the code and reubilt it from scratch using only slight code modifications it it works for me now :D
Troy
@bbqchickenrobot
Feb 20 2015 02:01
Do I need to set a z-index? The loader doesn't show in the designer either?
Darnell Williams
@Seeker1437
Feb 20 2015 02:02
You shouldn't need to
Darnell Williams
@Seeker1437
Feb 20 2015 02:20
here is a trick
Basically, open up the loading indicator project
Make sure it is targeting .Net 4.5
rebuild the project
(The loading indicator project)
and then make sure your app references the newly built project
should work again for you once you add it
Troy
@bbqchickenrobot
Feb 20 2015 02:23
i pulled the source into my project .... it compiles, etc...
Window opens but no indicator
Im manually setting the IsActive=True which I did in demo project and it worked fine there
Darnell Williams
@Seeker1437
Feb 20 2015 02:23
you saw the picture?
Troy
@bbqchickenrobot
Feb 20 2015 02:23
nah
dont see picture in designer either.... but I can select it from the right click menu but no graphic
Darnell Williams
@Seeker1437
Feb 20 2015 02:25
I changed to target framework to 4.5 in the project then rebuilt, then added as a reference, now the picutre shows properly
if the project is already in 4.5, set it back to 4.0 then to 4.5 again
Troy
@bbqchickenrobot
Feb 20 2015 02:29
cool, will try taht
thx 4 the help bro :)
Troy
@bbqchickenrobot
Feb 20 2015 02:37
ok, in a test form - the indicator loads up juset like yours.....
wonder if its som'n in my original form thats causing an issue..... has to be z-index?
Darnell Williams
@Seeker1437
Feb 20 2015 02:38
You shouldn't need that unless you are trying to render on top of something else?
Troy
@bbqchickenrobot
Feb 20 2015 02:50
Oh.... ya, was teying to render on my main form. Do i need a separat window for the loader? Duh....
How did u ger that cool lil window?
Ur own xaml?
Darnell Williams
@Seeker1437
Feb 20 2015 02:51
MahApps.Metro.SimpleChildWindow
Troy
@bbqchickenrobot
Feb 20 2015 02:54
Cool, just looked at that. Will try my own then fo that route
Thx. Again man
Darnell Williams
@Seeker1437
Feb 20 2015 02:54
np
Yeha I do plan to add my own stuff later but this is just a quick littleapp for myself to use at work xD
Troy
@bbqchickenrobot
Feb 20 2015 21:21
Got it workin.
Was the zindex and the fact i wasnt hosting it in its own form. Pretty cool little lib
Darnell Williams
@Seeker1437
Feb 20 2015 23:00
:)