These are chat archives for 75lb/local-web-server

9th
Jun 2016
krigton
@krigton_twitter
Jun 09 2016 10:28
hello
Lloyd Brookes
@75lb
Jun 09 2016 11:33
Hi
Lloyd Brookes
@75lb
Jun 09 2016 11:40
@krigton_twitter
krigton
@krigton_twitter
Jun 09 2016 13:48
hello
I think I sorted or at leas it's not related to the web server
Lloyd Brookes
@75lb
Jun 09 2016 13:49
Ok
krigton
@krigton_twitter
Jun 09 2016 13:49
thank you
Lloyd Brookes
@75lb
Jun 09 2016 13:49
Pleasure!
krigton
@krigton_twitter
Jun 09 2016 13:52
still, maybe you can give me a hint, why I'm getting 500 as response proxying to certain servers (if I open directly the link to the that server it works). what to look for? only if you have time. do not really want to bother you
Lloyd Brookes
@75lb
Jun 09 2016 13:55
well, a 500 is a server-side issue.. is there anything in the server logs?
krigton
@krigton_twitter
Jun 09 2016 14:03
not really, our admin says that it might be a certificate problem
the servers I'm proxying for are on https self signed certificate not signed for the exact domain name I'm proxying for
can this be an issue?
Lloyd Brookes
@75lb
Jun 09 2016 14:16
that's no a server issue, that's a client issue
if a client cannot connect, you would see an error at client-side.. i don't think you would get as far as receiving a 500
krigton
@krigton_twitter
Jun 09 2016 14:33
that's true, not sure where the problem lies. In the logs I only get the HEAD requests nor the GET or POST ones
Lloyd Brookes
@75lb
Jun 09 2016 14:44
have you tried running local-web-server in --verbose mode? it will give you a little more info about which requests are being proxied
ws --verbose --log-format none
@krigton_twitter
i have raised an issue #41 to implement more detailed log output for proxied requests.
krigton
@krigton_twitter
Jun 09 2016 15:34
this is what I gout
I got
so I guess I was close :D
Lloyd Brookes
@75lb
Jun 09 2016 15:35
ah, that is not a 500 error though
krigton
@krigton_twitter
Jun 09 2016 15:35
how I could work around this? I like your server and I would like to use it but I'm not sure I can do something about the self signed certificate in our system
I got a 500 at the end
Lloyd Brookes
@75lb
Jun 09 2016 15:35
i see
krigton
@krigton_twitter
Jun 09 2016 15:36
at least that's what I see in chrome dev tool
Lloyd Brookes
@75lb
Jun 09 2016 15:36
ok
hmm
Lloyd Brookes
@75lb
Jun 09 2016 15:42
i will attempt a quick fix, one second
krigton
@krigton_twitter
Jun 09 2016 15:42
thanks :D
Lloyd Brookes
@75lb
Jun 09 2016 15:48
ok, i have fixed it locally.. i will make a release for you
fixed in v1.2.6 - please update and try again
krigton
@krigton_twitter
Jun 09 2016 15:51
thank you
krigton
@krigton_twitter
Jun 09 2016 16:07
works, thank you!
Lloyd Brookes
@75lb
Jun 09 2016 16:08
great, thanks for getting in touch.
krigton
@krigton_twitter
Jun 09 2016 16:08
me too
krigton
@krigton_twitter
Jun 09 2016 17:08
just a quick question is it possible to load a configuration json like ws ---config=file_name.json ?
Lloyd Brookes
@75lb
Jun 09 2016 17:10
Yes
Look for "stored config" in the readme
krigton
@krigton_twitter
Jun 09 2016 17:11
oh great I will test it, it's is super super cause i can proxy to each environment by running the server with different configs
thanks very much
Lloyd Brookes
@75lb
Jun 09 2016 17:11
👍