Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
    FlyRad
    @FlyRad
    @Lexsus a view month ago I also tried to install linageOS on my Nexus 5x. I think there was/is a problem because of different filesystem, therefore it was not possible to install. In a short time I have to chage from Libre to Dexcom G5 because of skin irritation. Does that mean I also have to update with lineageOS for Pixel 2? I use the Combo.
    Mike
    @libxmike
    @Lexsus if you have Android 8.1 then it is not necessary, the reason for LOS is pairing with Combo, pairing is possible from 7.1 /LOS 14.1 or very old Android version 4.4 or somthing
    Lexsus
    @Lexsus
    With Android 8.1 xdrip+ working very bad with dexcom g5. I install LineAgeOs (for Pixel 2) on Nexus 5x and have not problems with G5.
    Mike
    @libxmike
    then stay with LOS 14.1 as 15.1 / 8.1 changed BT driver
    FlyRad
    @FlyRad
    @Lexsus what version of linageOS do you prefer for Nexus 5x with Dexcom 5 and Combo?
    Andy Rozman
    @andyrozman
    I am using Lineage 15.1 with Combo, and it works OK, but I don't have G5 (I use G4 with xBridge)
    cranetim
    @cranetim
    OK everyone I am about to close the loop tonight with my Nexus 5X, Dexcom G5, xDrip+ and Combo. Hooray! I only have one more question that I have not found directly referenced in all the reading I've consumed of late. After priming the transfer-set and inserting the head-set, instructions are to administer a 1 unit bolus to fill the empty head-set / cannula. Do I administer this from the pump, despite all warnings otherwise, from AAPS or is there some other technique for priming the head-set that will not affect my insulin totals in AAPS?
    cranetim
    @cranetim
    @Lexsus Knock on Wood. I've been using my Nexus 5X(Android8.1) with xDrip+ and G5 for three days now after pairing it with the Combo too. I guess i was prepared for problems but none yet. If my count is accurate xDrip has only missed about 4 pairings/BG's because i walked away without my phone for a few minutes. Although it did screwup the pairing process with Ruffy several times before i timed everything correctly in between the G5 connects..........
    Johannes Mockenhaupt
    @jotomo
    @cranetim Prime via AAPS. The record is then marked as Invalid and not added to IOB. That prime unit will be added to TDD, but that's negligible IMO. If you get in the habit of keeping the phone close by, that combination of hardware should run very smoothly. Congrats on closing the loop :-)
    cranetim
    @cranetim
    Thanks and yes I will keep it close!
    Andy Rozman
    @andyrozman
    does anybody know if changes made to BT in Android 8.1 that now allow us to use Combo, have been transitioned in Android 9 branch?
    cranetim
    @cranetim
    @andyrozman I read online about 4-5 days ago just before I closed loop that that was exactly the case. I bookmarked the site/forum to come back and read in detail the specifics and and it s gone now so..... Mysteriously I can't find anything detailing this. I'm curious though.....
    Mike
    @libxmike
    @andyrozman was this change for particular smartphone/chipset BT or general Android 8.1 change?
    I'm considering getting new phone in next 1-2 months and if 8.1 renders Combo communication useless then have to make sure I get one with 9.0 (well, for now I have two on my list, Galaxy S9+ and OnePlus 6T and bot have 9.0)
    Andy Rozman
    @andyrozman
    No. As I am told 8.1 is only version that works, without doing anything. I am just wondering if 9.x will also work, or did the change got "lost", if the new 9.x tree was created when 8.0 was released and later changes from 8.1 were NOT merged into 9.0, then we might have lost changes that are valuable to us. I have Galaxy S9 and battery is useless... I had to install Linegae 15.1 on it (Samsung doesn't want to give 8.1 out)... While S9+ has better battery it also has bigger display, which will negate everything good that would come from bigger battery... I was told that OnePlus has very good battery, so I ordered one (5T). Since it has 8.1 on it I hope it works OK, but as I was told OnyxOS might pose a problem with BT itself...
    Mike
    @libxmike
    @andyrozman OnyxOS is just overlay for base OS so if works on 8.1 should work, the only problem I may see with OnyxOS is aggressive battery management as they want to SHOW that they have good battery live, this is big problem on Huawei/Honor smartphones where they have very aggressive battery management in own OS/Overlay EMUI which can't be disabled even if rooted (maybe now, I sold my last year), I had Honor 9 and AAPS was killed EVEN when all battery management was disabled. Regarding Galaxy and battery, I had S8 for few months and battery live was good, xDrip+, AAPS and as my daily driver last maybe 36h BUT I rooted and debloated it, disabled all the Samsung crap apps, S9 should be even better in same scenario. I'm also concerned about OnePlus and possible BT problems (with 6/ 6T).
    Mike
    @libxmike
    problem I have with Lineage OS is that the native camera app is not ported to LOS and most of the time the LOS camera does not support dual camera, you have then just one and the quality is not as good as with native app, sometimes someone is porting the native cam app but you never know when and if at all
    Andy Rozman
    @andyrozman
    I don't use phone just for AAPS and stuff, this is my real phone... And while I am not heavy user battery still lasts about 10-12 hours, sometimes even less... And this is with Lineage... I hope OnePlus 5T will last little bit longer, I just hope I won;'t be forced to put LineageOS on it...
    infoneo
    @infoneo
    I have oneplus 6, dex g5, aaps dev branch. Paired on 8.1 (oxygen os) with ruffy "pairing" branch. Two days ago upgraded to android 9.0 (oxygen os). Since then haven't noticed any problems.
    Andy Rozman
    @andyrozman
    @infoneo But you did have problems with 8.1?
    infoneo
    @infoneo
    No, I haven't. Just pairing had to be done via "paring" branch.
    Andy Rozman
    @andyrozman
    pairing branch?
    Mike
    @libxmike
    there is ruffy version just for pairing
    @infoneo how is battery live on the 6? are you using xDrip+?
    infoneo
    @infoneo
    yes, xdrip+, battery is not bad. like on every smartphone it depends on individual habbits. battery stats estimates 1 day 14 hours(battery usage - navi: 8%; aaps: 3%; xdrp: 1%). Much better than my old sgs5 :)
    Andy Rozman
    @andyrozman
    @libxmike I did my pairing with standard version (I think)... I was actually using combo branch I think always... Would "pairing" branch be needed to 8.1?
    Mike
    @libxmike
    @andyrozman as far as I know if you paring with 7.1 or 8.1 you dont need "pairing" branch just the one you will use with AAPS
    I dont really remember in what case I use the "pairing" branch
    infoneo
    @infoneo
    @andyrozman in the wiki: https://androidaps.readthedocs.io/en/latest/EN/Configuration/Accu-Chek-Combo-Pump.html You can read: "Install ruffy and use it to pair the pump. If it doesn’t work after multiple attempts, switch to the pairing branch, pair the pump and then switch back the original branch." On the OxygenOS 8.1 and with basic ruffy, I have tried to pair many times - without success, when I switched to the "pairing" branch, I have paired with the first attempt. maybe it was coincidence :)
    Mike
    @libxmike
    @infoneo @andyrozman even with the "pairing" branch somtimes I needed multiple attempts
    Andy Rozman
    @andyrozman
    I had terible problems in begining with ruffy (a lot of crashes), so I started using the one from different repository (it was in one post in FB, where we talked about how much battery it used, that version was actually the most stable for me - I was using rooted Samsung A5 at the time)...
    Mike
    @libxmike
    ruffy uses less than 1% Battery in 4h, CPU total 1m33s and power use 2mAh (Moto G5)
    Andy Rozman
    @andyrozman
    I didn't switch because of battery, I switched because that other branch had some stability fixes, which actually helped great deal... After I started using that version, I rarelly had to restart my phone anymore (before that I had to restart my phone, every few days)...
    kallnap
    @kallnap
    Hi, I do have a question regarding the Android fix needed for Combo. Does anyone by chance know the tracking ID for the change, so it can be checked that it is integrated. I know that it is implemented, but I would like to have some trace that it can be confirmed.
    since it's a one line patch, you can also check the implementation file directly
    kallnap
    @kallnap
    @savek-cc thanks, do you also happen to have the link for Googleandroid itself?
    kallnap
    @kallnap
    danke
    cranetim
    @cranetim
    WOW! Energiser Ultimate Lithium just bit the dust after 46 days 11.5 hours
    That's not just a record for me on the combo, out likes almost triples the closest contender........
    out likes=out last
    Ok how about "it likes". Auto fill really can be irritating....
    th122
    @th122
    Wow. I'm getting a reliable 22 days from alkalines bought at a discounter (Aldi Nord)
    kallnap
    @kallnap
    quality of batteries varies quite a bit :-/
    Andy Rozman
    @andyrozman
    I usually use Energiser Lithium and they last about 40 days usually...but I had one that lasted over 50 days...
    Christoph Ke
    @chriske64
    Hello everyone, I've got a new phone, Sony Xperia XZ 2 compact (Android 9.0) and would like to pair with the combo
    I manage that the pump finds the phone and when I confirm the phone on the pump (after waiting for 5s), I never reach the point where I am supposed to enter the 10 digit security code
    has anyone experienced that problem before?