These are chat archives for APicogna/Projet_GeomPaint

19th
May 2014
QNTmetz2
@QNTmetz2
May 19 2014 11:16
getSize() est le noubeau nom de getNombre
de getNombrePoint() je n ai fait que traduire
getObject y était déjà et comme ça sonnait bien anglais je l'ai laissée comme ça
Je propose de garder pour l'instant ces deux méthodes, l'expérience prouvera si elles sont vraiment inutiles
je reconnais quand meme que getSize ressemble beaucoup à l'attribut length du tableau de points. On peut remplacer avantageusement tab.getSize() par tab.length (plus concis)
t-vilas
@t-vilas
May 19 2014 12:49
Non, je trouve ça bien d'avoir des méthodes spécifiques au modèle, même si dans le détail elles ne font que compter le nombre d'éléments d'un tableau.
Je ne remettais pas en cause l'utilité des fonctions, juste que le nom ne me paraissait pas suffisamment clair pour parler de lui-même. =)
QNTmetz2
@QNTmetz2
May 19 2014 17:57
Ah, je t'avais mal compris. Si tu vois un nom plus explicite que getSize tu peux modifier le nom de la méthode. Pour getObject je crois qu elle retourne le type de la figure (triangle, cercle etc. )
QNTmetz2
@QNTmetz2
May 19 2014 18:04
J'ai cloné le dépôt d'Alex ce midi(le nouveau dépôt bien sûr). J'ai vu qu'il a commencé à coder. Je m'y suis mis aussi. J'ai poussé ma classe MenuBar ce soir. Bien sûr il y a encore beaucoup à faire mais je crois que c'est un bon début.
QNTmetz2
@QNTmetz2
May 19 2014 18:12
Pensez-vous qu'on puisse se doter d'un attribut 'mode' (dans la classe Model par exemple) pour définir si l'utilisateur est en mode création (disposition de points mémo sur la zone dessin) ou en mode modif (autres actions). Vu qu'il n'y a que 2 modes (création et modification) un booléen devrait faire l'affaire.