Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
Carey Hoffman
@th3coop
haha ya, that happens
It gets a lot easier
Stuxnet233
@Stuxnet233
setup is hell for anything, but once its done, its smooth sailing
Carey Hoffman
@th3coop
Yep! until you have to do it again!
Stuxnet233
@Stuxnet233
oh god
Carey Hoffman
@th3coop
And then docker was born
Stuxnet233
@Stuxnet233
docker?
Carey Hoffman
@th3coop
oh...never mind. That was partly a joke.
Stuxnet233
@Stuxnet233
rip
Carey Hoffman
@th3coop
HA
Stuxnet233
@Stuxnet233
HA
Carey Hoffman
@th3coop
It's a tool that makes setting up environments a lot easier
But might not be what you need quite yet
Stuxnet233
@Stuxnet233
oh? sounds lovely, if i get to that point of my education
edubPDX
@edubPDX
I tried the GIT add-on and got the error "Not compatible with version of Komodo" I am currently using Komode IDE v12. I restarted Komodo and GIT is now available in my menu bar, but nothing works. Is the GIT add-on compatible with Komodo IDE v12?
Carey Hoffman
@th3coop
@edubPDX , just use Komodo IDE. It's free now and has Git integration by default.
LagLug
@laglugcom_twitter
how can i see methods or functions' return type in calltips autocomplete on codeintelligent ?? in some other editors we can see it
Carey Hoffman
@th3coop
@laglugcom_twitter could you provide a little more context? Language? Sample code? If the code has the right code comments then it should work.
Lucerberus
@Lucerberus
image.png
guys i have a little problem with komodo ide 12.01
@Lucerberus see my response to your forum post.
inspector71
@inspector71

Hi All

Incredibly relieved to have found Komodo again after searching for a better editor after my current editor, RJ TextEd, just could not get SFTP working for me

Not realising IDE was free, installed Edit. Looks like whilst some still work, all addons are not strictly compatible with Edit 12.
https://community.komodoide.com/packages/
Is there anywhere with compatible addons?
Also, anywhere explaining where Edit and / or IDE are in the process of determining if they will keep the XUL based addons or switch entirely to WebExtensions APIs?
Komodo might lose a lot of customization if WebExtensions are adopted however gain some performance if Quantum is integrated though I do not believe Mozilla claiming one has to equal the other (cannot have Quantum without WebExtensions)
inspector71
@inspector71
I would gladly attempt to update some of the addons if I can figure out the lay of the land with API support, so to speak. I have noted the "Addons (legacy) window but at a glance, unsure what API support context that suggests.
Carey Hoffman
@th3coop

Morning @inspector71 , thanks for your interest. All the addons, though they complain that they aren't compatible, should work fine. There are no new versions of the add ons than what Komodo finds on our server.

We are not planning on moving the Komodo code base away from XUL.

For editing add ons or writing your own, you can rely mostly on Komodo's SDK https://docs.activestate.com/komodo/12/sdk/api/. We wrap any Mozilla SDKs where needed/convenient.

srikanthvn99
@srikanthvn99
komodo ID fails to load , even after a fresh install, on mac, the initialising wheel keeps turning, has anyone have faced and solved this issue ?
Carey Hoffman
@th3coop
hi @srikanthvn99, you're looking for https://community.komodoide.com/t/fix-komodo-not-starting-on-big-sur/5429 most likely
Will Merrell
@wmerrell
I am using v12. I have used Komodo for years. Is there a way to select multiple lines of code by clicking and dragging in the gutter where the line numbers are? I am pretty sure I used to be able to do this but under v12 it is not enabled.
Carey Hoffman
@th3coop
@wmerrell this got removed (by accident I believe) in Komodo 11 when we implemented a bunch of new features in the editor gutter. Someone reported it here Komodo/KomodoEdit#3818
Will Merrell
@wmerrell
Thank you, Does anyone know if anyone is working on this? It is really annoying that this does not work. Is there a timeline to get it fixed?
inspector71
@inspector71

@th3coop Thanks for your thoughts. Alas Mozilla has broken links to the old "High / Low API" documentation mentioned on that SDK page.

The rest of that link looks choc a block with details though :)

Carey Hoffman
@th3coop
@wmerrell there is no plans to fix that issue. Looking at the code in the Komodo Edit repo should suffice to figure out how to patch the issue if you are really hampered.
@inspector71 thanks for the heads up. using the Komodo SDK should suffice though. We always wrapped any Mozilla SDKs I'm fairly certain.
inspector71
@inspector71
Thanks @th3coop
So you know if Komodo's sweet SFTP implementation is done by wrapping an existing Mozilla API?
inspector71
@inspector71
(Do you know ...)
Does Komodo IDE install 'over the top' of Komodo Edit ... use a Komodo Edit profile already established?
Carey Hoffman
@th3coop
Morning @inspector71. For SFTP, Komodo uses a Python library called Paramiko. And basically, yes, Komodo will import the most recent profile it finds when it starts up, whether the older profile is Komodo IDE or Edit.
inspector71
@inspector71
@th3coop Thank you! Much appreciated.
Sooo, does Mozilla natively support Python libraries or is that capability that has had to be baked into Mozilla's code by Komodo.
inspector71
@inspector71
BTW, not to sound patronizing or anything but Komodo Edit is such a good project. Everyone involves deserves genuinely heartfelt thank you from this black duck.
Looked into IDE but not really sure why an account with ActiveState is necessary. Seems dubious, especially as they now proclaim IDE to be 'free'.
Carey Hoffman
@th3coop
@inspector71, the thing that facilitates Python in Komodo's code base is called PyXPCOM. It allows certain parts of our JS and Python and the Mozilla C code to communicate between the languages. I don't believe Firefox includes it in there build but I think other programs built on Mozilla might have.
I don't find your sentiments patronizing (I think you might be using the wrong word?). Komodo Edit IS Komodo IDE just with less features. The Komodo developers and ActiveState maintain it.
The required login for Komodo IDE is for The Platform integration we added in one of the last releases.
It allows you to hook up an ActiveState Platform language install into your project.