Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
in order to see changes in the process instance your connector should provide an output variable name1 with a different value then the one provided as input
Elias Ricken de Medeiros
@erdemedeiros
@ladiesman2177 you can find some information about subprocesses here https://www.activiti.org/userguide/#bpmnSubprocessAndCallActivity
h928725721
@h928725721
Hello guys, I am useing Activiti6.0 and springboot. Now I have a question,how can I start transaction management of activiti?thanks before hand
ladiesman2177
@ladiesman2177
image.png
@erdemedeiros okay got it, thanks. Is anyone have experienced unauthorized after logging in to activiti modeler ? the project won't load at all
EdCurran
@EdCurran
Hey anybody have any advice on which HTTP client to use inside a connector? e.g. is there an HTTP client already used under the hood somewhere by activiti cloud / spring somewhere that it might make sense to piggy back off of? Considering using OkHttp.
saahilbhutwala
@saahilbhutwala
@erdemedeiros yes I got a sample cc working. So after further investigation, I figured out the issue and it was because the for my cloud connector, I am using a delayed message exchange to relay the status of a job, but turns out the plugin isn't enabled in my rabbitmq server on GKE. I was able to successfully run the connector locally on my localhost rabbitmq server after enabling the plugin. However I am unsure as to how I need to enable it for it to work on GKE since it is a third party plugin. Moreover, I cannot access the rabbitmq management page either when I go to rabbitmq.staging.XXX.XX.XX.XXX.nip.io and hence its making things even more difficult. if anyone knows how to enable the plugin on gke, that would solve my issue.
https://www.rabbitmq.com/community-plugins.html
https://github.com/rabbitmq/rabbitmq-delayed-message-exchange
davinzhang@outlook.com
@adminDavin
how should I add my mapper.xml to comandContext
saahilbhutwala
@saahilbhutwala
Hi, I'm following this guide to set up activiti using jx and GKE. Ive done this plenty a times now successfully however after I create the cluster and try to install jx, it fails because it fails to run the "helm init --service-account tiller" command. upon further investigation, It says that the "--service-account" flag was not found. which is an odd issue as I have the latest version of helm installed. Has anyone else encountered this issue/ can guide me on what I should do? https://activiti.gitbook.io/activiti-7-developers-guide/getting-started/getting-started-activiti-cloud/getting-started-activiti-cloud-jx
Marcello Teodori
@mteodori
quite odd, which version of helm are you using? I know 3 has been released and has no tiller
jgamboita
@jgamboita
image.png
Hi anyone i have error to create new project by activiti modeler, it dont load assistance, i get this error
jgamboita
@jgamboita
@almerico hi alex can youtell me how you fix that modeler can run?
Alex Merkulov
@almerico
hi @jgamboita
can you show the logs
Alex Merkulov
@almerico
and add more details
Alex Merkulov
@almerico
also question what helm chart version is used
ladiesman2177
@ladiesman2177
image.png
image.png
so i am having issue with the signal boundary event, after the flow arrived at service task do user 2, the process is suddenly complete, not moving to the signal boundary attached on it, the process instance is empty. So anyone knows this issue ? how can i fix this ? adding cancelActivity = false didn't help at all. Thanks before hand
Ephwurd
@Ephwurd
Hi all, I've been tasked with merging the data in the ACT_* tables between two separate databases. Just wondering has anyone attempted something like this before, and if there is a good resource to understand the data flow between these tables, as some of the table have no referential integrity constraints on them.
Daniel Muñoz
@daedmunoz

Hi everyone.

I'm not usure if this is the right place to do it but I want to report a bug.

I occurs when using PostgreSQL and the TTC example.

Short description:
The first time the application runs it fails to deploy the processes (due to missing columns in ACT_RE_DEPLOYMENT table).
If you restart the app, it updates the table (adds the columns PROJECT_RELEASEVERSION and VERSION_) and the processes are deployed correctly.

What is the correct way to fix this? I think that it could be fixed by adding those columns in org/activiti/db/create/activiti.postgres.create.engine.sql file.

Details:

Activiti version: 7.1.169 (Also happens in 7.1.0.M5)
PostgreSQL 11.3
Java 11

Steps to reproduce:
Clone the repo of the TTC English Campaign: repo: https://github.com/Activiti/ttc-rb-english-campaign
Connect to a PostgreSQL database
Run the application.

What should happen? Deploy the processes
What is happening? It throws the following error

org.apache.ibatis.exceptions.PersistenceException:
### Error updating database.  Cause: org.postgresql.util.PSQLException: ERROR: column "version_" of relation "act_re_deployment" does not exist
  Position: 103
### The error may involve org.activiti.engine.impl.persistence.entity.DeploymentEntityImpl.insertDeployment-Inline
### The error occurred while setting parameters
### SQL: insert into ACT_RE_DEPLOYMENT(ID_, NAME_, CATEGORY_, KEY_, TENANT_ID_, DEPLOY_TIME_, ENGINE_VERSION_, VERSION_, PROJECT_RELEASE_VERSION_)     values(?, ?, ?, ?, ?, ?, ?, ?, ?)
### Cause: org.postgresql.util.PSQLException: ERROR: column "version_" of relation "act_re_deployment" does not exist
  Position: 103
        at org.apache.ibatis.exceptions.ExceptionFactory.wrapException(ExceptionFactory.java:30)
        at org.apache.ibatis.session.defaults.DefaultSqlSession.update(DefaultSqlSession.java:200)
        at org.apache.ibatis.session.defaults.DefaultSqlSession.insert(DefaultSqlSession.java:185)
        at org.activiti.engine.impl.db.DbSqlSession.flushRegularInsert(DbSqlSession.java:787)
        at org.activiti.engine.impl.db.DbSqlSession.flushInsertEntities(DbSqlSession.java:662)
        at org.activiti.engine.impl.db.DbSqlSession.flushInserts(DbSqlSession.java:642)
        at org.activiti.engine.impl.db.DbSqlSession.flush(DbSqlSession.java:525)
        at org.activiti.engine.impl.interceptor.CommandContext.flushSessions(CommandContext.java:237)
        at org.activiti.engine.impl.interceptor.CommandContext.close(CommandContext.java:102)
        at org.activiti.engine.impl.interceptor.CommandContextInterceptor.execute(CommandContextInterceptor.java:68)
        at org.activiti.spring.SpringTransactionInterceptor$1.doInTransaction(SpringTransactionInterceptor.java:47)
        at org.springframework.transaction.support.TransactionTemplate.execute(TransactionTemplate.java:140)
        at org.activiti.spring.SpringTransactionInterceptor.execute(SpringTransactionInterceptor.java:45)
        at org.activiti.engine.impl.interceptor.LogInterceptor.execute(LogInterceptor.java:29)
        at org.activiti.engine.impl.cfg.CommandExecutorImpl.execute(CommandExecutorImpl.java:44)
        at org.activiti.engine.impl.cfg.CommandExecutorImpl.execute(CommandExecutorImpl.java:39)
        at org.activiti.engine.impl.RepositoryServiceImpl.deploy(RepositoryServiceImpl.java:82)
        at org.activiti.engine.impl.repository.DeploymentBuilderImpl.deploy(DeploymentBuilderImpl.java:233)
        at org.activiti.spring.autodeployment.NeverFailAutoDeploymentStrategy.deployResources(NeverFailAutoDeploymentStrategy.java:46)
        at org.activiti.spring.SpringProcessEngineConfiguration.autoDeployResources(SpringProcessEngineConfiguration.java:128)
        at org.activiti.spring.SpringProcessEngineConfiguration.buildProcessEngine(SpringProcessEngineConfiguration.java:81)
        at org.activiti.spring.ProcessEngineFactoryBean.getObject(ProcessEngineFactoryBean.java:57)
mzal123
@mzal123
hi,
I want to know if activiti7 can jump to the task node.
Miguel Ruiz
@miguelruizdev
Hi @daedmunoz , I managed to reproduce your issue and I'm working on it
This is an old problem we believed to be solved
Elias Ricken de Medeiros
@erdemedeiros
@daedmunoz thank your for letting us know. I didn’t realeased it because kubernetes is automatically restarting the application. Do you mind to report the issue here? https://github.com/Activiti/Activiti/issues/new
@mzal123, as far as I know activiti can only follow the transitions that were defined in workflow, you cannot jump to task if your model does not allow it.
Miguel Ruiz
@miguelruizdev
@daedmunoz no need to create an issue, I already created one: Activiti/Activiti#3015
the PR fixing the problem: Activiti/Activiti#3014
Daniel Muñoz
@daedmunoz
@miguelruizdev thanks!
abstrack
@abstrack
Does activiti 7 support migration from 6.0.0.4 DB? In my case it throws Unknown Version Exception
Elias Ricken de Medeiros
@erdemedeiros
Hi @abstrack
currently activiti 7 doesn’t provide out of the migration from version 6.x
abstrack
@abstrack
thanks, is it planned in the future releases?
Elias Ricken de Medeiros
@erdemedeiros
no, it’s not planed for now. Note that his might be a complex task in the case of a cloud deployment (with query and audit service), as it would be necessary to migrate what is the history tables there
abstrack
@abstrack
I need only to migrate activiti core
thaihoc
@thaihoc
image.png
Hi every one, i try to install activiti-cloud-example by using docker compose , but i have got an error
thaihoc
@thaihoc
what will I do to fix this problem?
Alex Merkulov
@almerico
@thaihoc looks like bug possibly something with network need to investigate
thaihoc
@thaihoc
@almerico might I set $DOCKER_IP not right. I used gateway ip of docker network that was created by docker compose in default.
ravindran78511
@ravindran78511
Hi am getting started with Activiti cloud docker image. However encountering error.... on "make modeler" Pulling from library/nginx
ERROR: no matching manifest for windows/amd64 10.0.18362 in the manifest list entries the Docker image started
ravindran78511
@ravindran78511
resolved by starting docker in experimentation
carbon-60
@carbon-60
@jgamboita Hi, Did you figure out why you've got the modeler error and how to fix it? I am new to Activiti. I tried to run the activiti-cloud-examples and got the exactly the same error. So I am wondering how I can get pass the error? Thanks, Joey
@ravindran78511 FYI, I was able to resolve that error by switching to linux container as well.
Jeevamathaiyan
@Jeevamathaiyan
Hi, i am new to activiti
Can anyone help me how to download activiti7 war file?
carbon-60
@carbon-60
@Jeevamathaiyan There seem to be a bug in Activiti web site that does not allow one to download activiti7, but you can go to https://github.com/Activiti/Activiti/releases/ to download.
Jeevamathaiyan
@Jeevamathaiyan
@carbon-60 Thanks Carbon, i have downloaded Activiti-7.1.143 this version in the above mentioned link, but i can't able to see the war folder. I have one query, in activiti7 having war folder?
carbon-60
@carbon-60
@Jeevamathaiyan I do not see it either. I suspect that you will have to build it from the downloaded source file. But again, I do not see an instruction on how to build from the source files either.