Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Jan 31 2019 21:04
    joerghoh commented #1732
  • Jan 31 2019 21:02
    joerghoh commented #1732
  • Jan 31 2019 19:40
  • Jan 31 2019 01:58
    badvision review_requested #1738
  • Jan 31 2019 01:58
    update-changelog[bot] commented #1738
  • Jan 31 2019 01:58
    badvision opened #1738
  • Jan 31 2019 01:54

    badvision on Renovator_bugfixes

    #1737 - Added additional asset … (compare)

  • Jan 31 2019 01:43
    badvision opened #1737
  • Jan 30 2019 15:26
    kwin opened #1736
  • Jan 30 2019 15:14
    kwin synchronize #1735
  • Jan 30 2019 15:10
    update-changelog[bot] commented #1735
  • Jan 30 2019 15:10
    kwin opened #1735
  • Jan 30 2019 14:00
    kwin edited #1733
  • Jan 30 2019 12:48
    mauryamanoj opened #1734
  • Jan 30 2019 12:31
    kwin opened #1733
  • Jan 30 2019 00:35
    davidjgonzalez commented #1715
  • Jan 29 2019 23:56
    badvision commented #1715
  • Jan 29 2019 21:55
    badvision milestoned #1732
  • Jan 29 2019 21:55
    badvision labeled #1732
  • Jan 29 2019 21:55
    badvision labeled #1732
nishi4009
@nishi4009
tried importing ACS AEM commons 2.4.2 by including in pom.xml for content package as well as tried installing through packMgr, though not receiving any error for both scenarios, not able to see bundle in /system/console. Tried with AEM restart as well with no luck.
Wim Symons
@wimsymons
Any pauseInstallation nodes below /system?
nishi4009
@nishi4009
in web console? or where exactly to check for it?
Wim Symons
@wimsymons
RJHBookLinux
@RJHBookLinux
What's the turnaround time before ACS Commons a release makes its way to adobe public repo? Looks like 3.10.0 isn't out there yet, just curious.
Sagar Mandal
@sagarmandal
Same question as @RJHBookLinux. Which repository to use to add 3.10.0 bundle as dependency in maven POM, until it is available in adobe public repo?
Justin Edelson
@justinedelson
we're having some unfortunately persistent issues getting 3.10.0 promoted. you can use https://bintray.com/acs/releases (click the Set Me Up link for details) until that is resolved.
david g.
@davidjgonzalez
@RJHBookLinux @sagarmandal - the ACS Commons home page has been udpated w an Alert addressing this (and link to Bintray) … sorry about that. Hopefully itll get resolved soon, but a bit out of our control :(
Kristopher Wong
@kristopherwong_twitter
Has anyone run across any tools to check the cacheability of pages/assets on 6.3? I generally run a Jmeter + sitemap to generate all pages and embedded assets and monitor the log/access to confirm cacheability but If there is an easier way... Let me know
CT1012
@CT1012
How to support AEM 5.6 acs-commons widgets for 6.3 classic UI? I found some code for sightly/touch UI... Is there any way i could use it for classic UI?
RJHBookLinux
@RJHBookLinux
Thanks for the update @davidjgonzalez no worries :)
Stuart Schmukler
@sasconsul
Has anyone used the AEM ACS Commons Email API in AEM 6.3?
Anuj Gupta
@atrangi_bakchod_twitter
Hey Everyone ..!! I am getting below error , Can anyone help me this
WARN [127.0.0.1 [1504325285879] GET /etc/replication/agents.author/publish2eucentral1/jcr:content.queue.json HTTP/1.1] com.adobe.acs.commons.wcm.notifications.impl.SystemNotificationsImpl Trying to get a invalid System Notification page at [ /etc/acs-commons/notifications/rep:policy ]
JoeriPeeters
@inventj
Anuj upgrade to 3.10.
Anuj Gupta
@atrangi_bakchod_twitter
thanks
(y)
Justin Edelson
@justinedelson
I think that was actually fixed in 3.5.0, but it looks like I didn't create a specific issue for it. It was fixed as part of the introduction of Service Users.
but yeah, upgrading to 3.10.0 would be better than 3.5.0 :)
Stuart Schmukler
@sasconsul
I am getting an NPE when trying to use EmailService with 3.10 Here is the the code
java.lang.NullPointerException
    at com.aaaa.ggggg.site.utils.ACSEmailUtil.sendApplicationMail(ACSEmailUtil.java:39)


public class ACSEmailUtil {

    @Reference
    private  EmailService emailService;

    private static final Logger LOG = LoggerFactory.getLogger(ACSEmailUtil.class);

    private static final String templatePath = "/etc/notications/aaa-ggggg/application-template.html";

    public Boolean sendApplicationMail(Map<String, DataSource> attachments,
                                       Map<String, String> emailParams, List<String> recipients) {

        List<String> failureList = emailService.sendEmail(templatePath, emailParams, attachments,
                    recipients.toArray(new String[recipients.size()]));

        if (!failureList.isEmpty()) {
            LOG.error("sendApplicationMail: failed to send to: {} ", failureList);
            return false;
        }

        return true;
    }
}
Justin Edelson
@justinedelson
@sasconsul which is line 39?
Justin Edelson
@justinedelson
and how are you getting an instance of ACSEmailUtil? It looks like you are not using Declarative Services and just invoking new ACSEmailUtil() in which case the @Reference annotation isn't operative and thus that instance variable is null.
Stuart Schmukler
@sasconsul
@justinedelson line 39 is the one with '''List<String> failureList = emailService ...'''
So, I should mark ACSEmailUtil as a Service and use a Reference annotation to access it?
Justin Edelson
@justinedelson
@sasconsul if you want @Reference to inject something, the class has to have @Component on it and clients of it need to access the DS-managed instance
Stuart Schmukler
@sasconsul
@justinedelson Tahnk-you that got me past the problem.
Stuart Schmukler
@sasconsul

It is clear that InternetAddress is failing to validation my addresses, but I have no idea why. [The domain exists.] I keep getting :

19.09.2017 17:30:35.863 *ERROR* [0:0:0:0:0:0:0:1 [1505867435788] POST /zzz/xxxx/ HTTP/1.1] com.adobe.acs.commons.email.impl.EmailServiceImpl Error sending email to [ ggggggggggggggggggggggggggggg@xxxxx.com ]
org.apache.commons.mail.EmailException: Missing final '@domain'
    at org.apache.commons.mail.Email.createInternetAddress(Email.java:605)
    at org.apache.commons.mail.Email.addCc(Email.java:806)
    at org.apache.commons.mail.Email.addCc(Email.java:789)
    at org.apache.commons.mail.Email.addCc(Email.java:769)
    at com.day.cq.commons.mail.MailTemplate.getEmail(MailTemplate.java:170)
    at com.adobe.acs.commons.email.impl.EmailServiceImpl.getEmail(EmailServiceImpl.java:233)
    at com.adobe.acs.commons.email.impl.EmailServiceImpl.sendEmail(EmailServiceImpl.java:184)
    at com.adobe.acs.commons.email.impl.EmailServiceImpl.sendEmail(EmailServiceImpl.java:220)

The bottom of the stacktrace has a clue:

Caused by: javax.mail.internet.AddressException: Missing final '@domain'
    at javax.mail.internet.InternetAddress.checkAddress(InternetAddress.java:1236)
    at javax.mail.internet.InternetAddress.validate(InternetAddress.java:1129)
    at org.apache.commons.mail.Email.createInternetAddress(Email.java:601)
    ... 119 common frames omitted

Trying to set a set a breakpoint fails to stop the program in AEM.

Any ideas?

Stuart Schmukler
@sasconsul
I have checked the InternetAddresses being sent in, they are fine.
Vaibhav Sharma
@vaibhav6451956
Hi @justinedelson @davidjgonzalez I recently cloned the acs commons repo and was following the video for setting up to start contributing..but on maven build of parent project few goals are getting failed...do I need to make any changes to my settings.xml as well?
Vaibhav Sharma
@vaibhav6451956
It worked...had to add Nexus Public repo link as well to my settings.xml...i just had the adobe internal artifactory links earlier..
Stuart Schmukler
@sasconsul
Anyine know where the XML Schema for AEM are located? I keep getting error messages from Intellij when committing .content.xml files. Intellij is looking for the XML schema xmlns:cq="http://www.day.com/jcr/cq/1.0" xmlns:jcr="http://www.jcp.org/jcr/1.0" xmlns:nt="http://www.jcp.org/jcr/nt/1.0"
sneharora
@sneharora
Hi, I was looking for option to bulk replicate assets from author to publish instance and came across this link https://adobe-consulting-services.github.io/acs-aem-commons/features/workflow-processes/content-traversing-replicate-with-options/index.html
Can somebody guide me on the steps to make this available on my AEM instance.I installed the package acs-aem-commons-content-3.4.0.zip but not sure where this UI will be available.
mahicks11
@mahicks11
Hey, we're leveraging the versioned clientlib tool which is working fine with our clientlibs, but I also wanted to apply this to the ContextHub kernel clientlib that gets loaded from /etc/cloudsettings/default/contexthub.kernel.js. Any ideas or suggestions on how to achieve this?
Justin Edelson
@justinedelson
@sneharora per the documentation, you have to use that in a workflow.
@mahicks11 /etc/cloudsettings/default/contexthub.kernel.js isn't a clientlibrary, so you can't use the VersionedClientLibs rewriter with it
mahicks11
@mahicks11
@justinedelson ok, thnx
Gonzalo Calandria
@GonzaloCalandria
Morning everyone... I need to add some properties to the lucene index and I'm a little bit lost on how should I do it with the ensure oak index feature.. can anyone help me to understand it a little bit more?
Rohn
@Rohnjose__twitter
Hello - How can we let Dispatcher respond to the HEAD requests coming in, instead of those requests to go to Publishers? We have tried enabling the /headers in the dispatcher configuration and could see .h file created, but still when a HEAD request comes in, its routed to Publisher
Sander van Beek
@svbeek
Hi all
Im seeing the following error in my logs after upgrading to AEM 6.2 + sp1 and ACS commons 3.9.0
com.day.cq.commons.inherit.InheritanceValueMap cannot be resolved to a type
seems to come from the 404 error handler
that class is available however, and exported by the cq commons bundle
anyone got a clue what could be wrong?
Dominik Süß
@d_suess_twitter
W/o looking into the concrete case that might be a timing issue leading to a cached resolution issue in the FSClassloader cache
Search in filesystem for the compiled jsp (corresponding class file reporting the issue) , delete the compiled classes in this bundle (some classes folder a bit deeper under launchpad )
Sander van Beek
@svbeek
allright, ill try that
Dominik Süß
@d_suess_twitter
And restart the fs classloader bundle (and maybe also the jsp scripting support)
Or just restart instance ;)