Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    Aaron France
    @AeroNotix
    I'm not sure there are any at this moment in time
    It's a very small codebase
    @gabriel-laddel you did, you know, read the code, right?
    Gabriel Laddel
    @gabriel-laddel
    I have not.
    Aaron France
    @AeroNotix
    Perhaps that would be better before asking me that.
    Gabriel Laddel
    @gabriel-laddel
    I'm working under the assumption that you've wrapped the C/C++ api with CL
    Aaron France
    @AeroNotix
    Right
    But there's more to it than that
    Gabriel Laddel
    @gabriel-laddel
    such as?
    Aaron France
    @AeroNotix
    the defcommand system, for example. It allows for registering functions against keystrokes
    Gabriel Laddel
    @gabriel-laddel
    Oy.
    That is nifty.
    Alrighty, I'm convinced.
    Downloading & reading today - I've used conkeror, but this sounds much better.
    (I should say, conkeror that has a parenscript repl)
    Aaron France
    @AeroNotix
    I wouldn't say it's as polished as conkeror yet though, it's still a young project
    polished as in all the bells and whistles conkeror has, a nice completion system for commands would be nice.
    I was toying with that
    but didn't complete it
    and then $DAY_JOB decided to suck up all my time.
    Gabriel Laddel
    @gabriel-laddel
    Yeah, those suck. You could always quit.
    @AeroNotix you're (probably) a smart guy, check out #bitcoin-assets sometime
    Aaron France
    @AeroNotix
    @gabriel-laddel not my thing
    Gabriel Laddel
    @gabriel-laddel
    the author of loper-os.org and some other common lispers hang out there.
    it is an interesting place.
    Aaron France
    @AeroNotix
    @/all AeroNotix/lispkit#47
    vindarel
    @vindarel
    Hello lispkiters, is someone here for installation help ?
    vindarel
    @vindarel
    i installed the dependencies, i can load stuff within quickload, but I don't find how to load lispkit. Does the "QUICKLISP_HOME" I see in the readme really mean something ? I run the sbcl command from a directory which contains the three cloned projects. Sbcl outputs " System "lispkit" not found". Am I missing smthg ? Thx ! & see you later !
    Aaron France
    @AeroNotix
    QUICKLISP_HOME is just intended to be wherever your quicklisp is installed. I'll make that clearer in the README.
    usually it's just set to ~/.quicklisp
    @vindarel which commands exactly are you running?
    vindarel
    @vindarel
    Oh allright, I found it :) I didn't understand because QUICKLISP_HOME isn't an environment variable for me. With a call to locate I found the ~/quicklisp directory. Now everything is installing… but I'm blocked because it wants libwebkit2gtk-4.0 and I found 3.0.
    Aaron France
    @AeroNotix
    @vindarel ubuntu?
    vindarel
    @vindarel
    The current Mint Debian 201403 (based on testing).
    Aaron France
    @AeroNotix
    @vindarel which libwebkitgtk packages do you have installed?
    vindarel
    @vindarel
    I installed the one I found, as I said the 3.0, precisely libwebkit2gtk-3.0-25 and libwebkit2gtk-3.0-dev.
    I give you the error message:
    To load "lispkit":
      Load 1 ASDF system:
        lispkit
    ; Loading "lispkit"
    .........................
    debugger invoked on a LOAD-FOREIGN-LIBRARY-ERROR in thread
    #<THREAD "main thread" RUNNING {AC1AA91}>:
      Unable to load any of the alternatives:
       ("libwebkit2gtk-4.0.so")
    vindarel
    @vindarel
    and I don't understand. Given the code in lispkit/cl-webkit/webkit2/webkit2.init.lisp, it should try to load either version 4.0 or 3.0:
    (define-foreign-library libwebkit2
        (:unix (:or
                    "libwebkit2gtk-3.0.so.25.10.9" ; webkit2gtk-2.4.6
                "libwebkit2gtk-4.0.so"         ; webkit2gtk-2.6.4
                    "libwebkit2gtk-3.0.so.25.10.8" ; webkit2gtk-2.4.5
                    "libwebkit2gtk-3.0.so.25.10.7" ; webkit2gtk-2.4.4
                    "libwebkit2gtk-3.0.so.25")))
    vindarel
    @vindarel
    I tried to put all those choices in cl-webkit/dom/init.lisp where only 4.0 is in the list, same error.
    Aaron France
    @AeroNotix
    @vindarel Which specific packages have you installed for Ubuntu?
    vindarel
    @vindarel
    I'm not on Ubuntu but on Mint with the Debian testing base and I've installed quicklisp and I followed the (previous) readme with the 3 git clones. I didn't install something else since I already had sbcl and libwebkit2gtk-3.0-25 and no more recent version. Hope that answers your question.
    Aaron France
    @AeroNotix
    @vindarel try building with the new build system
    vindarel
    @vindarel
    After a git pull, I run make and I get no rule to build the target $(APP_OUT) (roughly translated to english).
    Aaron France
    @AeroNotix
    @vindarel https://gist.github.com/AeroNotix/abef1129b631c61e4289 Fresh clone, works for me.
    vindarel
    @vindarel
    So stange ! It really doesn't work with a fresh clone ! Will try to investigate later and at least try on another machine when I can.
    vindarel
    @vindarel
    I installed it on a fresh debian successfully (I had to install liwebkitgtk 4 even if I had the 3), but couldn't test much (in a vbox and lispkit.org is down, so no documentation). The install procedure can hardly be simpler :)
    Aaron France
    @AeroNotix
    lispkit.org has nothing on it yet, eventually will. Glad it's working for you! :)
    @vindarel enjoy
    Victory Omole
    @vtomole
    Hey I'm having trouble build lisp kit, I'm getting:unhandled condition in --disable-debugger mode, quitting
    ;
    ; compilation unit aborted
    ; caught 2 fatal ERROR conditions
    Makefile:80: recipe for target 'deps' failed
    make: * [deps] Error 1