Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Sep 09 2019 16:25
    eromano milestoned #5057
  • Sep 09 2019 14:43
    eromano milestoned #5061
  • Sep 09 2019 11:36
    dhrn closed #5019
  • Sep 08 2019 08:17
    pionnegru milestoned #5063
  • Sep 06 2019 14:16
    aitseitz edited #5062
  • Sep 06 2019 14:11
    aitseitz opened #5062
  • Sep 05 2019 12:27
    dhrn milestoned #5058
  • Sep 05 2019 06:55
    dhrn milestoned #5054
  • Sep 04 2019 19:14
    eromano milestoned #5044
  • Sep 04 2019 16:48
    eromano milestoned #5055
  • Sep 04 2019 16:36
    DenysVuika labeled #5050
  • Sep 04 2019 13:57
    eromano milestoned #5030
  • Sep 04 2019 07:36
    pionnegru milestoned #5051
  • Sep 04 2019 06:31
    loictrichaud opened #5050
  • Sep 03 2019 14:11
    eromano milestoned #5046
  • Sep 03 2019 10:10
    eromano milestoned #4996
  • Sep 03 2019 07:56
    pionnegru milestoned #5045
  • Sep 02 2019 06:48
    pionnegru milestoned #5040
  • Sep 01 2019 09:03
    eromano milestoned #415
  • Aug 31 2019 03:24
    silverskyvicto edited #5039
fcassomdsd
@fcassomdsd
Oops, sorry. The screenshot was meant to be a reply to the previous message.
Eugenio Romano
@eromano
I think you need to check if you have CORS issues
Digital Catalyst
@digcat
hi @eromano I was looking at ticket Alfresco/alfresco-content-app#1182 which you closed recently, but I cant reopen
I added to the ticket about the continuing problem
Eugenio Romano
@eromano
Not sure I got the behaviour you see now, can you explain more or attach a video?
Digital Catalyst
@digcat
ok will do
Digital Catalyst
@digcat
hi @eromano hope this shows the issue flicking between Personal Files and File Libraries seem to consistently show the issue where the "This Folder is Empty"
Digital Catalyst
@digcat
have loaded a zipped up avi to the git issue, zipped cos the 36mb avi is too big for github
1 reply
aayush89890
@aayush89890
Hi can anybody tell me how can I apply search filter in adf-tasklist?
aayush89890
@aayush89890
hi @stjepanantolovic can you help me to apply the search filter in adf-tasklist ? I can see in one of your screenshot that it is there.
jackom83
@jackom83
Hello guys, i saw that login component of ADF can login (SSO) via oauth implicit flow, anyone know if It also use "response_mode=form_post" to improve security. Otherwise may be used pkce-enhanced authorization code flow?
2 replies
Juan Estrella
@JuanEstrella_gitlab
Hello everyone Juan here. Just started working with ADF recently. I am having a small issue with the ADF SearchService, trying to get nodes with a given aspect. I tested the FTS query using JS Console and it works. Code snippet is on https://gist.github.com/TheJuanAndOnly99/9f55ebc9c5c92378e38d1337b6b191f7, do you see anything wrong? Any help would be appreciated, thank you!
4 replies
amthmsExprn
@amthmsExprn
I have noticed that in ADF, APS Forms with a dropdown for a required field will display the correct default value configured in the APS Form Editor, but the value will not be set. When a user goes to complete/submit the form ADF will catch the error about a required field and report a generic error message that the task can not be completed. Using dev tools you can see APS complain about a specific variable. In APS, the default is set and the user is able to complete the task. The workaround has been defaults in a script task for the process. The issue to relate to ADF-5013, but was wondering if others had seen this?
For APS forms with display-values/read-only dynamic tables, ADF appears to allow some level of editing, but the variables are not updated when the task is completed. Has anyone seen this?
1 reply
VijayVelu-ClearCadence
@VijayVelu-ClearCadence
Hi, we have an ADF custom App that was designed to work with ACS and APS enterprise versions- can it be made to work against either or both Alfresco and Activiti Community versions?
1 reply
Marc Solé
@marc1s_gitlab
Hello world, Marc here. I am working with ADF and I am tying to add an aspect to a given node (folder). I think that the nodes API service is a good approach to do this but I am not able to find a solution. I have tried with the createNodeMetadata method but maybe i am missing something in the syntax. Code snippet is on https://gitlab.com/session-tech/nagrup/-/snippets/2122012 (lines 20 and 21), do you see anything wrong? Any help would be appreciated, thank you!
2 replies
Zain ul Abideen
@zain-abideen-87

HI All

I'm using AuthGuardBpm. Whenever I open a route containing query params separated by '&', they are lost when 'redirectUrl' is created. Any idea how I can handle this ?

vpasudo
@vpasudo
Hi @zain-abideen-87 : you want to mess with queryParamsHandling https://angular.io/api/router/UrlCreationOptions#queryParamsHandling
Zain ul Abideen
@zain-abideen-87

@vpasudo that's the case when we are redirecting in our custom code. I'm facing error when user is not logged in and AuthGuardBpm redirects to login url. AuthGuardBpm service creates a redirectUrl query param with calling url as it's value. The problem is if calling url has query params, those params are lost

e.g. I'm trying to call "/profile/123?pdf=abc.pdf". Now if the user is not loggedin, it will become following:

/login?redirectUrl=%2fprofile%2f123

you will notice that query param (pdf) is lost.

vpasudo
@vpasudo
in this case you might have to create your own guard and manage your queryParams here
Zain ul Abideen
@zain-abideen-87
Thanks a lot
umapathi
@umapathi20_gitlab
How to drag and drop the files from Alfresco adf-document-list to primeNg tree. Please let me know if anybody have an idea
1 reply
JunHog
@JunHog
Hello everyone, I'm trying to add as a content-action a button to UPDATE a file, forcing the version to be minor. So I don't want to use the "adf-upload-button" but the "adf-upload-version-button" probably, to skip the part where the user is supposed to chose if it's a major or minor update. What I want is just to let the user choose a file on its computer, and then update the node from where the content action was launched with the new content, any advice for this? I can't seem to make anything work, feel like I'm missing something. Best regards
Eugenio Romano
@eromano
Hi guys, Hyland Alfresco is Hiring new people in EMEA this means: Poland, UK, Germany, France, and Italy for us. You can visit the links below for more details:
Backend: https://careers-hyland.icims.com/jobs/6994/backend-developer/job?mode=view
Frontend: https://careers-hyland.icims.com/jobs/7315/frontend-developer/job?mode=view
QA: https://careers-hyland.icims.com/jobs/7316/test-engineer/job?mode=view
miguel-galan
@miguel-galan
Hi there,
We upgraded from version 2.4 to 4.3 (following all the intermediate steps)
All seem to work fine, except the SAVE button on the APS forms. The button stays disabled unless all mandatory fields are completed.
Is there anything we need to do to enable the SAVE button regardless of the fields? thanks (APS version: 1.9.x)
14 replies
miguel-galan
@miguel-galan
image.png
Uros Vukasinovic
@uvukasinovic
I want to integrate @alfresco/adf-process-services with my angular library
I have installed Angular 10, because of the compatibility with adf-process-services
When I try npm install @alfresco/adf-process-services
there are some errors/conflicts between versions
What version of Angular do you suggest to use if I want to integrate @alfresco/adf-process-services?
6 replies
luiscolorado
@luiscolorado

I want to integrate @alfresco/adf-process-services with my angular library

I had the same problem. The issue is not your version of Angular (I tried several -- please see the comments from April 2 to 12 above). There is a conflict in the packaging itself, so I submitted a problem report in the project: Alfresco/alfresco-ng2-components#6912

You may want to add a comment to that issue, maybe that will help to get a response or a solution
alfsender
@alfsender
Hi, I am using node version v10.15.1. I checked out master branch of https://github.com/Alfresco/alfresco-ng2-components.git and executed npm install. now when I try to start the app using npm start I am seeing error as FATAL ERROR: Ineffective mark-compacts near heap limit Allocation failed - JavaScript heap out of memory. I tried npm --max-old-space-size=8192 start as well but still facing same issue..
6 replies
m3io
@m3io

Hi everyone, there is a way that ADF 4.4 / 4.5 can run with node16/npm7 ?
i've tried to update, but all package.json dependencies fall apart when i run "npm install"

Thanks in advance

1 reply
m3io
@m3io
npmError.png
after i updated node-sass
Eugenio Romano
@eromano
have you update angular to 12?
Arik Sidney Guggenheim
@ariksidney
Hi there! I have a question regardin the default locale. Per documentation (https://www.alfresco.com/abn/adf/docs/user-guide/internationalization/) the locale language should be saved to the user preferences once it's detected. However I cannot see the preference in the local storage, it just appears once a locale is set with the language picker. Is there something else I have to do?
4 replies
Tim Donovan
@tdonovancsra
@eromano is your jira no longer available to view in read only? I was looking for status on this issue
https://alfresco.atlassian.net/browse/ADF-5373
10 replies
Saikiran Dhanekula
@dhanekula_sai_twitter
Hi everyone, can anyone help me with the node content PUT API request body? contentBodyUpdate requires binary content and I tried to convert image to binary string and send it through the API but in the end the content gets corrupted. Thanks in advance!
Here is the screenshot of requestBody of Update node content Rest API
image.png
Sanjay Bandhniya
@SanjayBandhniya
Hi
I am using ADF+APS for my application. I want to know what is the token expire time for adf?
2 replies
umapathi
@umapathi20_gitlab
I need one clarification on whether the selectAll checkbox will be displayed for when using [display]="gallery"? Please clarify
Massimo Loporchio
@massimolopo_twitter
Hi, have any of you faced a problem with saving the numeric value "0" in a field of a dynamic table?
1 reply
Digcat
@digitalcatalyst_gitlab
hi @eromano was looking at jira, https://alfresco.atlassian.net/browse/ACA-1918 noticed it was completed, but this appears to be the same issue as reported Alfresco/alfresco-content-app#1182 which is still showing as shown in the videos on the github ticket ?