These are chat archives for AngularClass/NG6-starter

30th
May 2016
denlab
@denlabs
May 30 2016 21:11

Hey all after cloning ng6 and installing deps, I'm seeing this error trying to run any gulp tasks:
'''
ERROR in ./~/css-loader!./~/stylus-loader!./client/app/app.styl
Module build failed: TypeError: /Users/dl/dev/ng6/client/app/app.styl:4:1
1| .app
2| height 100%
3| background-color $lightBgColor
4|
------^

Path must be a string. Received undefined
'''

any ideas? never used webpack/stylus before, so a bit lost here...

Sergey Protko
@fesor
May 30 2016 21:19
This is strange
denlab
@denlabs
May 30 2016 22:01
ah, it looks like stylus-loader 1.x.x not working well with stylus 0.54, bumping stylus-loader to ^2.0.0 seems to fix it
Sergey Protko
@fesor
May 30 2016 22:03
@denlabs good to know. Probably I should fix dependency issue. Thanks.
denlab
@denlabs
May 30 2016 22:06
@fesor np, but fyi, I included a dep for stylus in my package.json too "stylus": "^0.54.5",