These are chat archives for AngularClass/angular2-webpack-starter

31st
Jul 2016
Enzo Notario
@enzonotario
Jul 31 2016 03:22
Hi!! I have a problem when I try to run 'npm run server'... the log is:
0 info it worked if it ends with ok
1 verbose cli [ '/usr/bin/nodejs', '/usr/local/bin/npm', 'run', 'server' ]
2 info using npm@3.10.5
3 info using node@v5.12.0
4 verbose run-script [ 'preserver', 'server', 'postserver' ]
5 info lifecycle angular2-webpack-starter@5.0.5~preserver: angular2-webpack-starter@5.0.5
6 silly lifecycle angular2-webpack-starter@5.0.5~preserver: no script for preserver, continuing
7 info lifecycle angular2-webpack-starter@5.0.5~server: angular2-webpack-starter@5.0.5
8 verbose lifecycle angular2-webpack-starter@5.0.5~server: unsafe-perm in lifecycle true
9 verbose lifecycle angular2-webpack-starter@5.0.5~server: PATH: /usr/local/lib/node_modules/npm/bin/node-gyp-bin:/home/enzo/angular2-webpack-starter/node_modules/.bin:/usr/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin
10 verbose lifecycle angular2-webpack-starter@5.0.5~server: CWD: /home/enzo/angular2-webpack-starter
11 silly lifecycle angular2-webpack-starter@5.0.5~server: Args: [ '-c', 'npm run server:dev' ]
12 silly lifecycle angular2-webpack-starter@5.0.5~server: Returned: code: 1 signal: null
13 info lifecycle angular2-webpack-starter@5.0.5~server: Failed to exec server script
14 verbose stack Error: angular2-webpack-starter@5.0.5 server: npm run server:dev
14 verbose stack Exit status 1
14 verbose stack at EventEmitter.<anonymous> (/usr/local/lib/node_modules/npm/lib/utils/lifecycle.js:242:16)
14 verbose stack at emitTwo (events.js:100:13)
14 verbose stack at EventEmitter.emit (events.js:185:7)
14 verbose stack at ChildProcess.<anonymous> (/usr/local/lib/node_modules/npm/lib/utils/spawn.js:40:14)
14 verbose stack at emitTwo (events.js:100:13)
14 verbose stack at ChildProcess.emit (events.js:185:7)
14 verbose stack at maybeClose (internal/child_process.js:850:16)
14 verbose stack at Process.ChildProcess._handle.onexit (internal/child_process.js:215:5)
15 verbose pkgid angular2-webpack-starter@5.0.5
16 verbose cwd /home/enzo/angular2-webpack-starter
17 error Linux 4.4.0-21-generic
18 error argv "/usr/bin/nodejs" "/usr/local/bin/npm" "run" "server"
19 error node v5.12.0
20 error npm v3.10.5
21 error code ELIFECYCLE
22 error angular2-webpack-starter@5.0.5 server: npm run server:dev
22 error Exit status 1
23 error Failed at the angular2-webpack-starter@5.0.5 server script 'npm run server:dev'.
23 error Make sure you have the latest version of node.js and npm installed.
23 error If you do, this is most likely a problem with the angular2-webpack-starter package,
23 error not with npm itself.
23 error Tell the author that this fails on your system:
23 error npm run server:dev
23 error You can get information on how to open an issue for this project with:
23 error npm bugs angular2-webpack-starter
23 error Or if that isn't available, you can get their info via:
23 error npm owner ls angular2-webpack-starter
23 error There is likely additional logging output above.
24 verbose exit [ 1, true ]
can anyone help me please??
Enzo Notario
@enzonotario
Jul 31 2016 22:09
SORRY, I clone with --depth 1 and now it works...
why I have to clone with --depth 1?
or.. why do I have to clone with --depth 1 ?
sorry I don't speak english :)