These are chat archives for AngularClass/angular2-webpack-starter

6th
Sep 2016
rvalimaki
@rvalimaki
Sep 06 2016 06:45
@JonnyBGod thanks a lot! I was about to revert all my ~thousand paths back to relative paths, but thanks to you, that's not needed anymore.
rvalimaki
@rvalimaki
Sep 06 2016 07:19
@Bnaya IDK, I have patched our large application several times to match the latest webpack starter. Pretty much everything has totally changed several times in the process... Hopefully things get more stable when Angular2 itself gets more stable.
I suggest postfixing all conflicting files with "_old" or something, and then importing up to date files & folders from the starter project, and then patching the imported files using compare. Lot's of work, but nothing in comparison to Angular2 RC4 -> RC5/6 update....
Artur Käpp
@ArturKp
Sep 06 2016 10:17

Hey, two things.

I've been learning the starter pack in order to build my own and fully understand it. But a thing I haven't been able to figure out since yesterday is what loader or package(s) is(are) responsible for processing the <% or <%= or {% etc tags in html template?

Second thing that maybe I should have made an issue is that the chat link in README.md and also when starting to submit issue is not working (http://angularclass.com/member-join/)

Artur Käpp
@ArturKp
Sep 06 2016 11:06
Think I got the answer, it's HtmlWebpackPlugin, now I just have to figure out why its not working for me
ashkank83
@ashkank83
Sep 06 2016 19:39

@ashkank83
hi all, I'm getting the following error when trying 'npm start for my angular 2 application
'module.js:457
throw err;
^

Error: Cannot find module './webpack.common.js'
at Function.Module._resolveFilename (module.js:455:15)
at Function.Module._load (module.js:403:25)
at Module.require (module.js:483:17)
at require (internal/module.js:20:19)
at Object.<anonymous> (/Users/Ashkan/Desktop/LogiPro/Training/rc6WebPack/config/webpack.dev.js:3:20)
at Module._compile (module.js:556:32)
at Object.Module._extensions..js (module.js:565:10)
at Module.load (module.js:473:32)
at tryModuleLoad (module.js:432:12)
at Function.Module._load (module.js:424:3)'
any ideas what can the issue be?
I have simply followed the instruction from here https://angular.io/docs/ts/latest/guide/webpack.html