Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Sep 30 15:12
    bbrink68 commented #2049
  • Aug 23 13:34
    SouravKumar89 edited #2058
  • Aug 23 13:27
    SouravKumar89 opened #2058
  • Aug 22 00:04

    PatrickJS on master

    Update README.md (compare)

  • Aug 13 17:17
    ramsunvtech commented #1925
  • Aug 12 22:58
    terrancecorley commented #770
  • Aug 09 02:30
    jindovu commented #2049
  • Aug 09 02:22
    jindovu opened #2057
  • Aug 08 10:49
    krawinkelm commented #2053
  • Jul 21 14:14
    FilipLitwora commented #958
  • Jul 21 14:14
    FilipLitwora commented #958
  • Jul 21 14:14
    FilipLitwora commented #958
  • Jul 09 11:40
    Sanafan commented #1713
  • Jul 05 11:41
    hoang-innomizetech commented #2053
  • Jul 05 07:32
    Jilaba commented #1824
  • Jun 29 04:31
    Jason-Cooke synchronize #2055
  • Jun 28 14:51
    jesslilly commented #1827
  • Jun 12 18:16
    dvaldivia commented #1969
  • Jun 12 17:55
    dvaldivia commented #2049
  • Jun 12 07:51
    ppomet commented #2056
Jared Youtsey
@jkyoutsey
I'm seeing an interesting error with RC3 using the new router (3.0.0-alpha.7) and any production build: EXCEPTION: Error: Uncaught (in promise): Error: Cannot match any routes: ''
npm run server:prod gives that error, so does serving it up in nginx.
Ah, @bergvandenp is seeing the same thing. any progress?
Jared Youtsey
@jkyoutsey
@rjlee7 It's a bit simpler now <a [routerLink]="['/dashboards']" routerLinkActive="router-link-active">
Jared Youtsey
@jkyoutsey
My new router issue does not occur in dev. I'm going to remove build plugins until I can see where it fails.
Jared Youtsey
@jkyoutsey
Removing Uglify, Dedup, and Md5 didn't change anything...
Paul van den Berg
@bergvandenp
@jkyoutsey I just switched to LocationStrategy: HashlocationStrategy. That works like it supposed to
This message was deleted
bootstrap(AppComponent, [ APP_ROUTER_PROVIDERS, {provide: LocationStrategy, useClass: HashLocationStrategy}, ]);
that also prevents page reloads without the need to configure the server
Paul van den Berg
@bergvandenp
@jkyoutsey i still get that error for my root path, because i didn't define a route for ''. I'll ignore that for now
Jehong Ahn
@toonitw
This message was deleted
Jehong Ahn
@toonitw

Hello. I need a help.
I want to add a new AsyncRoute. But there's an exception

export const routes: RouterConfig = [
  { path: 'detail', component: 'Detail', canActivate: [ WebpackAsyncRoute ] },
  { path: 'foo', component: 'Foo', canActivate: [ WebpackAsyncRoute ] },
];
export const asyncRoutes: AsyncRoutes = {
  'Detail': require('es6-promise-loader!./+detail'),
  'Foo': require('es6-promise-loader!./+foo')
};
export const prefetchRouteCallbacks: Array<IdleCallbacks> = [
  asyncRoutes['Detail'],
  asyncRoutes['Foo']
];

I cannot even change a route name.

export const routes: RouterConfig = [
  { path: 'detail', component: 'Foo', canActivate: [ WebpackAsyncRoute ] },
];
export const asyncRoutes: AsyncRoutes = {
  'Foo': require('es6-promise-loader!./+detail'),
};
export const prefetchRouteCallbacks: Array<IdleCallbacks> = [
  asyncRoutes['Foo'],
];

What happened?

99% Cocoa
@rjlee7
@jkyoutsey thanks that worked great!
Jared Youtsey
@jkyoutsey
I wonder if the router issue is happening with other builds, such as gulp? If so, then this is ng2 core bug.
@bergvandenp how are you working if your root path doesn't work?
rwobben
@rwobben
Can I easily use ng prime things like the editable table with this template
Paul van den Berg
@bergvandenp
@jkyoutsey it all works. it just gives me a console error
Are you guys having problems with sass-loader@4.0.0?
it tries to scan my entire system and doesn't have permissions on my timemachine folder lol
Ramses De La Peña Coronado
@ramsesDeco
hi, someone can explain me why is node configuration like this? on webpack.prodution
node: {
    global: 'window',
    crypto: 'empty',
    process: false,
    module: false,
    clearImmediate: false,
    setImmediate: false
  }
Michael Blaszczyk
@Blasz
I'm considering moving to this build system from angular-CLI, what's the update process for getting the latest changes? Is it just fork + syncing with master?
Michael Chambaud
@mchambaud
Hello
How to use npm run ci in the CI? Do I need to have a CI build step that runs the server first?
Ramses De La Peña Coronado
@ramsesDeco
hi, how can i use "remap-istanbul" for code coverage, i see that this proyect already has loaded , but it doesn't implement it
rahdev
@rahdev
Do you still need to use angular2-webpack-starter to use angular2 and TypeScript or does jhipster support Angular 2 natively now?
hotJS
@hotJS
This message was deleted
Ramses De La Peña Coronado
@ramsesDeco

someone can tell me when should use a route async way, with the WebpackAsynRoute library from @angularclass/webpack-toolkit , i got understood that the wepback chunks allow that

thanks !

Carlos Esteban Lopez Jaramillo
@luchillo17
The idea is to have an App Shell, so the way async routes work right now is that you make the home page the first to load, and as soon as the event loop gets to an Idle state it should fetch and download the other pages of the app, basically lazy loading allowing to render faster the first page without waiting for the other 2-10 routes to download.
Thibaut Roy
@thbt
has anyone successfully imported bootstrap ?
also, how do i get rid of the following error ?
ERROR in [default]
Option 'sourceRoot' cannot be specified with option 'inlineSources'.

ERROR in [default] D:/git_clones/rail-prototypes/rail-b2c-showcase/typings/globals/webpack/index.d.ts:4:30
Cannot find module 'uglify-js'.
Emil Aasa
@emilaasa
Maybe some of you webpack conoisseurs can help with me this.
I have a ngrx/store-log-monitor component in my app component.
I'd like to completely strip it out in production. Ideas?
Carlos Esteban Lopez Jaramillo
@luchillo17
2 ideas:
  1. Make use of the define plugin to set an env global var, then in the component itself configure it to only work if env == 'prod' or something.
  2. Harder, use the NormalModuleReplacementPlugin to replace the module with an empty one that has the same functions but those ones does nothing.
Carlos Esteban Lopez Jaramillo
@luchillo17
This message was deleted
Emil Aasa
@emilaasa
@Luchillo Excellent, thanks for the ideas!
Emil Aasa
@emilaasa
@Luchillo Got a naive version working now, probably good enough until we have chrome extension dev tools anyway.
Carlos Esteban Lopez Jaramillo
@luchillo17
@emilaasa Sooo which approach did you take? also now we have augury which is the Ng2 version of Batarang.
Emil Aasa
@emilaasa
@Luchillo I just did *ngIf for now, got a webpack solution too but it's not pretty
Carlos Esteban Lopez Jaramillo
@luchillo17
And did you try agury?
Emil Aasa
@emilaasa
Not yet, installing now!
Anton Iliyn
@brud
hi, guys! this kit awesome, but i have trouble - i working on vagrant, when i execute npm run start:hmr - i'm waiting 40 (!) seconds, then if i type some stuff in /src folder - i'm waiting 16 sec, it's too long - can you help me with configuring?
Carlos Esteban Lopez Jaramillo
@luchillo17
In a normal pc it doesn't take that much, for example in mine the first one takes 15s and recurrent build takes 1-2 s top.
But mine has I7, DDR5 RAM and SSD
Karthik
@karthikkavin
i am using angular 2 child route, when i click a route show all child did not got error, but another time click same route got error on console "cannot read property 'visitExpression' of undefined ; Zone: angular ; Task: Promise.then ;"
how to reproduce, did not load any route
Emil Aasa
@emilaasa
Are we running rc4 now with material2?
Emil Aasa
@emilaasa
I get the following errors and as a npm noob I dont know how to resolve it:
npm WARN @angular2-material/checkbox@2.0.0-alpha.6 requires a peer of @angular/forms@^0.1.0 but none was installed.
npm WARN @angular2-material/icon@2.0.0-alpha.6 requires a peer of @angular/http@2.0.0-rc.3 but none was installed.
npm WARN @angular2-material/input@2.0.0-alpha.6 requires a peer of @angular/forms@^0.1.0 but none was installed.
npm WARN @angular2-material/radio@2.0.0-alpha.6 requires a peer of @angular/forms@^0.1.0 but none was installed.
npm WARN @angular2-material/slide-toggle@2.0.0-alpha.6 requires a peer of @angular/forms@^0.1.0 but none was installed.
But in the angularclass repo it seems the material branch is working just fine with the same stuff that I have put in it
tamtran-agilityio
@tamtran-agilityio
hello