These are chat archives for AnotherIndieDevStudio/CoopGameMaking

13th
May 2015
AnotherIndieDevStudio
@AnotherIndieDevStudio
May 13 2015 06:32
New patch has been released. Very small on this time around. Simply fixing overflowing events and adding the new mascot in.
AnotherIndieDevStudio
@AnotherIndieDevStudio
May 13 2015 08:15
Added a status object to the game file
also allowed the ability to trigger events without needing to be in the queue
allowing for non-random events
Tribuadore
@Tribuadore
May 13 2015 08:17
oh, queuing doesn't involve only random events
queuing was just how to manage the concept of adding events that may not be at "current elapsed time"
i.e say elapsed is currently 750
and you create an event that has time set to 500
its already overdue
but it will still fire as soon as its queued
because the update routine takes everything at elapsed or older and fires them
also you can queue something at time 2500, and it will not fire straight away
it will sit in the queue until elapsed 2500 is reached
AnotherIndieDevStudio
@AnotherIndieDevStudio
May 13 2015 08:19
my bad what I meant to say was
allow the ability to trigger events immediately from anywhere in the game.
Tribuadore
@Tribuadore
May 13 2015 08:20
Game.Event.queue(Game.Event({description: 'This is an event'}));
will get default time equal to current elapsed
default type of information
and fire straight away
AnotherIndieDevStudio
@AnotherIndieDevStudio
May 13 2015 08:21
ok
I misread code
Tribuadore
@Tribuadore
May 13 2015 08:21
:)
AnotherIndieDevStudio
@AnotherIndieDevStudio
May 13 2015 08:21
I apologize
Tribuadore
@Tribuadore
May 13 2015 08:21
I was thinking when I did it, it may be confusing
I was thinking either a lot more documentation on usage examples
AnotherIndieDevStudio
@AnotherIndieDevStudio
May 13 2015 08:21
I just assumed queue was for random events not being triggered at the same time
Ok I am stupid :^)
Tribuadore
@Tribuadore
May 13 2015 08:22
nah queue is just "the way" to get a event fired at its time value
we could rename it add()
AnotherIndieDevStudio
@AnotherIndieDevStudio
May 13 2015 08:22
didn't actually read the Game.Event.queue function
Tribuadore
@Tribuadore
May 13 2015 08:22
or something else
if you think queue() is a little weird
AnotherIndieDevStudio
@AnotherIndieDevStudio
May 13 2015 08:22
yeah it's a bit misleading
Tribuadore
@Tribuadore
May 13 2015 08:23
ok rename it add
AnotherIndieDevStudio
@AnotherIndieDevStudio
May 13 2015 08:23
will do now
Tribuadore
@Tribuadore
May 13 2015 08:23
how about a convenience function that shortens the statement and automatically create a new Game.Event instance
I was thinking something like....
Game.AddEvent({description: 'You are dead.'});
AnotherIndieDevStudio
@AnotherIndieDevStudio
May 13 2015 08:24
yeah that's what I added
Tribuadore
@Tribuadore
May 13 2015 08:24
The namespace is shorter
and you aren't passing a Game.Event instance
you are just passing the obj template
AnotherIndieDevStudio
@AnotherIndieDevStudio
May 13 2015 08:25
Ok
Tribuadore
@Tribuadore
May 13 2015 08:25
The implementation of Game.AddEvent would take that parameter and pass it to Game.Event()
var Game.AddEvent = function(obj) {
AnotherIndieDevStudio
@AnotherIndieDevStudio
May 13 2015 08:25
so I will keep queue and add in the Game.AddEvent
Tribuadore
@Tribuadore
May 13 2015 08:26
var event = Game.Event(obj);
Game.Event.queue(event);
Just leave queue for internal / advanced usage
and tell people that want to add events to use Game.AddEvent
probably a good api organisation style
top level functions get put on the Game namespace
internal / advanced functions get put on the modules namespace like Game.Event.
AnotherIndieDevStudio
@AnotherIndieDevStudio
May 13 2015 08:27
Yeah
that sounds like a good idea
Tribuadore
@Tribuadore
May 13 2015 08:28
i know, that why i said it :)
AnotherIndieDevStudio
@AnotherIndieDevStudio
May 13 2015 08:28
and it will prevent people being sp00ked from all this stuff
Tribuadore
@Tribuadore
May 13 2015 08:28
yep
promote usage of Game.* functions
AnotherIndieDevStudio
@AnotherIndieDevStudio
May 13 2015 08:28
yeah
Tribuadore
@Tribuadore
May 13 2015 08:28
but don't over pollute the Game. namespace
keep it clean
AnotherIndieDevStudio
@AnotherIndieDevStudio
May 13 2015 08:29
Yeah we will just keep the generic functions there
Tribuadore
@Tribuadore
May 13 2015 08:29
oh i just realised AddEvent is not the naming convention you guys wanted
didn't people want add_event
AnotherIndieDevStudio
@AnotherIndieDevStudio
May 13 2015 08:29
it's ok, I changed it
Tribuadore
@Tribuadore
May 13 2015 08:29
cool, i'm about to get insync with upstream/master
i'll have a look at the current state of the code
AnotherIndieDevStudio
@AnotherIndieDevStudio
May 13 2015 08:30
Also
for the enemies
I was thinking about simplifying it a bit to something like Items.js
people can easily create shit without getting mixed up with the character
Tribuadore
@Tribuadore
May 13 2015 08:31
yeah i know what you mean, good idea
AnotherIndieDevStudio
@AnotherIndieDevStudio
May 13 2015 08:31
it just creates that clear distinction between character and NPC and Enemy
Tribuadore
@Tribuadore
May 13 2015 08:31
i think
actually i'll have a look at item again
AnotherIndieDevStudio
@AnotherIndieDevStudio
May 13 2015 08:32
ok
Tribuadore
@Tribuadore
May 13 2015 08:32
is there any distinction between those three?
AnotherIndieDevStudio
@AnotherIndieDevStudio
May 13 2015 08:32
it is fairly basic
Tribuadore
@Tribuadore
May 13 2015 08:32
aren't they all characters
AnotherIndieDevStudio
@AnotherIndieDevStudio
May 13 2015 08:32
well yeah but we should probably keep the main character seperate from the enemies etc
idk
Tribuadore
@Tribuadore
May 13 2015 08:33
maybe
would be good if items on enemies could be picked up and used on main character too
items should just have modifier attributes, shouldn't they
as long as those modifiers align with generic character attributes, it's all good
i don't know, i've gotta help with dinner here now
AnotherIndieDevStudio
@AnotherIndieDevStudio
May 13 2015 08:35
I was thinking of having the monster stats be multipliers of the main characters stats
yeah no problem
Tribuadore
@Tribuadore
May 13 2015 08:35
oh i see
AnotherIndieDevStudio
@AnotherIndieDevStudio
May 13 2015 08:35
I will just tidy up the mess I have made
Tribuadore
@Tribuadore
May 13 2015 08:35
yeah, well thats cool
i'll leave some of the decisions to you
and i'll just go along with it
that's fine
if i see a trainwreck coming, i'll pipe up :)
AnotherIndieDevStudio
@AnotherIndieDevStudio
May 13 2015 08:36
aha
dw I will try keep it clean
Tribuadore
@Tribuadore
May 13 2015 08:45
omg, the github windows client is so bad
i find myself still doing have the things I want to do on the command-line
AnotherIndieDevStudio
@AnotherIndieDevStudio
May 13 2015 08:55
Yeah some stuff you have to do in command line
Tribuadore
@Tribuadore
May 13 2015 08:55
yeah, and i never remember the commands, so i've always go git help pages open to friggen do simple things
AnotherIndieDevStudio
@AnotherIndieDevStudio
May 13 2015 08:56
so I was thinking about generating a home page, explaining what the project is about and a basic API template
Because it will take a while to develop a full website, I will probably be using the Swagger api
this will hopefully assist people in understanding the code and will get a lot more beginners interested in a development project as well as more experience developers
experienced*
Tribuadore
@Tribuadore
May 13 2015 08:58
cool
AnotherIndieDevStudio
@AnotherIndieDevStudio
May 13 2015 08:58
who can't be bothered reading all the code
Tribuadore
@Tribuadore
May 13 2015 08:59
good idea
lol, you commited Thumbs.db to the repo
AnotherIndieDevStudio
@AnotherIndieDevStudio
May 13 2015 11:51
oops
so I decided to go with a very simple wordpress template rather than using something a bit more serious
this is just an example and information was written in like 10 minutes
Tribuadore
@Tribuadore
May 13 2015 11:58
Looks really good
AnotherIndieDevStudio
@AnotherIndieDevStudio
May 13 2015 11:58
Honestly?
Tribuadore
@Tribuadore
May 13 2015 11:58
Yeah, serious
AnotherIndieDevStudio
@AnotherIndieDevStudio
May 13 2015 11:58
Is the layout of information ok?
Tribuadore
@Tribuadore
May 13 2015 11:59
Yeah, it really is good
Easy to understand
Cool site for documentation stuf
I like it