Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
  • 04:42
    bcurran3 synchronize #588
  • 04:41
    bcurran3 synchronize #588
  • 04:40
    bcurran3 synchronize #588
  • 04:37
    bcurran3 opened #588
  • 03:22
    bcurran3 edited #587
  • 03:21
    bcurran3 opened #587
  • 02:18
    bcurran3 opened #586
  • Aug 17 20:52
    bcurran3 synchronize #582
  • Aug 17 20:43
    bcurran3 synchronize #582
  • Aug 17 17:14
    bcurran3 edited #582
  • Aug 17 17:12
    bcurran3 edited #582
  • Aug 17 17:11
    bcurran3 edited #582
  • Aug 17 17:07
    bcurran3 synchronize #582
  • Aug 17 16:56
    bcurran3 synchronize #582
  • Aug 17 16:55
    bcurran3 synchronize #582
  • Aug 17 15:57
    bcurran3 synchronize #580
  • Aug 17 15:53
    bcurran3 synchronize #580
  • Aug 17 15:50
    bcurran3 synchronize #580
  • Aug 17 15:50
    bcurran3 synchronize #580
  • Aug 17 15:41
    bcurran3 synchronize #578
Luca Candela
@CaliLuke
let's see if I can re-run the ansible script to setup the server now
crossing fingers!
nope, still doesn't work
damn it
open to suggestions :)
georgejung
@georgejung
Had a few problems with Transmission after a recent reboot. They updated the image, so using the latest caused some issue with NORDVPN that was throwing DNS resolution. I changed the image to 3.7.1 instead of latest and its working again. When i have more time I'll try to dig into it. Also my flood UI stopped working, turns out i needed to update my env variable to flood-for-transmission.
jakobjs
@jakobjs_twitter
First time user, currently trying to get things up-n-running. Just wanted to say thanks for spending your time on this project, it is awesome! :D
Jon Gibbins
@dotjay
Hello! I was wondering if anybody knows whether or not it's possible to back up two computers to Time Machine with Ansible-NAS. I have a single instance of Time Machine running in Docker, but wondering if I'd need to run a second instance to backup a second computer? Not sure it'd play nice with me backup up two computers to the one instance?
fofx
@fofx
Hi there. Hope someone can help me out here. I've upgraded my zfs pool and migrated my original pool to the new one. I would like my Ansible-NAS instance to start referencing the new pool, and I figured the easiest way was to rename the new pool to the original pool name. I can't run zfs export my original pool because it is currently being used. How can I "shutdown" all of the Ansible-NAS services so they are no longer using the pool? Am I going about this in a way that makes sense or is there a better solution?
allthestairs
@allthestairs
You can stop all the docker containers if that is what you mean by services.
If the docker daemon itself is accessing the pool then you'd need to stop the docker service itself.
fofx
@fofx

thanks @allthestairs that did the trick. I should have thought of that earlier. However, it appears there are missing datasets in my new pool even though I see all of the files there

TASK [Portainer Docker Container] *
fatal: [localhost]: FAILED! => {"changed": false, "msg": "Error removing container 0ec0a4054a8dcd44c8e93ee32ba5ed8a86f0bc0cf9605ea0138003240b617ac8: 500 Server Error: Internal Server Error (\"b'{\"message\":\"container 0ec0a4054a8dcd44c8e93ee32ba5ed8a86f0bc0cf9605ea0138003240b617ac8: driver \\\"zfs\\\" failed to remove root filesystem: exit status 1: \\\"/sbin/zfs fs destroy -r pool1/ce0be2ade0ab135fe5de3499905a265f2cb01ec8394d43fc622176ceff58464c\\\" => cannot open \'pool1/ce0be2ade0ab135fe5de3499905a265f2cb01ec8394d43fc622176ceff58464c\': dataset does not exist\\n\"}'\")"}

I'm not sure why the dataset is missing. Here is the command I used to send a snapshot from pool1 to pool2:
sudo zfs send -R pool1@now | zfs recv -F pool2
allthestairs
@allthestairs
Sorry, you're beyond me, my setup uses btrfs.
fofx
@fofx
I reattempted to migrate my pool. This time i made sure to use the -r option when creating the snapshot which included all of the datasets. I then just updated my all.yml to use the new zfs pool mount point and everything is working as expected.
Benedikt Strasser
@Shoggomo
grafik.png
Hello! I'm currently trying out ansible-nas in fresh Ubuntu 20.04 VM and somehow my networking broke, showing network unreachabe when pinging 8.8.8.8. I solved it by reinstalling ubuntu, but I wonder what caused it. It was a fresh system with only ansible-nas installed. Here is my nas.yml.
Has anybody experienced something like this?
Benedikt Strasser
@Shoggomo
Found the culprit, if anyone else has this problem see https://www.virtualbox.org/ticket/14374
fofx
@fofx
image.png
I have one main ZFS pool called pool1. Inside I have a Volume2 for the docker data and Volume3 which is my main filesystem that I store things in. When I run "zfs list" I see many datasets in pool1 that I don't recognize. I think these are for the docker containers but I'm not sure why they reside outside of Volume2. Can someone shed some light on this?
Darren OC
@darrenoc3
Hey all, maybe I did something very stupid but I had been using my Ansible-NAS machine for some software development and it was going fine. However today I logged in and my home directory was reverted back to it's state from 5 weeks ago, causing me to lose my whole dev environment including a bunch of docker containers. Does anyone know what would have caused the state of my system to revert like this? It had survived multiple reboots/shutdowns without losing state.
I did notice that my ~/.bashrc still had my most recent changes, even if everything else in my home dir was wiped out
allthestairs
@allthestairs
That is an unusual thing to happen. One way that can happen is if you've mounted a folder on top of your old home folder for a while and now the mount is gone?
You'd probably know if you were doing that though.
draedr
@draedr_gitlab
Hi, i'm trying out ansible-nas using an LXD container, but keeps failing trying to check for gnupg2, which is not available because it's a Ubuntu 20.04.3 container. I've tried with a 21.10 container too, but keeps trying to search for gnugp2.
The playbook is also run in another Ubuntu 20.04.3 container. Sorry if this is not the right place to ask.
oneclearday
@oneclearday
I'm struggling to make a start, I am trying to setup the test VM, my host is windows 10 and I have Virtualbox, Vagrant and Git-Bash which I am trying to use to run the test setup scripts - tests/test-vagrant.sh. Is it even possible to set this up with a windows host? I have managed to get the Vagrant example Ubuntu 18.04 working in VBox I just don't know how to run these scripts, I have changed to the tests directory in Git Bash and tried to run the script but it's all guesswork. Would some kind person give me simple instructions how to setup the test VBox using windows. Thank you
Anatoly Popov
@aensidhe
Hey, folks. I'm struggling with getting Influxdb and Grafana up and running. Grafana says on "test" in data source "Bad request" with response "Authentication to data source failed". Is there any manual I've missed on this?
Tycho Yacub
@tysaya123

Hey yall, I'm running into this issue:

ERROR! the role 'geerlingguy.nfs' was not found in /Users/tycya/Desktop/ansible-nas/roles:/Users/tycya/.ansible/roles:/usr/share/ansible/roles:/etc/ansible/roles:/Users/tycya/Desktop/ansible-nas

The playbook works fine until I switch to trying over ssh (I have ssh configured and can successfully ping the server). I notice that the paths it is checking for the role seems to be all on my local host.

Am I expected to have the roles download on my local host to be able to run the playbook over ssh?
I also noticed that others have a solved similar issues by downgrading to ubuntu 18 from 20 but didn't want to nuke until I have to.

Typing this out helped me realize that I should try installing the roles on my local computer. I think what tripped me up was that the installation instructions explicitly state using apt to install the requirements.yml and I assumed that meant you would only have to do it on the remote host because I am locally running MacOs.
Nebula
@itsnebulalol
is it possible to use a wildcard subdomain and letsencrypt with traefik? for example, *.itsnebula.net
pedromiguelferreirafrade1996
@pedromiguelferreirafrade1996
Hey everyone, hope you're all doing well. I need some assistance, and was wondering if any of you can help or know the answer to this. Anyone know the smb password for the shares?
and user
ArtemAnufiev
@ArtemAnufiev

Hi guys! I'm trying to install AnsibleNAS on VirtualBox on my Windows PC,but cant access to services through web. Steps i did:
1.Install Vbox with Ubuntu server
2.Followed all steps in installation

  1. Trying to access Heimdal in browser 127.0.0.1:10080 and get error in Chrome: ERR_UNSAFE_PORT

Cant access any webservices. Thanks for an answer.

Alan Hawrylyshen
@muonzoo
Chrome no longer likes that port . Change to port in the container map to 11080 (or something else).
ArtemAnufiev
@ArtemAnufiev

Chrome no longer likes that port . Change to port in the container map to 11080 (or something else).

Thanks for an answer.

ArtemAnufiev
@ArtemAnufiev

I have followed all installation steps on clean ubuntu server, than run "ansible-playbook -i inventories/my-ansible-nas/inventory nas.yml -b -K" and get error:
TASK [ansible-nas-docker : Add user account to Docker group] **
fatal: [ansible-nas]: FAILED! => {"changed": false, "msg": "Group docker does not exist"}

It seems that i should install manually?

I created a group docker and add my user, than sudo apt install docker.io

Only after that system works. Why didnt it mentioned in installation docs? Sorry question maybe stupid, because i am not so qualified(

2 replies
ArtemAnufiev
@ArtemAnufiev

One more question about Samba: i did samba setup as demo file, but i cant see samba that shared folders in my local network from Windows PC.What should i do? Thanks!

Shares you want published over Samba.
samba_shares:

  • name: downloads
    comment: 'Stuff downloaded'
    guest_ok: yes
    public: yes
    writable: yes
    browseable: yes
    path: "{{ downloads_root }}"
lpkampen
@lpkampen
Hi o/
Did anyone add code server to a ansible-nas fork yet?
lpkampen
@lpkampen
Gods… I got it working in the end… just wasn´t aware I had to change the codes from code-server to code_server
luka murn
@lumux:matrix.org
[m]
i need some help, i installed ansible-nas just fine on ubuntu server, kept everything default, except i changed my inventories under nas user to localhost. i can ssh into ansible-nas without issues, but i cannot access heimdall for the life of me. i went back and changed /ansible-nas/inventories/my-ansible-nas/inventory and changed it back to sample, uncommented both lines for remote and local access under all, rebooted and still cannot access it. what am i missing? i set my ansible_host ip in the inventory file to be the same as the ssh ip of the device 192.168.x.100, heimdall is enabled in group_vars and i made sure to allow 10080 port in firefox. i know i have to be missing something obivous
luka murn
@lumux:matrix.org
[m]
also if i run sudo docker app ls, there are no running apps, and sudo docker port 10080 says no such container 10080. i guess i installed something wrong?
luka murn
@lumux:matrix.org
[m]
figured it out, instead of rebooting you have to rerun the playbook and i have got it working now, wish there were more extensive wiki/docs on the entire process of setting it up
lpkampen
@lpkampen
you can shave off some time if you use this command:
ansible-playbook -i inventories/my-ansible-nas/inventory/ nas.yml -b -K -t heimdall
that will not run the whole playbook, only the changes you did to that part of the playbook
lpkampen
@lpkampen
I've had mine running for almost a year now and I thought the docs were good. I've looked over the docs now and I think there is a need for some more detailed docs. I'm gonna spin up another server when I get the time and write up a more noob-proof guide.
Jelle De Vos
@jellebean
Anyone have a clue why after setting everything up (cloudflare ddns, traefik, radarr, sonarr, all externally available) why traefik keeps using it's own certificate instead of the let's encrypt one it requested?