Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
J Khalaf
@Ciwan1859
I assume that article is now way out of date, can someone point me to an up to date article please?
Dinesh Yelchuri
@vyelchuri
I am planning to use this tool as HTML report generation tool in an enterprise
Is any one experienced any issues with that?
Steven Yates
@Steveiwonder
Hey, Does this libary support .net core?
Mark Tkachenko
@Rizzen
No, it doesnt
Rubemlrm
@Rubemlrm
Good afternoon folks
Vladimir Shmidt
@vladimir-shmidt
What for a plan of adopting to a core?
Rubemlrm
@Rubemlrm
@vladimir-shmidt maybe they want to increase the number of maintainers before go to that
Rubemlrm
@Rubemlrm
Good morning
i have a little question
when i'm using partial layouts how can i use the custom directives
?
but can't send a custom config
Paulo Ricardo Stradioti
@paulostradioti

Hi everyone. I'm trying to improve the performance of the first time I call a report by caching it ahead of time. However, my attempts to cache the template seems to have no effect.

Please, what am I doing wrong?
Here's the code? https://pastebin.com/mbJ1NzPa

Paulo Ricardo Stradioti
@paulostradioti
anyone please?
Jake Ashcraft
@jakeashcraft
Does anyone know of a full example on GitHub that loads layout, css, javascript, etc? Perhaps an example using bootstrap or similar framework.
texyh
@texyh
Hey guys
3 replies
please i have a little question
i am using RazorEngine.NetCore in .Net Core 3.1 and when i run Engine.Razor.Compile(key); i get the following error
Could not load type 'Microsoft.AspNetCore.Razor.Language.RazorTemplateEngine' from assembly 'Microsoft.AspNetCore.Razor.Language, Version=3.1.1.0, Culture=neutral, PublicKeyToken=adb9793829ddae60'.
Artur Karbone
@ArturKarbone
Hi guys. I have (i believe similar issue as @texyh ). In .NET Core 3.1 project with the latest RazoreEngine.NetCore i keep getting : The type or namespace name 'Hosting' does not exist in the namespace 'Microsoft.AspNetCore.Razor' (are you missing an assembly reference?)
Roberto Denisi
@rdenisi
Hi, .Net Core 3.1 is not supported?
Roberto Denisi
@rdenisi
I have the same error: Could not load type 'Microsoft.AspNetCore.Razor.Language.RazorTemplateEngine' from assembly 'Microsoft.AspNetCore.Razor.Language, Version=3.1.3.0
Han Dong
@HDONGDeveloper
RazorTemplateEngine What to replace on 3.0
Yaseen Agwan
@agwanyaseen
hey did anybody have used razor engine with sql queires especially for mssql queries?
Matthias Burger
@matthiasburger
Hey guys, I got some trouble when publishing my web-application (.net 4.6.1) in release-mode.. in debug it seems to work, in release-mode, template cant compile.. Anybody here who can help?
chinturathod
@chinturathod
Hey Guys,
I am getting this error Could not load type 'Microsoft.AspNetCore.Razor.Language.RazorTemplateEngine' from assembly 'Microsoft.AspNetCore.Razor.Language, Version=3.0.3.0, Culture=neutral, PublicKeyToken=adb9793829ddae60'.'
Alexander
@adoconnection
@chinturathod RazorEngine will not work on .NET Core, you can try mine :) https://github.com/adoconnection/RazorEngineCore
chinturathod
@chinturathod
Hi @adoconnection RazorEngine is working fine in azure functions with .net core 3.0. I am geting this error in .net core web api.
Alexander
@adoconnection
Interesting, Are you sure there is core3?
chinturathod
@chinturathod
Yes i m sure
Alexander
@adoconnection
To be honest I have no understanding how it is possible
cpatel22
@cpatel22
how can i call static function inside HTML convertor
Abhishek B.
@abhishekbhalani
Hello,
want to know RazorEngine Template can cached long time in file or somewhere to manually clear template when it been updated..
Memory Caching we are doing but it only hold sometime in memory only.
Igor A. Melekhine
@awsom82
how to run RazorTemplate example on OSX?
provided examples die