Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
    Sirus Laia
    @sslaia

    Caused by: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target I'm getting this error when compile master, Anyone help?

    Hi @collabro2017 I got rid of such error with openjdk 11 (I'm on Ubuntu).

    kujawek
    @kujawek:matrix.org
    [m]
    Hi. How to delete word that I accidentally added to the dictionary?
    1 reply
    Chi Ochita
    @Chishio_gitlab
    I can't seem to find a semicolon on the keyboard. Am I overlooking it, or is the keyboard missing that punctuation?
    1 reply
    EtienneDesticourt
    @EtienneDesticourt
    I'm getting a Strict Mode Violation: DiskReadViolation when running in Debug mode on an emulator. Any hints as to how I could get rid of it?
    EtienneDesticourt
    @EtienneDesticourt
    Ok, solved it by deleting the contents of DebugAnyApplication.
    Now I'm hitting another problem where the DictionaryLoadedListener does not get defined for the AnysoftKeyboardWithGestureTyping because mPredictionOn is set to False for AnySoftKeyboardSuggestions.
    It took me forever to debug but basically the gesture typing keyboard doesn't load its dictionnary unless predictions/suggestions are on. Suggestions aren't on when you open the google search-bar in the dock of the default emulator (Pixel 3A) so gesture typing does no work without any warning or error. So you have to open another input field which has suggestions activated so the dictionary will load, then if you go to any other input field, even without suggestions, gesture-typing will work. I think AnySoftKeyboardWithGestureTyping should load its dictionary independently of suggestions but I'm not familiar enough with the global architecture to suggest how.
    Haddou Mohamed Said
    @HaddouMohamedS1_twitter
    Hi, how i can replace enter button on the keyboard with check mark ? i know i can do that with xml layout with inputType:"Text" but that makes the gradient and the shadow on my text disappear
    EnForce61
    @EnForce61
    Hello so I wanted to ask something ,Keyboard is extremely good but it is a bit dificult to make it like Swiftkeyboard I am trying if someone can help it would be very helpful . I want
    Emmett Baker
    @emknbaker
    Hello everyone - Recently installed. I prefer to have the number key row on top, and also when pressing shift once it stays as the symbol row until I press a key otherwise. Right now the default behavior seems to that I have to hold shift to make the symbols stay (but that usually gets me stuck in caps-lock mode). Any place to change this? Thank you!
    5lttrz
    @5lttrz
    Hello. There is a bug where the keyboard corrects only the part we type rather than the whole word.
    Ex: If i type "thos" instead of "this" by accident, when i got back and correct the "os" part it thinks as if i am writing a separate word.
    krzysztof_korycki
    @krzysztof_korycki_gitlab
    Hi If I would like to create a new view - like emoji one how should I start?
    ivangj
    @ivangj:matrix.org
    [m]
    Hello! I had a swipe down to close keyboard that somehow stopped working... do you have any idea why?
    hueppinr
    @hueppinr
    Is it possible to use high ASCII code characters? How would I enter those? In windows I can use Alt+xxxx for example
    Julián Gómez
    @JulianGR
    Hi! is there an option to make word suggestions to appear in the middle of the suggestions bar?
    hueppinr
    @hueppinr
    Is there anyone reading the posts here?
    Anyone of the developers?
    I would be happy do donate or pay for the app but as it seems to be impossible to get support it seems useless
    Ibrahima SARR
    @ibrahimasarr
    Hi all
    Can anyone help me understand the step "Move PackBroadcastReceiver package to the right place" in Ad-don Packs Readme?
    matrimcauthon
    @matrimcauthon:matrix.org
    [m]
    Hi. Any way to remove the apostrophe From the.alphabet part of the keyboard ? And the voice search too?
    John Galt
    @victor.yanchuk:matrix.org
    [m]
    Hello
    Beethoven
    @beethoven___gitlab
    are custom themes and layouts a thing?
    if not from the app, do i have to use some kinda config file or what
    i'd also love to be able to do "dont" in gesture typing and have it autocorrect to "don't" so i don't have to swipe over to the apostrophe key
    Sirus Laia
    @sslaia
    Hi all, this question was asked before by @mubashirbashir_twitter (Dec 22 2019), but I haven't found a clear answer. Is it now possible to compile the main app with certain add-on language as default? I'm promoting ASK to preserve an endangered language (Nias, my own language), but the native speakers who have to write are not tech savvy. So they have difficulty in having to install an app and then the addon-language and then run the setup, etc. The only way to serve those target groups would be to compile the addon-language directly into the app. Is there any manual how to do that?
    Maybe @menny could lend me a hand in this regard?
    RootedNewbie
    @RootedNewbie
    I've used ask for a long time.

    For some reason tapping the space key no longer changes keyboard language. It used to work and the language keyboards are selected but there is now no way to switch keyboards like I used to. I'm using Canary.

    I need to switch between English and French. How can I restore the ability to switch keyboards?

    I'm on Android pie in case that matters.
    Sirus Laia
    @sslaia
    Hi @RootedNewbie on the theme I'm using there is a button (a long one) on the right top corner for changing the layout. The complaint I heard from users is that they are used to Gboard and expect that by pressing the space key the language layout option pops up. I wish ASK has exactly the same flow, as I'm using Gboard a lot.
    RootedNewbie
    @RootedNewbie
    Unfortunately i can't find a key to do that anywhere.
    I've long pressed several keys and none change language. The space key has 'English' written on it so that would be the logical one but it does not change languages. Ill keep trying different themes to see.
    RootedNewbie
    @RootedNewbie
    ——I uninstalled and reinstalled ask. Now everything works as it should.
    RootedNewbie
    @RootedNewbie
    Correction. After configuration to have a common top row to be numbers the ability to switch languages disappears.
    So, to change languages i cannot have a coomon top row of numbers. There really should be another way to change languages. The space key is the obvious one.
    I have the option "space switches language"selected but it does not work on short or long press.
    Perdellian
    @Perdellian
    Is there any way to keep autocorrect from spellchecking only new sections of words?
    And, when pressing backspace to undo a correction, to not remove the space punctuation mark that signaled the end of the word?
    Perdellian
    @Perdellian
    @RootedNewbie a couple weeks late, perhaps, but I've accidentally brought up the language selection dialog a few times by long-pressing the 123!#() key.
    RootedNewbie
    @RootedNewbie
    Perdelian, thanks for the suggestion. I tried it but it does not work for me. It probably depends on the keyboard selected. On the one I'm using, long press the 123!() key does not change lsnguages. I can now change languages by clicking on the top right of the keyboard but that disappears if i select to have numbers on the top row.
    That is why long pressing the space key is the logical option to change langusges but it is not implemented.
    Perdellian
    @Perdellian
    Ah. I'm using one of the Dvorak layouts (which I'd kinda like to tweak to be a little closer to AOSP Dvorak and just need to figure out how to do so)
    Still works using the Русский keyboard I installed for Duolingo
    Oh! I wonder if it also depends what style of bottom row you choose? I set mine to AOSP-style to give my right thumb more room to hit the spacebar, given my muscle memory
    Perdellian
    @Perdellian
    Took another perusal through the settings. Still not finding an answer to my questions about autocorrect and the correction thereof.
    stencil
    @stencil:matrix.org
    [m]
    Is there a Bangla/Bengali layout? I can't find it.
    Daniel Parks
    @danielrparks:matrix.org
    [m]

    I'm trying to build ASK and I'm getting this error

    Build command failed.
    Error while executing process /home/daniel/Android/Sdk/ndk/17.2.4988734/ndk-build with arguments {NDK_PROJECT_PATH=null APP_BUILD_SCRIPT=/home/daniel/dev/AnySoftKeyboard/ime/dictionaries/jnidictionaryv1/Android.mk APP_ABI=armeabi NDK_ALL_ABIS=armeabi NDK_DEBUG=1 APP_PLATFORM=android-9 NDK_OUT=/home/daniel/dev/AnySoftKeyboard/ime/dictionaries/jnidictionaryv1/build/intermediates/ndkBuild/debug/obj NDK_LIBS_OUT=/home/daniel/dev/AnySoftKeyboard/ime/dictionaries/jnidictionaryv1/build/intermediates/ndkBuild/debug/lib anysoftkey_jni}
    [armeabi] Compile++ thumb: anysoftkey_jni <= com_anysoftkeyboard_dictionaries_BinaryDictionary.cpp
    
    /home/daniel/Android/Sdk/ndk/17.2.4988734/toolchains/llvm/prebuilt/linux-x86_64/bin/clang++: error while loading shared libraries: libncurses.so.5: cannot open shared object file: No such file or directory
    make: *** [/home/daniel/dev/AnySoftKeyboard/ime/dictionaries/jnidictionaryv1/build/intermediates/ndkBuild/debug/obj/local/armeabi/objs-debug/anysoftkey_jni/src/main/jni/source/com_anysoftkeyboard_dictionaries_BinaryDictionary.o] Error 127

    Can anyone help me find the cause?

    Never mind. The problem is that clang++ itself requires an old version of ncurses