by

Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
    souzaxdr
    @souzaxdr
    Now I'm happy with my Solo. I am using Opensolo 3.0 and Ardupilot 3.7dev AND SolexAPP.
    Matt
    @Pedals2Paddles
    https://github.com/OpenSolo/OpenSolo is now live. Many separate repos combined and cleaned up into subdirectories. And others made sub-modules. Github wiki for documentation instead of readmes.
    With all the changes I've been working on for Open Solo 4, to include the current ArduCopter master that's now fully compatible.
    @FLYBYME I saw you forked the OpenSolo repo from my account. I think it should redirect on its own, but if it doesn't, you'll need to re-clone it from the Open Solo account.
    Chris Stevens
    @stevenscg
    🎉 Thanks for all the work, Matt!! This looks fantastic.
    Matt
    @Pedals2Paddles
    thx
    André Kjellstrup
    @AndKe
    Thank you.
    André Kjellstrup
    @AndKe
    4.0-dev docs say "Camera shutter trigger in ArduCopter if no GoPro is connected"
    I would say that even with a gopro, recording logging the usual CAM messages is essential, and a great help in getting time-stamping right. I suggest it is logged regardless of gopro being connected, or not.
    Matt
    @Pedals2Paddles
    It always logged cam messages before too
    This just redirects from GoPro trigger to Ardupilot shutter when no GoPro is detected.
    Mike Boland
    @mboland
    I am hooked on OpenSolo4. Great work. Now with the arse kissing out of the way I have an issue I hope is only my ignorance. I am trying to change controller mode on the Artoo from Mode 1 to Mode 2 and it is defying my every attempt. I followed the manual method in the Dev docs of SHH into the controller and changing the files as described. No effect. I have borrowed an Android phone (I don’t have ANY android devices) and used the 3DR app to change the Controller Mode from 1 to 2. No effect. What am I missing? Has something changed in OS4 that won’t allow the Controller Mode change? I am familiar with RCMAP in the parameters and have tried changing that and all looks good except now throttle and pitch are going the wrong way and the Reverse parameter in AC has no effect??? Can anyone give me a kick in the right direction please?
    Matt
    @Pedals2Paddles
    I haven't changed anything related to the existing methods of controller modes. At least not intentionally that I know of
    But I have also never tried to to change it
    Are you sure you're changing the correct reverse parameters? It would be RC1_REVERSED, RC2_REVERSED, etc
    Mike Boland
    @mboland
    Thanks for the reply @Pedals2Paddles , yes, I am familiar with the Arducopter parameters, which is where I initially went to change the RCMAP and then reverse the input channels for throttle and pitch.
    This is what started me chasing my tail as it made no difference to the inputs at all.
    Upon reading further I came across the old 3DR Solo pages in our Docs @ http://ardupilot.org/dev/docs/solo.html which mentioned changing controller modes.
    I followed those instructions but they seem incomplete as there is no apparent way to lock in the changes.
    QGC will do a Mode 2 calibration but then refuses to write the parameters because the throttle is reversed even if I set RC.
    I have also been circling through Github trying to find the binaries for the Artoo so I can go through it on the desktop without luck.
    If you need any assistance with the Wiki’s for open solo I would be happy to help where I can.
    Peter Barker
    @peterbarker
    @mboland FWIW I've bodged things together using RCMAP - so it is doable. We really should locate that configuration file and document its use, 'though.
    André Kjellstrup
    @AndKe
    This may be somehow linked to the fact that Solex cannot longer change controller to sane, metric units after 4.0-dev install. The command did not change, so it is hard to explain why, but it does work via SSH, not from Solex. Also, in my installs, it did not switch to Mode1.
    Mike Boland
    @mboland
    @peterbarker Thanks for that, amazing how we overlook the obvious. I was able to use RCMAP to remap the input channels and RC2/RC3_REVERSE to get the direction right. What muddied the waters was I was following the Wiki at https://github.com/ArduPilot/ardupilot_wiki/blob/master/dev/source/docs/solo.rst which is wrong.
    André Kjellstrup
    @AndKe

    I do

    git checkout ArduCopter-beta 
    modules/waf/waf-light configure --board CubeGreen-solo ArduCopter

    then get

    [ 64/643] Compiling libraries/AP_Baro/AP_Baro_BMP280.cpp
    ../../libraries/AP_Airspeed/AP_Airspeed_UAVCAN.cpp:10:52: fatal error: uavcan/equipment/air_data/RawAirData.hpp: No such file or directory
     #include <uavcan/equipment/air_data/RawAirData.hpp>
                                                        ^
    compilation terminated.
    
    Waf: Leaving directory `/home/andre/prog/ardupilot/build/CubeGreen-solo'
    Build failed
     -> task in 'objs/AP_Airspeed' failed (exit status 1): 
        {task 140112187138256: cxx AP_Airspeed_UAVCAN.cpp -> AP_Airspeed_UAVCAN.cpp.0.o}
     (run with -v to display more information)
    • What am I doing wrong here ? (trying to compile current AC 4.0beta)
    Matt
    @Pedals2Paddles
    @AndKe , that isn't the right branch. The Copter 4 branch is called Copter-4.0. https://github.com/ArduPilot/ardupilot/tree/Copter-4.0
    ./waf distclean
    ./waf configure --board CubeGreen-solo
    ./waf copter
    Are the commands I use. I've never used the light waf
    André Kjellstrup
    @AndKe
    Thanks, I had master checked out.
    Akshath-Singhal
    @Akshath-Singhal
    Hi! Has anyone managed to upload the Arducopter.apj files to Solo using the WinSCP procedure? I have substituted the stock cube with a GreenCube (CubeBlack with shorted pads to increase the PWM voltage level) and I managed to upload the firmware using a USB cable and conduct flight tests. However, I have been trying to test some modifications of the code and thus need to upload custom firmware frequently. I tried copying the arducopter.apj file to /firmware folder but it doesnt get updated on reboot. Are there any additional steps required? Or any other scripts that need to be uploaded?
    André Kjellstrup
    @AndKe
    @Akshath-Singhal make sure you have updated px_uploader.py, or else it won't use .apj , only .hex - or use newer OpenSolo4
    Akshath-Singhal
    @Akshath-Singhal
    Thanks. I will give it a try.
    Matt
    @Pedals2Paddles
    pixhawk.py and uploader.py are needed If you don't want to just do the full open solo 4 install
    Matt
    @Pedals2Paddles
    Open Solo 4 has been released, available in Solex & SidePilot, or manually by SSH/SFTP. https://github.com/OpenSolo/OpenSolo/releases
    Alex Albert
    @alexaalbertt
    do you know any information about connecting this inertial navigation system to pixhawk or do you know a post
    indir.jpeg
    Alex Albert
    @alexaalbertt
    do you have any idea how to connect inertial sense uINS with pixhawk?
    Mike Boland
    @mboland
    Is anyone else having issues getting the firmware to load with Sidepilot?
    Previously all had worked perfectly and as I saw v4 was out I tried to update but Sidepilot will not load any firmware.
    I get a ‘timeout’ error in the firmware page.
    Have done the delete Sidepilot and reload as I noticed it wasn’t loading the Maps.
    That seems to be fixed but still no firmware.
    professorpip
    @professorpip
    Hi is anyone else having issues with/vagrant/solo-builder/builder.sh. I've followed the instructions on https://github.com/OpenSolo/OpenSolo/wiki#For_Developers (using Virtualbox and Vagrant on Windows) -

    vagrant@vagrant-ubuntu-trusty-64:~$ /vagrant/solo-builder/builder.sh

    Proceed with build? (y/n):y

    Yes! Proceeding with build.

    [ tup ] [0.002s] Scanning filesystem...
    [ tup ] [0.404s] Reading in new environment variables...
    [ tup ] [0.408s] No Tupfiles to parse.
    [ tup ] [0.409s] No files to delete.
    [ tup ] [0.421s] Executing Commands...
    [ ETA~=??? Remaining=68 Active=1 ] 0%.tup/tmp/output-742: Text file busy
    tup error: Unable to unlink sub-process output file.
    Command ID=742 failed: python tools/assetgen.py resources/assets.cfg src
    [ ETA~=??? Remaining=68 Active=0 ] 0%
    tup: 1 job failed.

    professorpip
    @professorpip
    I think I need to do source_sync.sh before ./builder.sh... I am trying this now
    Hmmm. it makes no difference.. same error!
    professorpip
    @professorpip
    Note - also seeing a similar thread at 3drpilots on this - https://3drpilots.com/threads/git-freescale-com.15511/#post-149937
    André Kjellstrup
    @AndKe
    Please have in mind this serious performance problem on IMX6 + OpenSolo4 / AC4.x : ArduPilot/ardupilot#13810
    professorpip
    @professorpip
    Further to my query 2 days ago - I got opensolo to build, once I changed git clone git://git.freescale.com/imx/meta-fsl-bsp-release to git clone --branch nxp/dora_3.10.17-1.0.0_GA https://source.codeaurora.org/external/imx/meta-fsl-bsp-release/
    professorpip
    @professorpip
    Hi... I got a 4G dongle working on the solo... I wonder if anyone has any info on how artoo actually pairs with a solo? Obviously it looks for a sololink ssid, and something at 10.1.1.10 but what else? Eg MAC address or some other unique identifier... I ask because I would like to get a raspberry pi to ‘spoof’ being a solo, so as to tunnel connection to the solo through a vpn).. I guess the answer lies in the artoo imx source code somewhere.
    professorpip
    @professorpip
    Hi - Does anyone know or have any info about artoo's IMX6 pinouts. I am wondering if the USB pins might be on one of the debug connector pins - Here's some close up photos of the board... https://3drpilots.com/threads/solo-controller-artoo-at11a-schematics-pinouts.15611/ I would like to connect a 4g Dongle to the artoo (I've already got a 4g dongle working on the solo via the USB OTG on the accessory port)...
    professorpip
    @professorpip
    FYI - Jordi at mRo has shared with me the solo and artoo schematics. He said they are ok to share publicly now, so I have attached theme here. https://3drpilots.com/threads/solo-controller-artoo-at11a-schematics-pinouts.15611/post-150078 ... I hope they could also be put on the opensolo github as well (as it makes sense to have the hardware schematics in the same place as the open source code)... Cheers...
    André Kjellstrup
    @AndKe
    Great ! - does ha have access to any Gimbal or BMS data as well ?
    professorpip
    @professorpip
    No... I guess I could ask Jordi
    But I don’t want to annoy him by being unreasonable and asking too much as once
    André Kjellstrup
    @AndKe
    @professorpip I understand, in time, tell him "thank you" from various people in the community, including me at NORCE (Norwegian research institute), and tell him that anything else like data/schematics/software for the gimbal or BMS configuration would be very much appreciated too.. basically, anything he can dig up.
    professorpip
    @professorpip
    Ok sure... nothing to loose !!