Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    Randy Mackay
    @rmackay9
    @RoboBil, ok thanks. Is it "Y" that's downwards or is it "Z"? I'd expect it to be Z actually.. It's been a while though and it's possible we made a mistake in the driver or the script
    RoboBil
    @RoboBil
    @rmackay9 Could be... and speaking of axis...Another thing I discovered to keep the axis "correct" is the tag should also be mounted vertically on your bot. This per where to place your anchors/tag page
    Randy Mackay
    @rmackay9
    I wonder if we should move this discussion over to a new "VisionProjects" channel in Discord (www.ardupilot.org/discord) . I'm not personally monitoring Gitter anymore except for this particular channel. Do @patrickpoirier51 and others have any opinion on this?
    patrickpoirier51
    @patrickpoirier51
    As they say...we've got to go with the flow
    RoboBil
    @RoboBil
    Sorry guys... I just didn't know where to post my question(s). I'm more than happy to switch to wherever you'all wish.
    patrickpoirier51
    @patrickpoirier51
    @rmackay9 Have you created the vision room on discord ?
    patrickpoirier51
    @patrickpoirier51
    Ok created
    Bye Bye Gitter, everyone's welcome to discord
    lightpathproject
    @lightpathproject
    Is there a link?
    Vinicius Juvinski
    @juvinski
    Joel Fankam
    @joekrom
    all right
    Bo Shang
    @cnpcshangbo
    It seems the discord invite is invalid now.
    Ian McElhenny
    @mcelhennyi
    ++, new discord link?
    Bo Shang
    @cnpcshangbo
    Yes.
    Vinicius Juvinski
    @juvinski
    Bo Shang
    @cnpcshangbo
    Thanks. It works.
    gauravshukla914
    @gauravshukla914
    Hi. Even this new link is invalid. Any other links? Can I still post my questions here?
    e-mendes
    @e-mendes
    Luis Vale Gonçalves
    @lvale
    Hi there, more and more discussion is moving to discord so you are all invited to join us over there! https://ardupilot.org/discord
    alikarimiyazdi
    @alikarimiyazdi
    Hi. I have a pixy1, pixymon v1.0.2 software and IR Lock firmware v1.0.3. I tested my pixy I2C and SPI interfaces with arduino and it’s ok. But when I connect it to my pixhawk2 cube and set parameters (In mission Planner : “PLND_ENABLED = 1”,“PLND_TYPE = 2” In Pixymon: “outport =1”,“Restore default parameter values”) Mission planner says “Bad Vision Position”. I tested my pixy with different copter versions like Copter v4.0.3 Hexa frame and Copter v3.6.11 Quadcopter frame. Also I changed PLND_BUS parameter to 1 and -1 in both states. I tested it with three different pixhawk2 cube but in all cases i had “Bad Vision Position” on HUD. :frowning:
    What Can I do else? any idea?
    lgh5054
    @lgh5054
    Hello.
    Is there any way to use the loiter with t256 when entering the indoor shading area after using gps from outside?
    Andrea Belloni
    @anbello
    Hello
    For now there is a PR from @rmackay9 for manual switching between GPS and T265 (ArduPilot/ardupilot#14803)
    Andrea Belloni
    @anbello
    Then, I think, next step will be to switch on the base of values that indicate the data from GPS has degraded, from GPS: GPS.HDop, GPA.HAcc, GPA.Vacc and / or from EKF: XKF4.SV, XKF4.SP ...
    But this is only free thinking i am not an expert.
    Anyway now all this discussions are moved to discord https://ardupilot.org/discord
    lgh5054
    @lgh5054
    @anbello Thanks !
    Fahad1994-coder
    @Fahad1994-coder
    Hello everyone can someone guide me on how to build Navio2 computer vision system that detect object to deliver payload. pls give guideline in hardware and coding if its possible!
    Huibean Luo
    @Huibean
    has anyone get numba working on rpi4?
    Huibean Luo
    @Huibean
    Hi @thien94 can your script https://github.com/thien94/vision_to_mavros/blob/master/scripts/d4xx_to_mavlink.py running on RPI4? trying to test it
    DeafMic
    @DeafMic

    Hi everyone. I am currently using RealSense t265 in combination with Nvidia TX2 (Auvidea j120 board) for precision landing on an AprilTag. There is currently a persistent issue with the camera starting to randomly spit NaNs for its odometry (camera_pose_frame). As a result, the transform can not be calculated. It never happens while the drone is in the air, however, when it is left on the ground stationary the issue arises. Restarting the camera node or unplugging the camera USB helps until the next randomly timed error. librealsense v2.36.0 is installed. Could be a faulty unit, however, I`ve seen other people having it with no clear solution to the problem.

    If anyone had a similar issue, I`d appreciate any help, as well as provide any additional information.

    Thanks in advance!

    Jaime Machuca
    @jmachuca77
    If the camera is pointing down and you are too close to the ground this is likely to happen as there will not be enough “texture” in the image to calculate a pose and it will loose track.
    DeafMic
    @DeafMic
    Thanks a lot for the reply. Indeed, it seems to be the case. However, how can this issue be counteracted effectively? My drone is sitting on the ground quite often. For now, since it doesn`t seem to recover on its own, I just made another node to restart the camera node automatically when NaN is detected. Seems like a very dirty solution to me. Is there anything else that can be done?
    Ed Muthiah
    @ed-muthiah
    @Fahad1994-coder For a Navio2 based vision system, check out Intelligent Quads on youtube, that should guide you. Depending on your camera you should be able to run TinyYolo from legged_robotics on the RPI4. You should look into how to send commands using MAVROS. That should get you a really basic vision system. Hardware wise, you can use a RPI Camera V2 to start and the move to Intel Realsense D435i. https://www.youtube.com/watch?v=AP1UC0DlIrE&list=PLy9nLDKxDN683GqAiJ4IVLquYBod_2oA6
    ddomit
    @ddomit

    Hello Everyone! Im trying to use precision landing with IRlock in RTL mode but it never uses it!

    IRlock works in precision loiter and in land but RTL does not work at all.

    The setup is a quadcopter with the latest version of arducopter.

    Anyone knows how to make RTL look for IRLock and use it for landing?

    ddomit
    @ddomit
    Apparently terrain follow has to be enabled , but it limits you to have the rtl alt to the rangefinder maximum alt
    aaronsims2020
    @aaronsims2020

    Hi All,

    I’m looking for roslaunch files for global planner and local planner px4 obstacle avoidance running intel realsense D435 on a real drone not in simulation.

    I will appreciate any thing you are able to provide because I’ve been hacking away at this for weeks and it’s the standard supported configuration in the obstacle avoidance project so it shouldn’t be difficult for somebody who has tested it or used it to just send me what you have so I can look it over and compare it with what I’m having.
    I think it’ll be a lot easier if I can just see what works and then adapt my files to that.

    I will very much appreciate your help.

    Sincerely,

    Aaron

    Hoang Anh Tran
    @ineq1512
    Hi guys, I have problem when using vicon system.
    When I use vicon as mav gps for my drone, the drone can not hovering, it drift instead.
    I already checked the orientation and it seem be true with respect to the NED frame.
    When I add the optical flow, the drone can hovering pretty good.
    So I think there might be have some problem with my vicon setup but I don't know which is problem.
    Can anyone help me with this? Thanks!
    Rohan Singh
    @rohansingh42
    Hi All,
    I am facing an issue with setpoint velocity/position in guided mode. I am using Cubeorange with arducopter 4.0.5, running mavros on a companion computer connected via usb on the fcu. I am using a slam system to give pose data(not using gps as it's for indoor flight) to the drone, and the message is being received by the fcu (i can see the message in mavlink inspector). After this, when i switch to guided mode and give it a setpoint velocity/position message from mavros, i don't see any movement from the drone, and it often just starts drifting randomly (in random directions). I don't know what logs to share that show i am sending setpoint velocity and it is not being used by the fcu, but if anyone can suggest anything i can share those logs. I have also tried doing the same out in the open with gps (and no slam) and i see similar behavior. At this point i have no idea how to debug this issue. I must also add that i have worked with similar setup in the past and have had no issue like this and really lost about what could cause this. Any help with this would be appreciated. Thanks.
    Carlos Vicente
    @cjmv

    Hey everyone, I've been playing around with mavros to interface a NVIDIA Jetson Nano and a Pixhawk through the GPIO to/from telemetry port. I'm launching mavros with the apm launch file.
    I'm able to arm/disarm successfully and although in a peculiar way, I'm also able to change to custom modes.
    So although I'm able to change modes with the command, for instance:
    rosrun mavros mavsys mode -c 1
    I still get an error " CMD: Unexpected command 11, result 0". But it does change the mode nevertheless (I can see it in Mission Planner)

    Although if I issue:
    rosrun mavros mavcmd int 176 0 1 0 0 0 0 0
    I get the error " CMD: Unexpected command 176, result 3"

    Shouldn't mavsys mode -c 1 use command 176?

    The other thing I've been trying to do is to test actuating on a servo, which should work by using MAV_CMD_DO_SET_SERVO, (command 183), although once again after issuing:
    rosrun mavros mavcmd int 183 1 1023 0 0 0 0 0
    I'm getting the error "CMD: Unexpected command 183, result 3"

    It's probably something really basic... but I can't put my finger on it.
    Any pointers?

    Vinicius Juvinski
    @juvinski
    I think you need to post on ardupilot’s discord channel - vision project
    Carlos Vicente
    @cjmv
    Hi @juvinski , who me? I have no problem on doing that. But what does that mean exactly? Does that mean that I will probably get better help on Discord than here? :-)
    Jaime Machuca
    @jmachuca77
    Yes the Gitter channels have been deprecated for a while new discussions should be done on discord
    Carlos Vicente
    @cjmv
    Hi @jmachuca77 , Thanks... will do then!
    Carlos Vicente
    @cjmv
    By the way... I'm looking for it on Discord but I can't see to find it in the Public Servers. What's the actual name of it?
    Vinicius Juvinski
    @juvinski
    try this
    1 reply
    Carlos Vicente
    @cjmv
    Will do... thanks!
    Hoang Anh Tran
    @ineq1512
    @juvinski can you sent me the discord invite link too?
    Vinicius Juvinski
    @juvinski
    Hoang Anh Tran
    @ineq1512
    Thanks
    ddomit
    @ddomit
    What do you think is the best tutorial for vision landing?