Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
Sophie Khan
@sophfk1
Im trying to run a python code, where i can simulate two drones on the apmplanner. Is this possible? If so, how??
I think im doing the maxproxy connections wrong
guglie
@guglie
@sophfk1 if you use sim_vehicle.py it will open mavproxy for you, use the instance option to create two different ports, remember also to set two different mav ids (SYSID_THISMAV parameter), then check also the output ports in mavproxy and then create two links in apmplanner
Sophie Khan
@sophfk1
@guglie how do you create two links in apmplanner?
ardupilotbot
@ardupilotbot
[unknown]
[ArduPilot/apm_planner] Pull request submitted by muramura
ArduPilot/apm_planner#1174
I created the configuration parameter file for AC 3.6.9 release version with the following command.
./Tools/scripts/build_parameters.sh
ardupilotbot
@ardupilotbot
[unknown]
[ArduPilot/apm_planner] New comment by Arne-W on pull request #1174: Copter: Change to setting parameter of AC 3.6.9 release version.
Nice - thank you a lot! thumbsup emoji
[unknown]
[ArduPilot/apm_planner] Pull request closed: ArduPilot/apm_planner#1174 by Arne-W
[unknown]
[apm_planner:master] 2 new commits by murata:
`ArduPilot/apm_planner@5ddba41Copter: Change to setting parameter of AC 3.6.9 release version. - murataArduPilot/apm_planner@e39ecf3` Copter: Add throwing mode and zigzag mode to flight mode selection item. - murata
ardupilotbot
@ardupilotbot
[unknown]
[ArduPilot/apm_planner] Pull request submitted by muramura
ArduPilot/apm_planner#1175
  1. I change from CH to RC. It became a radio control from the channel.
    1. I change from RC to SERVO. It distinguishes RC and SERVO.
    2. When SERVO is specified by the camera trigger of the camera gimbal, the setting item of the camera trigger can be changed.
ardupilotbot
@ardupilotbot
[unknown]
[ArduPilot/apm_planner] New comment by Arne-W on pull request #1175: Copter/CameraGimbal: Change from CH to RC, RC to SERVO
@muramura Thank you for participating to AP2. I will do the review as soon as possible.
Luis Vale Gonçalves
@lvale
What is the current build system for apm_planner on MacOS. I just tried QT5.13 with APM_Planner master and i’m getting lots of warnings (4000+) but compiled ok (and runs)
murata,katsutoshi
@muramura
@lvale san... I am building with qt 5.11.3 on ubuntu.
guglie
@guglie
@sophfk1 from the menu: communication > add link
@sophfk1
Arne Wischmann
@Arne-W
@lvale I am only building on ubuntu - so I cannot say anything about warnings on Mac. I know that we have a lot of them in third party code.
Arne Wischmann
@Arne-W
@sophfk1 I am not sure if handling 2 or more UAVs always work with AP2. Be careful when trying.
@sophfk1 please let me know wheter it works or not.
Sophie Khan
@sophfk1
@Arne-W I have not gotten it to work
ardupilotbot
@ardupilotbot
[unknown]
[ArduPilot/apm_planner] Pull request submitted by muramura
ArduPilot/apm_planner#1176
I want to change NULL notation to nullptr.
As C ++ language, nullptr is better than NULL.
ardupilotbot
@ardupilotbot

[unknown]
[ArduPilot/apm_planner] New comment by muramura on pull request #1175: Copter/CameraGimbal: Change from CH to RC, RC to SERVO
@Arne-W san...
Thanks for your comment.
The following file is unnecessary.

*I will delete it.*

src/ui/configuration/CameraGimbalConfig.cc.bug

ardupilotbot
@ardupilotbot
[unknown]
[ArduPilot/apm_planner] Pull request closed: ArduPilot/apm_planner#1175 by Arne-W
[unknown]
[apm_planner:master] 4 new commits by murata:
`ArduPilot/apm_planner@1d5704eCopter: Change from CH to RC - murataArduPilot/apm_planner@d9242a2CameraGimbal: Change from RC to SERVO - murataArduPilot/apm_planner@13480ccCameraGimbal: Enable setting of camera trigger group box - murataArduPilot/apm_planner@48c13a2` configuration: Delete unnecessary files - murata
[unknown]
[ArduPilot/apm_planner] New comment by Arne-W on pull request #1175: Copter/CameraGimbal: Change from CH to RC, RC to SERVO
Thank you thumbsup emoji
ardupilotbot
@ardupilotbot

[unknown]
[ArduPilot/apm_planner] Pull request submitted by muramura
ArduPilot/apm_planner#1177
I live in Japan.
I have many mountainous areas in Japan.
I want to use a map with elevations.
I want to be able to use the map of the Geographical Survey Institute of Japan.

Screenshot from 2019-07-28 21-10-46

ardupilotbot
@ardupilotbot

[unknown]
[ArduPilot/apm_planner] Issue created by wx4cb
ArduPilot/apm_planner#1178
HI

trying to install the armhf package on a raspberry pi 3 running ubuntu mate. following this thread over on "discuss". I get the error below. Any thoughts?

root@GroundStation:~# dpkg -i  apm_planner_2.0.26_xenial_armhf.deb
dpkg: error processing archive apm_planner_2.0.26_xenial_armhf.deb (--install):
 package architecture (armhf) does not match system (arm64)
Errors were encountered while processing:
 apm_planner_2.0.26_xenial_armhf.deb

root@GroundStation:~# uname -a Linux GroundStation 4.15.0-1032-raspi2 #34-Ubuntu SMP PREEMPT Wed Feb 6 11:46:23 UTC 2019 aarch64 aarch64 aarch64 GNU/Linux

ardupilotbot
@ardupilotbot
[unknown]
[ArduPilot/apm_planner] New comment by Arne-W on issue #1178: error trying to install on raspberry PI 3
@wx4cb The armhf package is build for ARM32 systems. You are using an ARM64 (aarch64) System.
Some Arm CPUs support both armhf and aarch64 - but your OS is an aarch64 one so it refuses to install the armhf package.
ardupilotbot
@ardupilotbot

[unknown]
[ArduPilot/apm_planner] New comment by wx4cb on issue #1178: error trying to install on raspberry PI 3
ok np. that's what i thought.it had something to do with that.

if i install 32 bit support would it work then? or would i have to try and
compile on the pi ?

On Sun, 4 Aug 2019 at 06:00, Arne Wischmann notifications@github.com
wrote:

@wx4cb https://github.com/wx4cb The armhf package is build for ARM32
systems. You are using an ARM64 (aarch64) System.
Some Arm CPUs support both armhf and aarch64 - but your OS is an aarch64
one so it refuses to install the armhf package.


You are receiving this because you were mentioned.
Reply to this email directly, view it on GitHub
https://github.com/ArduPilot/apm_planner/issues/1178?email_source=notifications&email_token=AALNCAKACDH3J53V5Z6LY7LQC2SDFA5CNFSM4IJB43TKYY3PNVWWK3TUL52HS4DFVREXG43VMVBW63LNMVXHJKTDN5WW2ZLOORPWSZGOD3P6LQA#issuecomment-517989824,
or mute the thread
https://github.com/notifications/unsubscribe-auth/AALNCAIRQESLXQ5YI4KCKWTQC2SDFANCNFSM4IJB43TA
.

ardupilotbot
@ardupilotbot
[unknown]
[ArduPilot/apm_planner] New comment by Arne-W on issue #1178: error trying to install on raspberry PI 3
@wx4cb Yes you could do that.... BUT as the package you are trying to install is REALLY old I would recommend to build the current master on the raspi for aarch64. I will take a while on that system but I think it is worth the effort as the current master has a lot of improvements and bug fixes compared to 2.0.26.

[unknown]
[ArduPilot/apm_planner] New comment by wx4cb on issue #1178: error trying to install on raspberry PI 3
i tried comppiling it 3 times on the pi, but it keeps crashing the pi. i'm
going to setup a cross compiler to do it when i get time

On Sun, 4 Aug 2019 at 06:36, Arne Wischmann notifications@github.com
wrote:

@wx4cb https://github.com/wx4cb Yes you could do that.... BUT as the
package you are trying to install is REALLY old I would recommend to build
the current master on the raspi for aarch64. I will take a while on that
system but I think it is worth the effort as the current master has a lot
of improvements and bug fixes compared to 2.0.26.


You are receiving this because you were mentioned.
Reply to this email directly, view it on GitHub
https://github.com/ArduPilot/apm_planner/issues/1178?email_source=notifications&email_token=AALNCAOQ6URUAPWL36V42VDQC2WJRA5CNFSM4IJB43TKYY3PNVWWK3TUL52HS4DFVREXG43VMVBW63LNMVXHJKTDN5WW2ZLOORPWSZGOD3P65QQ#issuecomment-517992130,
or mute the thread
https://github.com/notifications/unsubscribe-auth/AALNCAK5JGRYLGA5Y4QJGMLQC2WJRANCNFSM4IJB43TA
.

ardupilotbot
@ardupilotbot
[unknown]
[ArduPilot/apm_planner] New comment by Arne-W on issue #1178: error trying to install on raspberry PI 3
Hmm - perhaps you should try https://github.com/dockcross/dockcross|<https://github.com/dockcross/dockcross>. I have heard that it is easy to use - but never tried by myself. =)
ardupilotbot
@ardupilotbot
[unknown]
[ArduPilot/apm_planner] Pull request closed: ArduPilot/apm_planner#1177 by Arne-W
[unknown]
[apm_planner:master] 1 new commit by murata:
`ArduPilot/apm_planner@a022bed` map: Added Japan Map - murata
[unknown]
[ArduPilot/apm_planner] New comment by Arne-W on pull request #1177: map: Added Japan Map
thanks thumbsup emoji
ardupilotbot
@ardupilotbot

[unknown]
[ArduPilot/apm_planner] New comment by pushkalb123 on issue #260: Build error, missing sndfile.h
sudo apt-get install libsndfile1-dev

solve this problem

ardupilotbot
@ardupilotbot
[unknown]
[ArduPilot/apm_planner] New comment by wx4cb on issue #1178: error trying to install on raspberry PI 3
still no good. can't cross compile and can't compile on the pi. any other ideas anyone?
ardupilotbot
@ardupilotbot
[unknown]
[ArduPilot/apm_planner] New comment by dcarpy on issue #1178: error trying to install on raspberry PI 3
@wx4cb Create some swap space on the Pi before compiling. It is likely you are running out of memory.
ardupilotbot
@ardupilotbot
[unknown]
[ArduPilot/apm_planner] New comment by wx4cb on issue #1178: error trying to install on raspberry PI 3
@dcarpy i'll give that a try thnx.
ardupilotbot
@ardupilotbot
[unknown]
[ArduPilot/apm_planner] New comment by zakkhoyt on issue #1147: apmplanner2 requires version 5.9.0 or later, but QtOpenGL provides version 5.6.0
Had same issue as OP on macOS catalina beta 5. Daily build 2019-03-08
launches for me.
ardupilotbot
@ardupilotbot

[unknown]
[ArduPilot/apm_planner] New comment by wx4cb on issue #1178: error trying to install on raspberry PI 3

@wx4cb Create some swap space on the Pi before compiling. It is likely you are running out of memory.
ok that worked.

Now i have one more question. how do i make a binary package so that we can put it on a resources page so that everyone can get it that's trying to do the same thing.

ardupilotbot
@ardupilotbot
[unknown]
[ArduPilot/apm_planner] New comment by dcarpy on issue #1178: error trying to install on raspberry PI 3
Use debuild instead of make. You may have to install some additional packages.
[unknown]
[ArduPilot/apm_planner] New comment by dcarpy on issue #1178: error trying to install on raspberry PI 3
Don't forget to close this issue before you are done. :-)
ardupilotbot
@ardupilotbot
[unknown]
[ArduPilot/apm_planner] New comment by wx4cb on issue #1178: error trying to install on raspberry PI 3
i tried that, but it appears there's an issue with a libqt5declarative5 package that i can't find in the latest ubuntu mate
[unknown]
[ArduPilot/apm_planner] New comment by wx4cb on issue #1178: error trying to install on raspberry PI 3
charlesb@GroundStation:/usr/src/apm_planner$ debuild -us -uc y This package has a Debian revision number but there does not seem to be an appropriate original tar file or .orig directory in the parent directory; (expected one of apmplanner2_1.0.orig.tar.gz, apmplanner2_1.0.orig.tar.bz2, apmplanner2_1.0.orig.tar.lzma, apmplanner2_1.0.orig.tar.xz or apm_planner.orig) continue anyway? (y/n) dpkg-buildpackage -rfakeroot -us -uc -ui dpkg-buildpackage: info: source package apmplanner2 dpkg-buildpackage: info: source version 1.0-cb dpkg-buildpackage: info: source distribution UNRELEASED dpkg-buildpackage: info: source changed by Charles Blackburn <wx4cb at cfl dot rr dor com> dpkg-source --before-build apm_planner dpkg-buildpackage: info: host architecture arm64 dpkg-checkbuilddeps: error: Unmet build dependencies: git-buildpackage phonon libqt5multimedia5 libqt5positioning5 libqt5webkit5 libqt5webkit5-qmlwebkitplugin | qml-module-qtwebkit libqt5declarative5 qtcreator libsdl1.2-dev flite1-dev libopenscenegraph-dev libqt5webkit5-dev python-serial python-pexpect dpkg-buildpackage: warning: build dependencies/conflicts unsatisfied; aborting dpkg-buildpackage: warning: (Use -d flag to override.) debuild: fatal error at line 1152: dpkg-buildpackage -rfakeroot -us -uc -ui failed charlesb@GroundStation:/usr/src/apm_planner$ sudo apt-get install git-buildpackage phonon libqt5multimedia5 libqt5positioning5 libqt5webkit5 libqt5webkit5-qmlwebkitplugin | qml-module-qtwebkit libqt5declarative5 qtcreator libsdl1.2-dev flite1-dev libopenscenegraph-dev libqt5webkit5-dev python-serial python-pexpect qml-module-qtwebkit: command not found E: Unable to locate package libqt5webkit5-qmlwebkitplugin charlesb@GroundStation:/usr/src/apm_planner$ charlesb@GroundStation:/usr/src/apm_planner$ sudo apt-get install git-buildpackage phonon libqt5multimedia5 libqt5positioning5 libqt5webkit5 qml-module-qtwebkit libqt5declarative5 qtcreator libsdl1.2-dev flite1-dev libopenscenegraph-dev libqt5webkit5-dev python-serial python-pexpect Reading package lists... Done Building dependency tree Reading state information... Done E: Unable to locate package libqt5declarative5
ardupilotbot
@ardupilotbot
[unknown]
[ArduPilot/apm_planner] New comment by dcarpy on issue #1178: error trying to install on raspberry PI 3
Hmm...when you say latest Ubuntu Mate are you saying 18.04?
https://packages.ubuntu.com/xenial/libqt5declarative5 and
https://packages.ubuntu.com/bionic/allpackages?format=txt.gz
ardupilotbot
@ardupilotbot

[unknown]
[ArduPilot/apm_planner] New comment by wx4cb on issue #1178: error trying to install on raspberry PI 3
The latest download i beleive is based on bionic.

Ill post a listing wheen i get home later.

On Sun, Aug 18, 2019, 09:14 Dave C. notifications@github.com wrote:

Hmm...when you say latest Ubuntu Mate are you saying 18.04?
https://packages.ubuntu.com/xenial/libqt5declarative5 and
https://packages.ubuntu.com/bionic/allpackages?format=txt.gz


You are receiving this because you were mentioned.
Reply to this email directly, view it on GitHub
https://github.com/ArduPilot/apm_planner/issues/1178?email_source=notifications&email_token=AALNCAM72CIEY5XBHQUUSEDQFFDKHA5CNFSM4IJB43TKYY3PNVWWK3TUL52HS4DFVREXG43VMVBW63LNMVXHJKTDN5WW2ZLOORPWSZGOD4Q7ZWI#issuecomment-522321113,
or mute the thread
https://github.com/notifications/unsubscribe-auth/AALNCAJNX35ORRHYTUXVOHDQFFDKHANCNFSM4IJB43TA
.

ardupilotbot
@ardupilotbot

[unknown]
[ArduPilot/apm_planner] Pull request submitted by niuxw
ArduPilot/apm_planner#1179
Hello APM Planner developers,

I found a problem that the waypoints drawn on the map are not accurate. According to this post: https://discuss.ardupilot.org/t/inaccurate-waypoint-logging-with-toggle-switch/26636, I believed that the error come from the conversion from float to double value. APM Planner requests and write waypoints gps position in float, however, the Ardupilot system uses int32 to store the gps position for waypoints in default. So I changed the source code to make APM Planner request and write each waypoints in int32. The message ID for the mission item, which contains waypoint ID, should be MAVLINK_MSG_ID_MISSION_ITEM_INT rather than the MAVLINK_MSG_ID_MISSION_ITEM, and the mission item type should be mavlink_mission_item_int_t instead of mavlink_mission_item_t.

Thanks,
Xiangwei Niu

ardupilotbot
@ardupilotbot

[unknown]
[ArduPilot/apm_planner] Issue created by AlexisTM
ArduPilot/apm_planner#1180
I bought a recent Pixhawk Cube Black and I needed the latest update to be able to flash/recognize the Pixhawk.

I am using Bionic => Install from source (no daily for Bionic) and built the master: a022bedb9e07bbb5f3f37bb4d24bc4931dc3d6df

The result is that I could not flash the firmware unless APM Planner was started as sudo.

The dialout group is set and tested as I can flash PX4 from QGC.

ardupilotbot
@ardupilotbot
[unknown]
[ArduPilot/apm_planner] New comment by AlexisTM on issue #1180: [Linux][master] Fails to upload unless apm_planner is started as sudo
The issue is caused by a lock /var/lock/LCK..ttyACM0 file not cleaned properly. This was not cleaned by apm_planner2 after the flash thus it failed to connect.
ardupilotbot
@ardupilotbot
[unknown]
[ArduPilot/apm_planner] Issue closed: ArduPilot/apm_planner#1180 by AlexisTM
ardupilotbot
@ardupilotbot
[unknown]
[ArduPilot/apm_planner] Pull request submitted by AndKe
ArduPilot/apm_planner#1181