Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Jul 16 09:44
    JulianGoesPro commented #1264
  • Jul 16 09:43
    JulianGoesPro commented #1264
  • Jul 13 12:56
    Arne-W commented #1264
  • Jul 12 15:28
    JulianGoesPro edited #1264
  • Jul 12 15:28
    JulianGoesPro edited #1264
  • Jul 12 15:27
    JulianGoesPro edited #1264
  • Jul 12 15:26
    JulianGoesPro edited #1264
  • Jul 12 15:26
    JulianGoesPro opened #1264
  • Jul 05 14:16
    Arne-W closed #1262
  • Jul 05 14:16
    Arne-W commented #1262
  • Jul 05 14:13

    Arne-W on master

    Imported new Sik uploader from … (compare)

  • Jul 05 14:13
    Arne-W closed #1263
  • Jul 05 12:59
    humanoid2050 commented #1262
  • Jul 05 12:26
    AndKe commented #1262
  • Jul 05 08:45
    Arne-W commented #1262
  • Jul 05 08:44
    Arne-W opened #1263
  • Jul 05 07:12
    AndKe commented #1262
  • Jul 04 23:52
    humanoid2050 opened #1262
  • Jun 03 19:07
    Arne-W commented #1255
  • May 29 23:54
    muramura commented #1255
ardupilotbot
@ardupilotbot
[unknown]
[ArduPilot/apm_planner] New comment by liox1985 on issue #1213: APM Planner not working on MAC OS Catalina 10.15.3
Dear Experts please help
liox1985
@liox1985
ardupilotbot
@ardupilotbot

[unknown]
[ArduPilot/apm_planner] New comment by billbonney on issue #1213: APM Planner not working on MAC OS Catalina 10.15.3
From your screenshots it’s working.. Docs here https://ardupilot.org/planner2/index.html

(Just ignore any instructions to install serial port drivers for FTDI etc..)

ardupilotbot
@ardupilotbot
[unknown]
[ArduPilot/apm_planner] New comment by cmavr8 on issue #357: APM Planner crashes when trying to download more than one logs
This has been too long and I am not able to test the fix. Since there are no new reports/unhappy users let's close it. Thanks!
[unknown]
[ArduPilot/apm_planner] Issue closed: ArduPilot/apm_planner#357 by cmavr8

[unknown]
[ArduPilot/apm_planner] New comment by liox1985 on issue #1213: APM Planner not working on MAC OS Catalina 10.15.3
No its not working there is no option to detect FMU and select the frame to build ..

Install framwork screen is blank

ardupilotbot
@ardupilotbot
[unknown]
[ArduPilot/apm_planner] Issue closed: ArduPilot/apm_planner#1213 by billbonney

[unknown]
[ArduPilot/apm_planner] New comment by billbonney on issue #1213: APM Planner not working on MAC OS Catalina 10.15.3
support forum is here for using the app https://discuss.ardupilot.org/c/ground-control-software/apm-planner-2-0/72

You just need to select your device to see the screen https://ardupilot.org/planner2/docs/connect-autopilot.html

ardupilotbot
@ardupilotbot
[unknown]
[ArduPilot/apm_planner] New comment by DroneRookie on issue #1212: Ardupolit not working with mac
Sorry still not working, installed new drivers and changes USB cable as well.
ardupilotbot
@ardupilotbot

[unknown]
[ArduPilot/apm_planner] New comment by liox1985 on issue #1213: APM Planner not working on MAC OS Catalina 10.15.3
Finally managed to connect it however
Cannot see preloaded Models and Menu like (https://ardupilot.org/planner2/_images/ap2_connect-autopilot-connected-firmware-
<img width="1280" alt="Screenshot 2020-06-17 at 15 48 18" src="https://user-images.githubusercontent.com/64191743/84887201-094e9180-b0b3-11ea-8520-019b98edacff.png">

warning.png)

How to add them any reference

ardupilotbot
@ardupilotbot

[unknown]
[ArduPilot/apm_planner] New comment by liox1985 on issue #1213: APM Planner not working on MAC OS Catalina 10.15.3
Dear Experts,

Kindly assist with your inputs to proceed further ..

ardupilotbot
@ardupilotbot

[unknown]
[ArduPilot/apm_planner] Issue created by liox1985
ArduPilot/apm_planner#1214
Dear Experts,

Not able to view the menu after connecting PX4 (FMU2.x) using USB port
Apple OS - 10.15.3 (Catalina)
APM Version 2.0.26-2c1

Kindly assist .. Please refer attached pic

<|Uploading Screenshot 2020-06-17 at 15.48.18.png…>

ardupilotbot
@ardupilotbot
[unknown]
[ArduPilot/apm_planner] New comment by liox1985 on issue #1214: Not able to view the Models and Menu after opening Initial setup (PX4 Connected)
<img width="1280" alt="Screenshot 2020-06-17 at 15 48 18" src="https://user-images.githubusercontent.com/64191743/84992454-889c9d80-b165-11ea-8213-19e6f0be4e53.png">
ardupilotbot
@ardupilotbot
[unknown]
[ArduPilot/apm_planner] New comment by DroneRookie on issue #1212: Ardupolit not working with mac
Guys, one more step done, one more step conquered.
Now i am able to connect to APM planner and its able to find port as well.
I tried to install firmware for quadcopter, it got completed saying "APM flashing complete".
Unfortunately that's as far as i could go. Nothing happens after that.
Am I missing anything after that , do i need to do anything else to start my configuration.
I clicked on connect and screen is shown connected but there is no movement on the left side panel.
ardupilotbot
@ardupilotbot
[unknown]
[ArduPilot/apm_planner] Issue created by DroneRookie
ArduPilot/apm_planner#1216
Hello Experts,
Can any one help me with this ? I am new to drone world so excuse me for silly question.
I am getting an error message when i am trying to configure APM planner "PreArm: Compass not healthy " and don’t know how to fix it and its not letting me complete the configurations.
Also, i could configure RC in the APM planner and see that RC is connected to drone but its not making arming the motors( which was happening earlier, before i configured RC)
Any help will be highly appreciated.
ardupilotbot
@ardupilotbot
[unknown]
[ArduPilot/apm_planner] New comment by Arne-W on issue #1211: ./release/apmplanner2: No such file or directory
Sorry but this question is somewhat unspecific - there could be 1000 reasons for that.
Try to tell what you did and what happened. Were there any problems during compiling or while configuring??
ardupilotbot
@ardupilotbot
[unknown]
[ArduPilot/apm_planner] New comment by Arne-W on issue #1213: APM Planner not working on MAC OS Catalina 10.15.3
Please use the support forum - and update to the new version 2.0.28-rc1.
[unknown]
[ArduPilot/apm_planner] New comment by Arne-W on issue #1214: Not able to view the Models and Menu after opening Initial setup (PX4 Connected)
Please stop spamming
[unknown]
[ArduPilot/apm_planner] Issue closed: ArduPilot/apm_planner#1214 by Arne-W
ardupilotbot
@ardupilotbot
[unknown]
[ArduPilot/apm_planner] New comment by Arne-W on issue #1212: Ardupolit not working with mac
You should use the support forum... however in your home directory the should be a folder named apmplanner2. Within that folder you should find logfiles. Take a look - perhaps they can help to find out whats going wrong.
[unknown]
[ArduPilot/apm_planner] New comment by Arne-W on issue #1216: Error message prearm: compass not healthy
I think you will have to calibrate the compass.
Please go to the support forum there you will find a lot of informations regarding your problems.
This is only for software problems related to apmplanner itself.
Thank you
ardupilotbot
@ardupilotbot
[unknown]
[ArduPilot/apm_planner] New comment by DroneRookie on issue #1216: Error message prearm: compass not healthy
Thanks for your Arne-W.
I have tried to calibrate compass numerous times but i keep on getting error that "not enough data point" and calibration not complete.I have moved APM in all directions in order to get enough data points but i keep getting the same message.
Anyways thx for your replay
[unknown]
[ArduPilot/apm_planner] New comment by Arne-W on issue #1215: Undefined reference errors in libQt5Quick.so, libQt5Qml.so
You could use the official released AppImage you can find here.
did you install "qtdeclarative5-qtquick2-plugin"?
ardupilotbot
@ardupilotbot
[unknown]
[ArduPilot/apm_planner] New comment by Arne-W on issue #1216: Error message prearm: compass not healthy
Here you can find some hints: url|[https://youtu.be/DmsueBS0J3E](https://youtu.be/DmsueBS0J3E)
And stay away from magnetic things or metal when doing calibration.
[unknown]
[ArduPilot/apm_planner] Issue closed: ArduPilot/apm_planner#1216 by Arne-W
ardupilotbot
@ardupilotbot
[unknown]
[ArduPilot/apm_planner] New comment by Eric97 on issue #1215: Undefined reference errors in libQt5Quick.so, libQt5Qml.so
Thanks. qtdeclarative5-qtquick2-plugin is installed. I tried a fresh build on a clean Ubuntu 18.04, then compiles without problems. Guess there is a conflict with my other Qt dependent packages.
[unknown]
[ArduPilot/apm_planner] Issue closed: ArduPilot/apm_planner#1215 by Eric97
ardupilotbot
@ardupilotbot

[unknown]
[ArduPilot/apm_planner] New comment by liox1985 on issue #1214: Not able to view the Models and Menu after opening Initial setup (PX4 Connected)
Hi Team , Its not spam facing genuine issue with software to connect.

Please advice.

ardupilotbot
@ardupilotbot
[unknown]
[ArduPilot/apm_planner] New comment by billbonney on issue #1214: Not able to view the Models and Menu after opening Initial setup (PX4 Connected)
Use the latest release https://github.com/ArduPilot/apm_planner/releases and please look on the forum. (You have askes this question twice hence the spam reference)
ardupilotbot
@ardupilotbot

[unknown]
[ArduPilot/apm_planner] Issue created by Andr3g2
ArduPilot/apm_planner#1217
Hallo,

On "howto config pid" written like:
• set Ch6 Opt = CH6_RATE_KP....Min=0,1 ... Max=0,2
• use Ch6 poti and look changes on "Extended Tuning" after <Refresh Params>
but RAT_RLL_P already 0.1

it seems ExtendedTuning/Refresh reads values from the cache only. (see below)

version: v20.27_rc1
workaround: Full Parameter List: <Refresh>
then switch back to "Extended Tuning"
poss. solution: add: usecache=ignore if ch6opt!=none

regards Andre

`
$ apmplanner2.sh | egrep "ATCRAT..._P"
[20200718 19:33:12.167 DEBUG] - Param: "ATC_RAT_RLL_P" : QVariant(double, 0.1)
[20200718 19:33:12.257 DEBUG] - Param: "ATC_RAT_PIT_P" : QVariant(double, 0.1)
[20200718 19:33:12.262 DEBUG] - Param: "ATC_RAT_YAW_P" : QVariant(double, 0.12)
[20200718 19:33:16.460 DEBUG] - Param: "ATC_RAT_RLL_P" : QVariant(double, 0.1)
[20200718 19:33:16.462 DEBUG] - Param: "ATC_RAT_PIT_P" : QVariant(double, 0.1)
[20200718 19:33:16.560 DEBUG] - Param: "ATC_RAT_YAW_P" : QVariant(double, 0.12)
• "Extended Tuning" Refresh Params
[20200718 19:33:27.428 DEBUG] - Using param "ATC_RAT_PIT_P" from cache
[20200718 19:33:27.428 DEBUG] - Param: "ATC_RAT_PIT_P" : QVariant(double, 0.1)
[20200718 19:33:27.431 DEBUG] - Using param "ATC_RAT_RLL_P" from cache
[20200718 19:33:27.431 DEBUG] - Param: "ATC_RAT_RLL_P" : QVariant(double, 0.1)
[20200718 19:33:27.434 DEBUG] - Using param "ATC_RAT_YAW_P" from cache
[20200718 19:33:27.434 DEBUG] - Param: "ATC_RAT_YAW_P" : QVariant(double, 0.12)

...
[20200718 19:34:58.743 DEBUG] - Using param "ATC_RAT_RLL_P" from cache
[20200718 19:34:58.744 DEBUG] - Param: "ATC_RAT_RLL_P" : QVariant(double, 0.1)
[20200718 19:34:58.744 DEBUG] - BasicPID: "ATC_RAT_RLL_P" : 0.1
• Full Parameter List: Refresh
[20200718 19:35:17.129 DEBUG] - Param: "ATC_RAT_RLL_P" : QVariant(double, 0.121)
[20200718 19:35:17.129 DEBUG] - BasicPID: "ATC_RAT_RLL_P" : 0.121
[20200718 19:35:17.133 DEBUG] - Param: "ATC_RAT_PIT_P" : QVariant(double, 0.121)
[20200718 19:35:17.226 DEBUG] - Param: "ATC_RAT_YAW_P" : QVariant(double, 0.12)

``\

Randy Mackay
@rmackay9
Hi there, more and more discussion is moving to discord so you are all invited to join us over there! https://ardupilot.org/discord
Billy Mullins
@tweetbmullins_twitter
Hey Gang, How would I go about figuring out what would need to be implemented in firmware to support the minimum mavlink functionality? I'm thinking about trying to fit the appropriate mavlink messages into the http://www.brokking.net/ymfc-32_auto_main.html, which is an STM32 home grown quad copter. Where is example firmware source? Or just the messages that would need to be sent/received/protocol. Thanks.
islemhm
@islemhm
hello i have a problem in APMplanner, i use ubuntu 18.04 and this version of apm planner "apm_planner_2.0.26_bionic64.deb"This is my 'install firmware' screen which is blank in both disconnected & connected state (I'm trying to configure my pixhawk1 for the first time)
Any ideas why this is occuring and how do I fix this?
image.png
André Kjellstrup
@AndKe
@islemhm yes, that is a known error due to come changes in the firmware paths. Clone the apmplanner from github and build it yourself, it will work just fine then.
islemhm
@islemhm
@AndKe thanks for answering me but how i build it?
islemhm
@islemhm
@AndKe I followed this tutorial to install it
https://github.com/ArduPilot/apm_planner
André Kjellstrup
@AndKe
@islemhm just start reading here: https://github.com/ArduPilot/apm_planner#install-qt
you need QT , for example 5.12.6 - it can be the free/community edition QT, no need for the expensive one.
then move on to the next step , make and make .. and done. :)
Arne Wischmann
@Arne-W
@islemhm look here https://github.com/ArduPilot/apm_planner/releases there you can fine an Appimage which will work without installing
and take the 2.0.29 RC1
Its only tested for copters - never had a Rover and therefore never tested rovers... So Sorry
Arne Wischmann
@Arne-W
Perhaps QGroundcontrol can help you configure your rover?
islemhm
@islemhm
@Arne-W yes I installed qground control but during the pixhawk configuration in the radio step I could not deactivate because I did not have a controller
André Kjellstrup
@AndKe
@Arne-W please see: ArduPilot/apm_planner#1240 it's a shame, but I learned just now that there is a appimage, I thought for years that Linux users needed to compile it.. and did it on all field-laptops at work :)
islemhm
@islemhm
image.png
hello ihave this problem in apm _planner i use ubuntu 18.04
Tim Tuxworth
@timtuxworth
I'm trying to install APM Planner on my Mac running 11.5 Big Sur and I had to run 2.0.28 to get it to work, but the notes says flashing firmware won't work with this version, which I will need for my brand new PixRacer R15, and there is no Mac version for 2.0.29. Is the Mac version coming?
FiorellaZampetti
@FiorellaZampetti
Hi all,

We are a team of researchers from the University of Sannio (Italy) that is conducting research on the adoption and use of simulators for developing cyber-physical systems (CPSs). This is a non-profit research conducted as part of the European H2020 Project COSMOS “DevOps for Complex Cyber-Physical Systems” https://www.cosmos-devops.org.

We would be grateful if you could participate in the survey. It is composed of only 6 questions, and it will take no longer than 5 minutes. Participation in this survey is voluntary and confidential. No personal information is mandatory, and personal data will be treated as strictly confidential.

The goal of this survey questionnaire is to investigate how and why open-source developers adopt simulators, as well as hardware-in-the-loop, during their normal development tasks.

We will store data in compliance with the GDPR (General Data Protection Regulation). By completing this survey, you are consenting to participate in this study.

Please click on the link below to fill in the survey:
https://surveyhero.com/c/pdnmpqzt

We thank you in advance for your collaboration. We will only analyze aggregated data, and individual responses will not be traced back to an individual respondent. If you have questions about the questionnaire or our research, please do not hesitate to contact us.

Fiorella Zampetti, fzampetti@unisannio.it, fiorellazampetti@gmail.com
Vittoria Nardone, vnardone@unisannio.it
Massimiliano Di Penta, dipenta@unisannio.it