These are chat archives for Automattic/mongoose

10th
Feb 2018
Mark Stosberg
@markstos
Feb 10 2018 15:09
Since we upgraded from Mongoose 3.8.x to 4.13.x, connections to the primary only increase until the app or database restart, eventually exhuasting hardware resources. Connections to primary only go up after Mongoose 4.x upgrade Any ideas what could be causing this?
Kev
@lineus
Feb 10 2018 15:17
are you seeing any errors in your application's logs?
Mark Stosberg
@markstos
Feb 10 2018 15:23
@lineus Log activity seems to look normal. I just checked db.currentOps(), and there's very little going on (like 5 current operations, but 5,000+ connections. It seems like something isn't closing connections anymore.
Kev
@lineus
Feb 10 2018 15:29
@markstos you're probably aware of this already, but there were several breaking changes from 3 to 4.
that list might help give you a place to start
Mark Stosberg
@markstos
Feb 10 2018 15:43
@lineus I was aware of the breaking changes and reviewed the carefully. Due to my testing, I even got a new item added to the list. Do you think it could be an issue that I added useMongoClient:true to my connection string? I see that this enabled "new connection logic", but I haven't yet been able to confirm what I opted into. :) I appreciate your prodding questions to move this forward. I'll be sure to share what I find here.
Kev
@lineus
Feb 10 2018 15:46
yeah, I'm fairly new to just about all of this :) but I know what it feels like to scream into the void of a quiet channel so I try and speak up even when I'm hopelessly out matched by a question :)
valeri has a good explanation of usemongoclient on his blog here
Kev
@lineus
Feb 10 2018 15:52
and I frequently forget to mention folks, lol. @markstos ^
Mark Stosberg
@markstos
Feb 10 2018 15:52
@lineus Ha, I also sometimes try to be helpful even when I don't know all the answers. Thanks, I'll check out that link.