These are chat archives for AvaloniaUI/Avalonia

5th
Dec 2017
Jeremy Koritzinsky
@jkoritzinsky
Dec 05 2017 00:34
Sounds good!
Steven Kirk
@grokys
Dec 05 2017 08:58
VS 15.5 seems to have fixed a lot of the hangs! (not used it that much yet though so there's still time)
seems a lot better so far though
danwalmsley
@danwalmsley
Dec 05 2017 12:05
@grokys do you need a repro for issues introduced with #1284 or
Steven Kirk
@grokys
Dec 05 2017 12:12
yeah, was waiting for your simple repro!
Steven Kirk
@grokys
Dec 05 2017 16:18
regarding #1151 do you think it's worth setting up an https://opencollective.com/ account and seeing what happens? @kekekeks @jkoritzinsky @danwalmsley etc
we could at least use it at first for i dunno, AWS servers etc?
Nikita Tsukanov
@kekekeks
Dec 05 2017 16:20
It it doesn't cost us anything
I don't see any reasons not to
Steven Kirk
@grokys
Dec 05 2017 16:21
i'll set up an account then
Jeremy Koritzinsky
@jkoritzinsky
Dec 05 2017 16:21
Sounds good to me
Steven Kirk
@grokys
Dec 05 2017 16:24
ok, applied to create an account
Jeremy Koritzinsky
@jkoritzinsky
Dec 05 2017 16:57
Did you guys see this? xamarin/Xamarin.Forms#1317
Ill take a look at implementing this in Avalonia as well.
Darnell Williams
@Seeker1437
Dec 05 2017 16:59
@kekekeks can I pm you really quick?
Hey everyone!
Hey everyone! What's new in Avalonia?
Krutonium
@Krutonium
Dec 05 2017 17:01
All Hail the Hyptnotoad
Darnell Williams
@Seeker1437
Dec 05 2017 17:02
?
Oh glowing eyes
Matthijs ter Woord
@mterwoord
Dec 05 2017 17:41
@grokys Could you keep me posted on general thoughts/progress/etc/etc on opencollective?
please
Steven Kirk
@grokys
Dec 05 2017 17:42
sure
Matthijs ter Woord
@mterwoord
Dec 05 2017 18:18
fyi, i'm closing in on the beaglebone graphics issue i'm having. (with my own yocto build of linux)
Matthijs ter Woord
@mterwoord
Dec 05 2017 19:05
hmm, it seems it just works fine, but the window i was testing with had all controls removed and a black background
go figure what my suspected wrong behavior was.. :)
Paul Lyon
@pmlyon
Dec 05 2017 20:55
hi, i just started using avalonia, when i'm doing databinding is it possible for me to specify a format string for my values? previously with wpf i'd use contentformatstring
Nikita Tsukanov
@kekekeks
Dec 05 2017 21:01
FormatString is not yet supported
It should be trivial to create a converter that accepts a format string as a parameter
So you can use it as a workaround
Paul Lyon
@pmlyon
Dec 05 2017 21:22
kk, thanks for confirming for me!
Steven Kirk
@grokys
Dec 05 2017 21:47
danwalmsley
@danwalmsley
Dec 05 2017 23:50
@grokys @jkoritzinsky @kekekeks you guys know about this Span<T> type, supposed to help reduce unnecessary allocations, perhaps it might help improve performance in Avalonia?
Jeremy Koritzinsky
@jkoritzinsky
Dec 05 2017 23:51
It might help at the interoperability layers but I'm not sure if we have places it will help in upper layers.