These are chat archives for AvaloniaUI/Avalonia

6th
Feb 2018
Nikita Tsukanov
@kekekeks
Feb 06 2018 08:49 UTC
go ahead without the updated VS extension
I guess so
It works after all
Actually, I might try to adapt old previewer infrastructure to .NET Core
Since we don't depend on winforms anymore
Nikita Tsukanov
@kekekeks
Feb 06 2018 08:56 UTC
Hmmm
Nope, designer host uses WPF inside host process
Pavel Zhdanovich
@SWATOPLUS
Feb 06 2018 11:06 UTC
Where can I find examples of the custom renderer implementation shown in this demo. https://youtu.be/8qzqweimcFs?t=1480
I'm interested in SharpDx and drawing into html canvas.
Steven Kirk
@grokys
Feb 06 2018 11:55 UTC
@SWATOPLUS there are some interop demos here https://github.com/AvaloniaUI/Avalonia/tree/master/samples/interop, not sure if that's what you're looking for?
Pavel Zhdanovich
@SWATOPLUS
Feb 06 2018 12:07 UTC
I am looking for samples, which rendering into nonwindow context, such as html canvas on the client side.
Steven Kirk
@grokys
Feb 06 2018 12:33 UTC
ah ok, i don't know about that, and unfortunately i don't speak russian ;)
@kekekeks :point_up:
Pavel Zhdanovich
@SWATOPLUS
Feb 06 2018 12:35 UTC
It's ok, this question is directed to Nikita
Chris Pie
@kpietraszko
Feb 06 2018 18:11 UTC
Hi, I'm having trouble getting Desginer/Previewer to work. I'm using latest nightly and it's .net core 2.0 project. Do I still need to multi target (with net461) as it used to be?
Steven Kirk
@grokys
Feb 06 2018 18:13 UTC
@kpietraszko yes i think the designer doesn't support .net core yet
Chris Pie
@kpietraszko
Feb 06 2018 18:28 UTC
@grokys Thanks, I eventually managed to multi-target without error about package downgrade and now it's fully operational. Huge potential in this framework, keep up the good work.
Steven Kirk
@grokys
Feb 06 2018 18:28 UTC
thanks @kpietraszko!
Per Westerlund
@RexTremendae
Feb 06 2018 22:33 UTC
Hi there Avalonia pros! I have a - possibly strange - question. How is the AppBuilder.SetupWithoutStarting() method supposed to work? If I call it before I call the Start<Window>() method, the UI is showing but is totally non-responsive. Anybody know why?