These are chat archives for AvaloniaUI/Avalonia

11th
Feb 2018
Big Jake
@jakesays
Feb 11 2018 00:05
wonder how hard it would be to put xamarin forms over avalonia
Gutemberg Ribeiro
@galvesribeiro
Feb 11 2018 00:55
@jkoritzinsky is skia backend requires windowing from any well-known windowing subsystem or can we just use skia pointing to a buffer and we are fine?
@jakesays I have skia running on ARM from ages. It works pretyt well btw... And regarding XForms, I believe if the problems I had in the past with Avalonia in ARM were solved, and with the support to Skia as backend, run XForms should be pretty simple tbh as it is just bindings on top of native platform controls...
Jeremy Koritzinsky
@jkoritzinsky
Feb 11 2018 01:10
The skia backend can render to a bitmap if you want. We also have support for Linux framebuffers
Gutemberg Ribeiro
@galvesribeiro
Feb 11 2018 01:10
Thanks man! Linux framebuffer is what I meant when I mentioned buffer
:)
I plan to give it a try on my devices once more and they are all based on linux framebuffers :)
I just need to build Mono latest versions again :)
Gutemberg Ribeiro
@galvesribeiro
Feb 11 2018 02:12
@jkoritzinsky any samples on linux framebuffer usage?
Jeremy Koritzinsky
@jkoritzinsky
Feb 11 2018 02:23
@kekekeks knows more about it than I do.
Gutemberg Ribeiro
@galvesribeiro
Feb 11 2018 02:23
:+1:
Gutemberg Ribeiro
@galvesribeiro
Feb 11 2018 12:16
@kekekeks just that? O.o
Brad
@BPattersonRaven
Feb 11 2018 21:35
Hey guys, I have taken the plunge into updating my program from 0.5.1 to nightly. Upon starting my program I get an error I did not have before Message "Value cannot be null.\r\nParameter name: xamlType" originating from my MainView.xaml.cs AvaloniaXamlLoader.Load(this);. Anyone seen this before or know where I should start looking? Cheers.
Jeremy Koritzinsky
@jkoritzinsky
Feb 11 2018 21:42
Did you update your markup extensions? We've removed a few that Portable.Xaml now supplies. And we've moved from StyleResource to StaticResource/DynamicResource
Brad
@BPattersonRaven
Feb 11 2018 21:48
No I have not made any changes to the rest of my code yet, just enough to get it to build. I'll have a look into making those changes.
Brad
@BPattersonRaven
Feb 11 2018 22:09
Changing StyleResource to StaticResource did the trick but I have run into another upgrade issue. "Property '{clr-namespace:Avalonia.Controls;assembly=Avalonia.Controls}ContentControl.Content' is already set to this '{clr-namespace:Avalonia.Controls;assembly=Avalonia.Controls}Button' object"
Brad
@BPattersonRaven
Feb 11 2018 22:14
I placed Svg's within a button changing which one was visible depending on a bool (for a pause/play button) it seems to have triggered that exception