by

Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • 22:44
    grokys synchronize #4029
  • 22:44

    grokys on 4002-devtools-selected-node

    Import Fluent Slider avoid divide by zero add base apply template method and 11 more (compare)

  • 22:43
    danwalmsley synchronize #4083
  • 22:43

    danwalmsley on control-catalog-theme-switch

    fix resolving theme. (compare)

  • 22:42
    danwalmsley synchronize #4083
  • 22:42

    danwalmsley on control-catalog-theme-switch

    set background to something sen… (compare)

  • 22:35
    danwalmsley synchronize #4083
  • 22:35

    danwalmsley on master

    RepeatButton should use same st… Add example for RepeatButton Merge branch 'master' into feat… and 2 more (compare)

  • 22:35
    danwalmsley closed #4084
  • 22:27
    danwalmsley synchronize #4084
  • 22:26
    danwalmsley synchronize #4074
  • 22:25

    danwalmsley on fluent-slider-port

    (compare)

  • 22:25

    danwalmsley on master

    Import Fluent Slider avoid divide by zero add base apply template method and 5 more (compare)

  • 22:25
    danwalmsley closed #4051
  • 22:24
    danwalmsley synchronize #4051
  • 22:24
    danwalmsley synchronize #4051
  • 22:24

    danwalmsley on fluent-slider-port

    Benchmark and simple optimizati… Implemented custom format suppo… Naming and 23 more (compare)

  • 22:21
    maxkatz6 synchronize #4084
  • 22:18
    maxkatz6 opened #4084
  • 22:15
    grokys synchronize #4029
John Buczkowski
@SCLD-JBuczkowski
In theory, is this a viable option?
I have the following pretty simple view definition:
<Window xmlns="https://github.com/avaloniaui" xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml" xmlns:d="http://schemas.microsoft.com/expression/blend/2008" xmlns:mc="http://schemas.openxmlformats.org/markup-compatibility/2006" xmlns:dxnav="http://schemas.devexpress.com/winfx/2008/xaml/navigation" xmlns:dxlc="http://schemas.devexpress.com/winfx/2008/xaml/layoutcontrol" xmlns:dxwui="http://schemas.devexpress.com/winfx/2008/xaml/windowsui" xmlns:vm="clr-namespace:MyMvvmApp.ViewModels;assembly=MyMvvmApp" mc:Ignorable="d" d:DesignWidth="800" d:DesignHeight="450" x:Class="MyMvvmApp.Views.MainWindow" Icon="/Assets/avalonia-logo.ico" Title="MyMvvmApp">

<dxnav:OfficeNavigationBar >
<dxnav:NavigationBarItem>One</dxnav:NavigationBarItem>
<dxnav:NavigationBarItem>Two</dxnav:NavigationBarItem>
</dxnav:OfficeNavigationBar>

</Window>
I get the following compile time errors:
Severity Code Description Project File Line Suppression State
Error Unable to resolve type OfficeNavigationBar from namespace http://schemas.devexpress.com/winfx/2008/xaml/navigation (line 43 position 10) Line 43, position 10. MyMvvmApp C:\avalonia\sandbox\MyMvvmAppWithDevExpress\Views\MainWindow.xaml 43
Error XAMLIL Unable to resolve type OfficeNavigationBar from namespace http://schemas.devexpress.com/winfx/2008/xaml/navigation (line 15 position 10) Line 15, position 10. MyMvvmApp C:\avalonia\sandbox\MyMvvmAppWithDevExpress\Views\MainWindow.xaml 15
John Buczkowski
@SCLD-JBuczkowski
I pretty much copied from existing WPF project. I'm not sure how to go about trying to figure out this issue.
Is it a namespace resolution issue?
Benedikt Stebner
@Gillibald
This will not work. The DevExpress components need to be built against Avalonia and that will require more than just a recompile.
Avalonia is very similar to WPF but not a 1:1 replacement
Splitwirez
@Splitwirez
I'm noticing there are a lot of Issue posts regarding window transparency on Windows, to many of which the response has been something to the effect of "once Windows 7 support ends, we can use DwmEnableBlurBehindWindow or DwmExtendFrameIntoClientAreato get blurred transparency on Windows". Problem is, that's straight-up incorrect - those APIs only produce blur on Windows Vista and 7. On Windows 8 and newer, they just produce an opaque solid colour, and in all cases, the affected window is, in one way, or another, coloured to match the user's Window frames. The only time you'd get blur out of those APIs on Windows 8 or newer is with that Aeroglass program installed ( http://glass8.eu/ )...surely that's not going to be required, right?
John Buczkowski
@SCLD-JBuczkowski
@Gillibald : I think we have access to the DevExpress source. If I were to be ambitious and try to rebuild DevExpress with Avalonia, are there any additional libraries/packages that I would need?
Benedikt Stebner
@Gillibald
@SCLD-JBuczkowski It depends on the API's that are being used. If they directly use DirectX to render some components like Telerik does this would be much more work. Also, Storyboards are currently not supported. I think we need some kind of compatibility check for migrating from WPF to Avalonia in the future to make this task easier.
Nikita Tsukanov
@kekekeks
I don't think that we should consider Win7 to be not supported at least until 2023...
ahopper
@ahopper
recent download figures for my app are win10x64 143 win7x86 40 linuxx64 70. I tried to drop win7 a year ago or so and it was not popular.
Nikita Tsukanov
@kekekeks
In one of our apps we've dropped XP support somewhere around 2017
and there still were tons of complaints
ahopper
@ahopper
I have had requests for xp support:)
Nikita Tsukanov
@kekekeks
I think it could be done with corert
just quite a bit of work
ahopper
@ahopper
don't tell my users it is possible:) xp embedded only got to end of life last year and win 7 embedded has a bit more time.
Jose C Gomez
@josegomez
good morning, quick question re: localization
I can't find much info on that, does Avalonia have a prefered method to support localization language in particular using resource files or assets?
Benedikt Stebner
@Gillibald
Using a MarkupExtension should work
Jose C Gomez
@josegomez
MarkupExtension eh... not familar I'll do some googling
any avalonia specific pointers or examples ?
Benedikt Stebner
@Gillibald
I don't have ported my extension to Avalonia yet sry
Binding for example is a MarkupExtension
Would look like so for example Text="{loc:Loc MyResourceName}"
Jose C Gomez
@josegomez
thanks, I'll play with it
Nikita Tsukanov
@kekekeks
Meanwhile 8K stars on github
Jose C Gomez
@josegomez
🎉🎉
Jose C Gomez
@josegomez
would something like this be worth doing a PR on the Avalonia side of things?
Nikita Tsukanov
@kekekeks
a library in AvaloniaCommunity org
localization is a bit controversial
so it would be unwise to try to force a default approach
Jose C Gomez
@josegomez
hmm interesting fair enough, I'd be willing to throw this in a library in that org if it makes sense or I can just put it out as a nuget too if it helps, just trying to contribute some since you guys have been so awesome
Alexander
@openmandev

I have dynamical TabControl:

    <TabControl Items="{Binding TabsList}" SelectedItem="{Binding SelectedTab}" HorizontalAlignment="Stretch" HorizontalContentAlignment="Stretch">

I have a synchronous command in dynamicaly fullfilled ContextMenu in TreeView in one Tab:

      Calibrate = ReactiveCommand.Create
      ( () =>
        {
          CalibrateTabOpen((SelectedNode as TankItem).stnk.tnk);
          // Dispatcher.UIThread.Post((Action)(() => CalibrateTabOpen((SelectedNode as TankItem).stnk.tnk)));
        }
      );

This command raise an event:

    public Unit CalibrateOpen(ecb.t_tnk tnk)
    {
      UserTabItem userTab = new UserTabItem() { TabImage = "Assets/clb.png", TabTitle = "Перечень тарировок", TabType = UserTabItem.UserTabType.CALIBRATES };
      CalibrateViewModel calibrateViewModel = new CalibrateViewModel(userTab,tnk,httpContext);
      TabsList.Add(calibrateViewModel);
      SelectedTab = calibrateViewModel;
      return Unit.Default;
    }

After clicking menu I've got the new Tab, but also I've got an empty ContextMenu (very small rectangle) above my new Tab in the same position where it was before. This empty menu disappeares by clicking in any area. How can I avoid this strange behavior?

K0beBean
@K0beBean
hey is there a reason why I can't disable a NativeMenuItem? I'm setting Enabled to false but its still clickable. I can set its Header so thats working
Steven Kirk
@grokys
@openmandev sounds like a bug. could you open an issue with a minimal repro and i'll try to fix it
Alexander
@openmandev
@grokys , ok, a little bit later.
Nikita Tsukanov
@kekekeks
@K0beBean which OS?
K0beBean
@K0beBean
Windows 10
Nikita Tsukanov
@kekekeks
Mkay, that should be easy to fix
We are missing the binding here
K0beBean
@K0beBean
ah ok. also it looks like theres no Name so you cant use FindControl, is that intentional
Nikita Tsukanov
@kekekeks
you can copy-paste that style to your App.xaml and add <Setter Property="IsEnabled" Value="{Binding Enabled}"/>
native menu items aren't controls
K0beBean
@K0beBean
thanks