Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    lenjoyn
    @lenjoyn
    If this is really a typo, I will make a pull request to fix it (and also make a readme.md or something to remind new users the content should be download)
    avinmaulana
    @avinmaulana
    Hello, everyone.
    It is possible to run matcaffe using newer version of matlab in ubuntu? the mex of matlab only support gcc 4.7, the gcc version of newer ubuntu only supported >4.8 (afaik).
    Any ideas?
    Thanks for the help
    Radhika Dua
    @Radhikadua123

    Hi,

    I could install caffe easily using conda create -n caffe_gpu -c defaults python=3.6 caffe-gpu.
    But I want to compile the feature/20160617_cb_softattention branch of caffe as it contains some functions that i need to use. By following the compile steps given in the official documentation, it fails.
    What steps should I follow?

    Thanks in advance!

    Radhika Dua
    @Radhikadua123

    Hi,

    While installing caffe I am getting this error:

    protobuf/generated_message_table_driven.h(210): error: static assertion failed with ""
    
    1 error detected in the compilation of "/tmp/tmpxft_00007fe0_00000000-17_absval_layer.compute_61.cpp1.ii".
    Makefile:585: recipe for target '.build_release/cuda/src/caffe/layers/absval_layer.o' failed
    make: *** [.build_release/cuda/src/caffe/layers/absval_layer.o] Error 1

    Please share how can I fix it.

    Robert Nsinga
    @bobuntu
    Could you provide more details @Radhikadua123??
    mu
    @aishangjj
    :q
    Prashant Dandriyal
    @PrashantDandriyal
    Hello!
    I am working on FeatherCNN which is based on Caffe and I can't use the library as the Caffe output blob is not accessible to me. Please help if someone has experience of FeatherCNN library...Thanks in advance
    xiaofashi
    @wangmaodada
    Hello, the author, I have a question to consult. My former supervisor used your Caffe to make a model to identify the teapot. I didn't leave a document after leaving office. I want to learn about the use of Caffe, but the official instructions are not clear. Can you tell me how to start the identification? How do I turn off recognition?
    Vladislav Denisov
    @381706-1-DenisovVladislavL
    Hello! Can I check whether CPU or GPU mode is supported right at runtime to set the set_mode_cpu() or set_mode_gpu() parameter respectively?
    Farid
    @mrgransky
    Besides Caffe Model Zoo, is there other pages providing pretrained CNNs on Caffe? I found https://modelzoo.co/framework/caffe with some but details are missing !
    Dhiren Hamal
    @dhiren-hamal

    Hello! Guys,
    I want to run deeplab v2 with caffe. I have ubuntu 14.04, cuda7, cudnn4, opencv3 in docker. While compiling I got "./include/caffe/util/device_alternate.hpp:34:23: fatal error: cublas_v2.h: No such file or directory

    include <cublas_v2.h>" error.

    I am stuck with this problem from last a couple of days. Please help me.

    Mário Almeida
    @4knahs
    What is the default way to run caffe models on android (arm) GPUs?
    fernandoc1
    @fernandoc1
    In file included from /home/fccoelho/Code/caffe/src/caffe/util/math_functions.cu:1:0:
    /usr/local/cuda/include/math_functions.h:54:2: warning: #warning "math_functions.h is an internal header file and must not be used directly.  This file will be removed in a future CUDA release.  Please use cuda_runtime_api.h or cuda_runtime.h instead." [-Wcpp]
     #warning "math_functions.h is an internal header file and must not be used directly.  This file will be removed in a future CUDA release.  Please use cuda_runtime_api.h or cuda_runtime.h instead."
      ^~~~~~~
    In file included from /usr/local/cuda/include/cuda_runtime.h:115:0,
                     from <command-line>:0:
    /usr/local/cuda/include/crt/common_functions.h:74:24: error: token ""__CUDACC_VER__ is no longer supported.  Use __CUDACC_VER_MAJOR__, __CUDACC_VER_MINOR__, and __CUDACC_VER_BUILD__ instead."" is not valid in preprocessor expressions
     #define __CUDACC_VER__ "__CUDACC_VER__ is no longer supported.  Use __CUDACC_VER_MAJOR__, __CUDACC_VER_MINOR__, and __CUDACC_VER_BUILD__ instead."
                            ^
    CMake Error at cuda_compile_1_generated_math_functions.cu.o.Release.cmake:220 (message):
      Error generating
      /home/fccoelho/Code/caffe/build/src/caffe/CMakeFiles/cuda_compile_1.dir/util/./cuda_compile_1_generated_math_functions.cu.o
    
    
    src/caffe/CMakeFiles/caffe.dir/build.make:517: recipe for target 'src/caffe/CMakeFiles/cuda_compile_1.dir/util/cuda_compile_1_generated_math_functions.cu.o' failed
    make[2]: *** [src/caffe/CMakeFiles/cuda_compile_1.dir/util/cuda_compile_1_generated_math_functions.cu.o] Error 1
    CMakeFiles/Makefile2:420: recipe for target 'src/caffe/CMakeFiles/caffe.dir/all' failed
    make[1]: *** [src/caffe/CMakeFiles/caffe.dir/all] Error 2
    Makefile:149: recipe for target 'all' failed
    make: *** [all] Error 2
    Do someone knows how to compile with CUDA 10?
    I'm having that problem
    yegane-AI
    @yegane-AI
    Guys, I wanna work with Ristretto. I've followed the manual in this link: http://lepsucd.com/ristretto-cnn-approximation/subpage/. But I couldn't find the quantized.prototxt file in the directory RistrettoDemo. Any one can help me to find that file?
    Trigram19
    @Trigram19
    Why exactly would Caffe be a more feasible option than TF or Torch?
    tahrir94
    @tahrir94
    Hello, I am trying to get a pre-trained caffe model for my thesis project on real-time object detection. I'm following this repo to do it: https://github.com/chuanqi305/MobileNet-SSD. So far, I annotated all the images in my datasets to generate their xml's and generated lmdb's for the test and train data. However, I just cannot find any clear instructions on how to generate a trained .caffemodel file. I would REALLY appreciate any help with this, thank you!
    Ekaterina Abramova
    @Katya007_gitlab
    Hello, I am installing coffe using make all command, and getting error: LD -o .build_release/lib/libcaffe.so.1.0.0
    ld: warning: directory not found for option '-L/Users/MYUSERNAME/anaconda/lib'
    ld: warning: directory not found for option '-L/usr/local/opt/opencv4/lib'
    ld: framework not found vecLib
    clang: error: linker command failed with exit code 1 (use -v to see invocation)
    make: * [.build_release/lib/libcaffe.so.1.0.0] Error 1
    Could you please let me know how to resolve it? No help found on google.
    avinmaulana
    @avinmaulana

    Hello, I am installing coffe using make all command, and getting error: LD -o .build_release/lib/libcaffe.so.1.0.0
    ld: warning: directory not found for option '-L/Users/MYUSERNAME/anaconda/lib'
    ld: warning: directory not found for option '-L/usr/local/opt/opencv4/lib'
    ld: framework not found vecLib
    clang: error: linker command failed with exit code 1 (use -v to see invocation)
    make: * [.build_release/lib/libcaffe.so.1.0.0] Error 1
    Could you please let me know how to resolve it? No help found on google.

    Try using different version of opencv
    make sure the directory of anaconda was set properly on you makefile.config

    Ekaterina Abramova
    @Katya007_gitlab
    I seem to have resolved the above problem. The next issue is: ld: library not found for -lboost_python3 Any ideas on how to solve it? I can see boost_python3 folder inside my files. Where and how do I set the directory so that 'make all' stops complaining?
    Kamran Tayyab
    @Kamran14
    Can someone help me out with my error?
    Anujgarg2714
    @Anujgarg2714
    I don,t how hoe to train your own model an generate cafeemodel and prototxt please help
    ABCDAS
    @ABCDAS
    Can someone help me out with my error?
    [libprotobuf ERROR C:\Users\guillaume\work\caffe-builder\build_v140_x64\packages\protobuf\protobuf_download-prefix\src\protobuf_download\src\google\protobuf\message_lite.cc:248] Exceeded maximum protobuf size of 2GB.
    F0814 15:05:56.169399 11676 io.cpp:78] Check failed: proto.SerializeToOstream(&output)
    Check failure stack trace:
    mattybennett-phg
    @mattybennett-phg
    Hi All. I'm testing out the 'Deep Exemplar-based Colorization' project on GitHub. I've only just today managed to download the Docker image, so am very new to this.
    I'm trying to understand how to use it, but there are few to no instructions. I want to try out the demo, then replace the demo images with my own test image.
    Can anyone on the channel advise me please?
    Hi Misha. I may be able to help a little. In Github, on the project page there is a button to switch branches. Select one that has a docker Dockerfile in the code, download the zip and extract it to your work folder. Open PowerShell in your work folder and run the Docker command to compile the image. This will be something like: " docker build -t deep-colorization -f Dockerfile . "
    za13
    @za13

    I am using Ubuntu and tried to build Caffe and got a bunch of errors saying this file was generated by an older version of protoc

    After doing some research into it, it seems many people resolved the problem by doing

    conda uninstall libprotobuf

    However, when I tried that, I get this:

    Collecting package metadata (repodata.json): done
    Solving environment: \ 
    Found conflicts! Looking for incompatible packages.
    This can take several minutes.  Press CTRL-C to abort.
    failed                                                                          
    
    UnsatisfiableError: The following specifications were found to be incompatible with each other:
    
    
    
    Package libstdcxx-ng conflicts for:
    python=3.6 -> libstdcxx-ng[version='>=7.2.0|>=7.3.0']
    Package libgcc-ng conflicts for:
    python=3.6 -> libgcc-ng[version='>=7.2.0|>=7.3.0']
    Package xz conflicts for:
    python=3.6 -> xz[version='>=5.2.3,<6.0a0|>=5.2.4,<6.0a0|>=5.2.5,<6.0a0']
    Package libffi conflicts for:
    python=3.6 -> libffi[version='3.2.*|>=3.2.1,<3.3a0|>=3.3,<3.4.0a0']
    Package zlib conflicts for:
    python=3.6 -> zlib[version='>=1.2.11,<1.3.0a0']
    Package ncurses conflicts for:
    python=3.6 -> ncurses[version='6.0.*|>=6.0,<7.0a0|>=6.1,<7.0a0|>=6.2,<7.0a0']
    Package tk conflicts for:
    python=3.6 -> tk[version='8.6.*|>=8.6.7,<8.7.0a0|>=8.6.8,<8.7.0a0']
    Package readline conflicts for:
    python=3.6 -> readline[version='7.*|>=7.0,<8.0a0|>=8.0,<9.0a0']
    Package pip conflicts for:
    python=3.6 -> pip
    Package sqlite conflicts for:
    python=3.6 -> sqlite[version='>=3.20.1,<4.0a0|>=3.22.0,<4.0a0|>=3.23.1,<4.0a0|>=3.24.0,<4.0a0|>=3.25.2,<4.0a0|>=3.26.0,<4.0a0|>=3.29.0,<4.0a0|>=3.30.1,<4.0a0|>=3.31.1,<4.0a0']
    Package openssl conflicts for:
    python=3.6 -> openssl[version='1.0.*|1.0.*,>=1.0.2l,<1.0.3a|>=1.0.2m,<1.0.3a|>=1.0.2n,<1.0.3a|>=1.0.2o,<1.0.3a|>=1.0.2p,<1.0.3a|>=1.1.1a,<1.1.2a|>=1.1.1c,<1.1.2a|>=1.1.1d,<1.1.2a|>=1.1.1e,<1.1.2a|>=1.1.1g,<1.1.2a']
    Package ld_impl_linux-64 conflicts for:
    python=3.6 -> ld_impl_linux-64
    I also tried conda uninstall protobuf and got:
    Collecting package metadata (repodata.json): done
    Solving environment: / 
    Found conflicts! Looking for incompatible packages.
    This can take several minutes.  Press CTRL-C to abort.
    failed                                                                          
    
    UnsatisfiableError: The following specifications were found to be incompatible with each other:
    
    Package tk conflicts for:
    python=3.6 -> tk[version='8.6.*|>=8.6.7,<8.7.0a0|>=8.6.8,<8.7.0a0']
    Package zlib conflicts for:
    python=3.6 -> zlib[version='>=1.2.11,<1.3.0a0']
    Package openssl conflicts for:
    python=3.6 -> openssl[version='1.0.*|1.0.*,>=1.0.2l,<1.0.3a|>=1.0.2m,<1.0.3a|>=1.0.2n,<1.0.3a|>=1.0.2o,<1.0.3a|>=1.0.2p,<1.0.3a|>=1.1.1a,<1.1.2a|>=1.1.1c,<1.1.2a|>=1.1.1d,<1.1.2a|>=1.1.1e,<1.1.2a|>=1.1.1g,<1.1.2a']
    Package ncurses conflicts for:
    python=3.6 -> ncurses[version='6.0.*|>=6.0,<7.0a0|>=6.1,<7.0a0|>=6.2,<7.0a0']
    Package readline conflicts for:
    python=3.6 -> readline[version='7.*|>=7.0,<8.0a0|>=8.0,<9.0a0']
    Package pip conflicts for:
    python=3.6 -> pip
    Package libffi conflicts for:
    python=3.6 -> libffi[version='3.2.*|>=3.2.1,<3.3a0|>=3.3,<3.4.0a0']
    Package xz conflicts for:
    python=3.6 -> xz[version='>=5.2.3,<6.0a0|>=5.2.4,<6.0a0|>=5.2.5,<6.0a0']
    Package ld_impl_linux-64 conflicts for:
    python=3.6 -> ld_impl_linux-64
    Package libgcc-ng conflicts for:
    python=3.6 -> libgcc-ng[version='>=7.2.0|>=7.3.0']
    Package sqlite conflicts for:
    python=3.6 -> sqlite[version='>=3.20.1,<4.0a0|>=3.22.0,<4.0a0|>=3.23.1,<4.0a0|>=3.24.0,<4.0a0|>=3.25.2,<4.0a0|>=3.26.0,<4.0a0|>=3.29.0,<4.0a0|>=3.30.1,<4.0a0|>=3.31.1,<4.0a0']
    Package libstdcxx-ng conflicts for:
    python=3.6 -> libstdcxx-ng[version='>=7.2.0|>=7.3.0']

    when I type protoc --version, it says libprotoc 2.6.1

    can anyone help?

    SriHarsha72
    @SriHarsha72
    i am new to ubuntu i am trying to install caffe v0.9999 i am getting the following error
    can any one help me how to solve this
    i am trying to install matcaffe

    make: /usr/Desktop/MATLAB/bin/mexext: Command not found
    protoc --proto_path=src --cpp_out=.build_release/src src/caffe/proto/caffe.proto

    protoc --proto_path=src --cpp_out=.build_release/src src/caffe/proto/caffe_pretty_print.proto

    g++ .build_release/src/caffe/proto/caffe.pb.cc -pthread -fPIC -DCPU_ONLY -DNDEBUG -O2 -I.build_release/src -I./src -I./include -Wall -Wno-sign-compare -c -o .build_release/src/caffe/proto/caffe.pb.o 2> .build_release/src/caffe/proto/caffe.pb.o.warnings.txt \
    || (cat .build_release/src/caffe/proto/caffe.pb.o.warnings.txt; exit 1)

    g++ .build_release/src/caffe/proto/caffe_pretty_print.pb.cc -pthread -fPIC -DCPU_ONLY -DNDEBUG -O2 -I.build_release/src -I./src -I./include -Wall -Wno-sign-compare -c -o .build_release/src/caffe/proto/caffe_pretty_print.pb.o 2> .build_release/src/caffe/proto/caffe_pretty_print.pb.o.warnings.txt \
    || (cat .build_release/src/caffe/proto/caffe_pretty_print.pb.o.warnings.txt; exit 1)

    g++ src/caffe/layers/euclidean_loss_layer.cpp -pthread -fPIC -DCPU_ONLY -DNDEBUG -O2 -I.build_release/src -I./src -I./include -Wall -Wno-sign-compare -c -o .build_release/src/caffe/layers/euclidean_loss_layer.o 2> .build_release/src/caffe/layers/euclidean_loss_layer.o.warnings.txt \
    || (cat .build_release/src/caffe/layers/euclidean_loss_layer.o.warnings.txt; exit 1)
    In file included from src/caffe/layers/euclidean_loss_layer.cpp:4:0:
    ./include/caffe/util/io.hpp:7:10: fatal error: hdf5.h: No such file or directory

    include "hdf5.h"

          ^~~~~~~~

    compilation terminated.
    Makefile:454: recipe for target '.build_release/src/caffe/layers/euclidean_loss_layer.o' failed
    make: * [.build_release/src/caffe/layers/euclidean_loss_layer.o] Error

    Berkant
    @berkantay
    Hello people I am trying install latest caffe on my jetson tx2 dev board that has jetpack 4.4
    OpenCV version 4.3.0 cuda enabled
    Torch 1.6.0 cuda enabled
    Last framework i need is caffe but I could not find any resource for jetpack 4.4
    mishabeliy15
    @mishabeliy15
    Hello! Could you help me, please? I can't build caffe with opencl for openpose on MacBook pro 16
    [ 36%] Building CXX object src/caffe/CMakeFiles/caffe.dir/layers/prelu_layer.cpp.o
    8 warnings generated.
    4 warnings generated.
    [ 36%] Building CXX object src/caffe/CMakeFiles/caffe.dir/layers/recurrent_layer.cpp.o
    [ 36%] Building CXX object src/caffe/CMakeFiles/caffe.dir/layers/reduction_layer.cpp.o
    1 error generated.
    make[5]: [src/caffe/CMakeFiles/caffe.dir/layers/malis_loss_layer.cpp.o] Error 1
    make[5]:
    Waiting for unfinished jobs....
    6 warnings generated.
    make[4]: [src/caffe/CMakeFiles/caffe.dir/all] Error 2
    make[3]:
    [all] Error 2
    make[2]: [caffe/src/openpose_lib-stamp/openpose_lib-build] Error 2
    make[1]:
    [CMakeFiles/openpose_lib.dir/all] Error 2
    make: * [all] Error 2