Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
  • Sep 23 04:33
    loic-sharma closed #623
  • Sep 23 04:30
    loic-sharma closed #602
  • Sep 23 04:29
    loic-sharma closed #613
  • Sep 23 04:27
    loic-sharma closed #633
  • Sep 23 04:25
    loic-sharma closed #627
  • Sep 23 04:22
    loic-sharma closed #640
  • Sep 23 04:20
    loic-sharma closed #684
  • Sep 23 04:18
    loic-sharma closed #650
  • Sep 23 04:08
    loic-sharma closed #673
  • Sep 23 04:00
    loic-sharma closed #590
  • Sep 23 04:00
    loic-sharma closed #609
  • Sep 23 03:55

    loic-sharma on v0.4.0-preview2

    (compare)

  • Sep 23 03:43
    loic-sharma edited #687
  • Sep 23 03:42

    loic-sharma on main

    Remove the release notes length… (compare)

  • Sep 23 03:42
    loic-sharma closed #687
  • Sep 23 03:41
    loic-sharma ready_for_review #687
  • Sep 23 03:41
    loic-sharma closed #610
  • Sep 23 03:39
    loic-sharma edited #687
  • Sep 23 03:37
    loic-sharma edited #687
  • Sep 23 03:30
    loic-sharma edited #687
Aurélien
@adhermy
Is there something that catches the env values to write them up on appsettings.json? because nothing seems to moves even though the env values are correctly updated.
Loïc Sharma
@loic-sharma
Hey @adhermy, the default ASP.NET Core configuration system reads configs from command line arguments, environment variables, and the appsettings.json file. See this documentation: https://docs.microsoft.com/en-us/aspnet/core/fundamentals/configuration/?view=aspnetcore-2.2#default-configuration
When you run the docker image, do you pass the environment file using the --en-file baget.env option?
Aurélien
@adhermy
I use kubernetes configmap to replace appsettings.json
Aurélien
@adhermy
New problem now : Please check the value of the Environment Variable GOOGLE_APPLICATION_CREDENTIALS ---> System.IO.DirectoryNotFoundException: Could not find a part of the path '/app/'
The env var is correctly setted though, with the exact content of the json i've generated for the service account, i'm a bit puzzled
Aurélien
@adhermy
Okay found the problem. Baget expect a path in GOOGLE_APPLICATION_CREDENTIALS and not the credentials themselves
Aurélien
@adhermy
I've succeeded to deploy my stack :) But now our windows servcer doesn't see the packages available using Chocolatey
Loïc Sharma
@loic-sharma
Ah, I believe that Chocolatey uses legacy NuGet V2 APIs, which BaGet doesn't support
Loïc Sharma
@loic-sharma
Yes, that seems to be the case. See: chocolatey/chocolatey.org#664
Aurélien
@adhermy
Okay i see. Thank you :)
Fabian Grutschus
@fabiang
Hello everyone. I'm planing to serve BaGet via HTTPS. I need a proxy like Nginx to archive that, right? I don't see any enviroment variables to define a certifcate (and key). Thanks in advance
Loïc Sharma
@loic-sharma
Hi, you should be able to use the Kestrel configurations to set an HTTPS certificate. See the "Replace the default certificate from configuration" section here: https://docs.microsoft.com/en-us/aspnet/core/fundamentals/servers/kestrel?view=aspnetcore-2.2#listenoptions-usehttps
I've never used this myself, so please let me know if you run into issues
But yes, you can always use a proxy like NGINX
Brennen Sprimont
@brennen.j.sprimont_gitlab
Can BaGet be hosted behind a nginx proxy? I tried a couple weeks ago and ran into the issue described here: loic-sharma/BaGet#276
Fabian Grutschus
@fabiang
Thanks. I'll give it a try now and will report. I guess Kestrel is a bit too complicated and I gonna use a Nginx-Proxy instead
Fabian Grutschus
@fabiang
Ok, I've BaGet running on port 80 and behind an Nginx-Proxy behind port 443. It seems that the content under /static wasn't generated.
I guess the Docker image doesn't create them. I'm using loicsharma/baget:latest
Gonna test now, which stage in the Dockerfile of BaGet create the static files and why they aren't generated
Fabian Grutschus
@fabiang
ok BaGet on port 80, delivers the static content. Just didn't see I was on https://localhost
@brennen.j.sprimont_gitlab seems like exactly your issue
h0730303779
@h0730303779
嗨~ feel ~ How do you use it?
Loïc Sharma
@loic-sharma
@h0730303779 Did you see the “Getting Started” guide here? https://loic-sharma.github.io/BaGet/
Let me know if you run into any issues
h0730303779
@h0730303779
like DevExpress NuGet Feed URL , what to do it ?
Private feeds are not supported at this time! See this pull request for more information. :)
arvkonstantin
@arvkonstantin
Good afternoon. I have a question.
I launch docker
/shares/baget # docker run --rm --name nuget-server -p 9011:80 --env-file baget.env -v "baget-data:/var/baget" loicsharma/baget:latest
Configuration in baget.env
Storage__Path=/var/baget/packages
And the packages are in
/var/snap/docker/common/var-lib-docker/volumes/baget-data
instead
/shares/baget/baget-data
thareek
@thareek

Hi.. my config has aws s3, rds postgres and the baget app is running fine (windows 10 desktop machine). Almost uploaded 20 packages and able to download it and use it as expected. one specific package push is failing at every attempt.

error "Response status code does not indicate success: 500 (Internal Server Error)."

say package name is "address1.01.nupkg", And when i change the rds postgres to sqllite of local in config the push is working fine.

so some reference specific to this package in postgres is causing the error, so what are the options to clean up the package related details directly in postgres? Or is there logs we can check to idenity rootcause for this error ?

canceriens
@canceriens
hi I managed to spin up a BaGet server and I can see its running, I can upload my packages just fine but I can neither see them listed on the UI nor can I download them using Visual Studio
has anyone faced this problem before? if yes, do we know what might be the best solution is?
Loïc Sharma
@loic-sharma
@thareek, I created a GitHub issue for your problems: loic-sharma/BaGet#545
@canceriens, that's odd. Try navigating to http://localhost:5000/v3/search?includePrerelease=true&semVerLevel=2.0.0. Do you see anything there? This should return all the listed packages. If that doesn't work we may need to inspect your database
@arvkonstantin that sounds like a generic Docker problem. I'd suggest reaching out to the Docker community to help you out with Docker problems
jbwaclawski-msm
@jbwaclawski-msm
Anyone have issues getting the integration wtih S3 working properly?
Loïc Sharma
@loic-sharma
What kind of issues are you running into?
Giovanni
@IGionny
Hi everyone: I have a docker baget updated with the latest image. Simple conf: local filesystem etc.. when I try to download a package it return me a generic 500 error...where I should start to investigate on it?
"docker logs --follow baget" show me the issue ;)
Paul Schneider
@pazof
Isn't there any issue about installation using Postgres ?
My initial migration fails
using PG11
Paul Schneider
@pazof
I authored a new issue :-)
but I don't think I 'll try and fix it
Loïc Sharma
@loic-sharma
Hello hello, I'm moving the BaGet chat to Discord. Hopefully that will result in more folks being online to help answer questions. You can find that here: https://discord.gg/MWbhpf66mk