These are chat archives for Behat/Behat

4th
Jun 2015
Alex Panshin
@enl
Jun 04 2015 05:15
Hi there.

Behat's composer.json allows upgrade to symfony 2.7. But there are tons of deprecations in 2.7. And Behat fails to start due these deprecation errors.

PHP Deprecated: Symfony\Component\DependencyInjection\Definition::setFactoryService(client_factory) is deprecated since version 2.6 and will be removed in 3.0. Use Definition::setFactory() instead. in /home/enlightened/projects/kidly/vendor/symfony/dependency-injection/Definition.php on line 208

Alex Panshin
@enl
Jun 04 2015 05:35
Ouch! Sorry, guys. That's my own service definition, not behat's one.