Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • May 14 10:27
    izzylys opened #2322
  • May 14 06:47
    radoslawkosinski commented #263
  • May 12 07:47
    Xaalek commented #2320
  • May 12 07:46
    Xaalek commented #2320
  • May 11 23:40
    jf-dynamics edited #2321
  • May 11 23:39
    jf-dynamics edited #2321
  • May 11 23:38
    jf-dynamics edited #2321
  • May 11 23:36
    jf-dynamics opened #2321
  • May 11 10:00
    wdefender opened #2320
  • May 11 04:33
    andreyea commented #2306
  • May 11 03:15
    Keboo commented #2306
  • May 11 01:49
    andreyea commented #2306
  • May 10 23:46
    andreyea commented #2306
  • May 10 23:32
    andreyea commented #2306
  • May 08 03:07

    github-actions[bot] on icons

    [Icon update detected by Github… (compare)

  • May 08 03:07
    github-actions[bot] opened #2319
  • May 06 17:29
    Keboo labeled #2317
  • May 06 17:29
    Keboo commented #2317
  • May 06 17:25
    Keboo labeled #2317
  • May 06 17:21
    Keboo commented #2318
stany9g
@stany9g
@Erapchu Well, I am surprised because I do not have that many rows, only something around 50 or so. Thank you for your help I will look into the link.
Andrey Nasonov
@Erapchu

@stany9g Please try to add the next properties to datagrid for virtualization:

VirtualizingPanel.IsVirtualizing="True"
VirtualizingPanel.VirtualizationMode="Recycling"
VirtualizingPanel.IsContainerVirtualizable="True"

Probably this should increase performance

stany9g
@stany9g
@Erapchu I have it set. I think it is no the problem of the virtualization itself but as @Keboo suggested in #2211 it may have something to do with the size of the parent of the DataGrid. For now, I have set the MaxWidth and MaxHeight of the underlying PART_PopupContentElement (Card) in the style and removed the VisualTransition with that I reached a quite the "optimization" still not perfect as a just opening the same dialog as when switching between content of dialog. Anyway, thank you for the help I really appreciate your time and effort.
Miosss
@Miosss
Hello,
is there easy way to reduce Margin in ListViewItems? This Margin="8" is set on ContentPresenter inside a Ripple thats is "between" ListViewItem and ListView.ItemTemplate which I provide in Visual Tree, so there is no plain access to it I think
image.png
Overriding entire ControlTemplate is pain the ass when something changes in the original style
Miosss
@Miosss
Nevermind, I found the solution: materialDesign:ListViewAssist.ListViewItemPadding="4"
Yoooi0
@Yoooi0
@Erapchu oh, i think i should have said that I want to change a style globally on all controls, i know that x:Key would have worked but that would mean putting it on every control in xaml
to be more exact, i want to remove the focus/tab navigation dotted border from all controls like buttons, sliders etc.
wh1t3l0v3r
@wh1t3l0v3r
i am just starting to learn this
Andrey Nasonov
@Erapchu
@Yoooi0 you need to not use Defaults.xaml, create your own styles, your own Defaults.xaml and add it to merged dictionaries.
For example:
<!--In Defaults.xaml-->
<Style TargetType="{x:Type Button}" BasedOn="{StaticResource MyStyledButton}" />

<!--Your style-->
<Style x:Key="MyStyledButton" TargetType="{x:Type ButtonBase}">
</Style>

<!--In app.xaml, merged dictionaries-->
<ResourceDictionary Source="pack://application:,,,/WpfApp1;component/ResourceDictionaries/Defaults.xaml"/>
Andrey Nasonov
@Erapchu
One more thing is that you can leave all default styles from material design, just merging them with this library. You can just see what happens in Defaults.xaml in MaterialDesignInXamlToolkit library. Copy it to your Defaults.xaml, a small corrects with namespaces and put you style for Button or any other control. That's it. @Yoooi0
Michel Michels
@MichelMichels
@Keboo There are a lot of dead questions in the GitHub issue tracker. I'd like to propose to close some to keep a cleaner backlog
I have time to go through them and flag them for removal if you'd like
KHALED LAKEHAL
@KHALED-LAKEHAL
Hello it's can extends from pack icon and use to add my custom icon
Michel Michels
@MichelMichels
@KHALED-LAKEHAL the class doesn't seem to be extendable as it depends on a readonly dictionary of icon SVG paths which gets loaded by a hardcoded PackIconDataFactory
you'll have to use Image for your own icons
KHALED LAKEHAL
@KHALED-LAKEHAL
@MichelMichels thanks
Michel Michels
@MichelMichels
@Keboo I apologize if the multiple PR requests are irritating. I couldn't decide the commits should be merged in one PR as they were different issues/features on the same control
Kevin B
@Keboo
@MichelMichels that is fine, been fighting a cold. One my head is functioning again i will get them reviewed/merged.
Teknica
@TeknicaAD

@MichelMichels that is fine, been fighting a cold. One my head is functioning again i will get them reviewed/merged.

Get well soon, we need you!!

Derrick Berg
@derrickberg-dev
I'm trying to use the listbox on the far right in the demo app, but instead of the toggle, I just wanted a button to copy data to the clipboard. I've managed to get it working but everytime I click the button, a lot of repeated exceptions occur. Exception thrown: 'System.Runtime.InteropServices.COMException' in PresentationCore.dll Exception thrown: 'System.NotImplementedException' in PresentationCore.dll
I just copied the "AnotherCommandImplementation" class and put the command and clipboard code into the SelectableViewModel class.
public class SelectableViewModel : INotifyPropertyChanged
    {
        private bool _isSelected;
        private string _name;
        private string _description;

        private AnotherCommandImplementation CopyToClipboardCommands;

        public ICommand CopyToClipboards => CopyToClipboardCommands = new AnotherCommandImplementation(CopyToClipboard);

        private void CopyToClipboard(object obj)
        {
            var toBeCopied = obj;
            try
            {
                if (toBeCopied != null)
                {
                    Clipboard.SetDataObject(toBeCopied);
                }
            }
            catch
            {
                Console.WriteLine("Clipbaord error");
            }
        }
I have a feeling this ain't right^
Michel Michels
@MichelMichels
@Keboo Take care!
Michel Michels
@MichelMichels
@derrickberg-dev I can't reproduce your issue. Could link me repo?
Could you*
Derrick Berg
@derrickberg-dev
yeah i could put it on github
I doubt its anything with MaterialDesign's xaml code or anything, its probably the way im trying to call the copy to clipboard method
Either that or its because im on vs2017 using .NET Frmwrk 4.6.1
Derrick Berg
@derrickberg-dev
this is what my card looks like
                <materialDesign:Card materialDesign:ShadowAssist.ShadowDepth="Depth3" Padding="32" Margin="16" Width="Auto" Height="Auto" >
                    <ItemsControl ItemsSource="{Binding Items2}" Grid.IsSharedSizeScope="True">
                        <ItemsControl.ItemTemplate>
                            <DataTemplate DataType="{x:Type local:SelectableViewModel}">
                                <Border x:Name="Border" Padding="10" BorderThickness="0 0 0 1" BorderBrush="{DynamicResource MaterialDesignDivider}">
                                    <Grid>
                                        <Grid.ColumnDefinitions>
                                            <ColumnDefinition SharedSizeGroup="Checkerz" />
                                            <ColumnDefinition />
                                        </Grid.ColumnDefinitions>
                                        <Button x:Name="clipbtn" VerticalAlignment="Center" Command="{Binding CopyToClipboardCommand, Mode=OneTime}" CommandParameter="{Binding Description}" Style="{StaticResource MaterialDesignFloatingActionMiniAccentButton}" materialDesign:ShadowAssist.ShadowDepth="Depth3" Width="36" Height="36">
                                            <materialDesign:PackIcon Width="18" Height="18" Kind="ClipboardOutline"/>

                                        </Button>
                                        <StackPanel Margin="9 5 0 0" Grid.Column="1" Width="Auto">
                                            <TextBlock Text="{Binding Name}" FontSize="16" FontWeight="Bold" Foreground="White"/>
                                            <TextBlock Text="{Binding Description}" FontSize="14" Foreground="White" />
                                        </StackPanel>
                                    </Grid>
                                </Border>
                            </DataTemplate>
                        </ItemsControl.ItemTemplate>
                    </ItemsControl>
                </materialDesign:Card>
I thought the command on the button would only trigger on clicks but it looks like its running the method multiple times when the button has only been clicked once
Michel Michels
@MichelMichels
image.png
@derrickberg-dev I think something else is wrong, code runs perfect here
little disclaimer, I'm running this on VS 2019 and .NET 5.0
but the exception you're getting has something to do with WPF and the Interop namespace. Are you using any c(++) DLL assemblies in your code?
Michel Michels
@MichelMichels
I'm working on a Leadingicon for the Button control and it's working fine in runtime, but the XAML designer is showing me strange behavior. I guess it has something to do with me overriding the ContentTemplate
image.png
This is in runtime (don't mind the Flat and Outlined style, it's still a WIP)
In the XAML designer, I get this
image.png
So it seems like the designer can't resolve the Icon and the visibility property I have set on the button
any thoughts?
<wpf:PackIcon
    x:Name="LeadingIcon"
    Margin="0 0 8 0"
    Kind="{Binding Path=(wpf:ButtonAssist.LeadingIcon), RelativeSource={RelativeSource FindAncestor, AncestorType={x:Type Button}}}"
    Visibility="{Binding Path=(wpf:ButtonAssist.HasLeadingIcon), RelativeSource={RelativeSource FindAncestor, AncestorType={x:Type Button}}, Converter={StaticResource BooleanToVisibilityConverter}}"
    VerticalAlignment="{TemplateBinding VerticalAlignment}" />
code from inside the DataTemplate of the ContentTemplate setter
Kevin B
@Keboo
@MichelMichels send like the designer is possibly loading (or holding onto) an older version. Normally when I have seen designer issues with the pack icon it simply does not sure. But the fact it is showing the wrong icon is a little odd
Michel Michels
@MichelMichels
@Keboo yes, it is showing the "Abacus" PackIcon, which is the first one
Mikael Silvén
@silven
Hello, I've noticed that the DialogHost adjusts itself upwards in the presence of an onscreen keyboard. This is great! However, it only does it when the app is NOT maximized. How can I make it do so also when maximized?
Amrani
@AmraniRiyad
It is not related to MaterialDesign but if someone can give some light on this one please ? : https://stackoverflow.com/questions/65864630/form-with-validation-of-models-wrapped-in-viewmodels-with-one-to-many-relation
Amrani
@AmraniRiyad

Hello, I've noticed that the DialogHost adjusts itself upwards in the presence of an onscreen keyboard. This is great! However, it only does it when the app is NOT maximized. How can I make it do so also when maximized?

Hi, maybe some margin (DialogMargin ?) is preventing it from moving?