These are chat archives for CF711/facebookProject

7th
Mar 2015
towhidabsar
@towhidabsar
Mar 07 2015 00:11
Yeah I just pulled, ok I will work on the front end tonight and try to get some of the stuff working..ofcourse the calendar stocks and fb will be stubbed out?
if anyone can help me with something, my visual studio file structure does not update for some reason and it's still showing old files that don't exist :worried:
Chris
@CF711
Mar 07 2015 00:12
The entire landing page is done
Robert Warren Gilmore
@RobertWarrenGilmore
Mar 07 2015 00:12
I will bang out the stock component.
@towhidabsar, in the Solution Explorer panel, there is a button "Show All Files".
You have to toggle that on.
Otherwise Visual Studio is an ass hole and doesn't show you files that haven't yet been explicitly included in the project.
towhidabsar
@towhidabsar
Mar 07 2015 00:17
yeah it's being an asshole
Robert Warren Gilmore
@RobertWarrenGilmore
Mar 07 2015 00:17
Microsoft's core value.
towhidabsar
@towhidabsar
Mar 07 2015 00:19
yeah show all files shows me all the files literally, but doesn't get rid of files that don't exist lol
Robert Warren Gilmore
@RobertWarrenGilmore
Mar 07 2015 00:24
Try right clicking on the erroneous files and selecting Exclude from Project.
Robert Warren Gilmore
@RobertWarrenGilmore
Mar 07 2015 05:37
What a night!
It took about two hours to uninstall Visual Studio 2015 and about another hour to install Visual Studio 2013.
But I finally got my local copy of the project to run.
Chris
@CF711
Mar 07 2015 06:51
yay
Robert Warren Gilmore
@RobertWarrenGilmore
Mar 07 2015 06:53
@CF711, you were there. :P
Christopher Eldridge
@celdridge91190
Mar 07 2015 13:46
@/all Hey guys I created a Development branch on GitHub. I don't see it showing up to pull from yet not sure if I missed a step but if we can try to start using that instead of Master it may save us some headaches in the future
Robert Warren Gilmore
@RobertWarrenGilmore
Mar 07 2015 15:48
Make a commit to it. Then it can be pulled from.
@celdridge91190
Matt Metcalf
@mrm9084
Mar 07 2015 16:29
@/all If everyone could do me a huge favor and let me be the only person to deploy it would be great. I don't want to go through that again.
Robert Warren Gilmore
@RobertWarrenGilmore
Mar 07 2015 17:41
@cf711, the site looks like ass on mobile. So much for Bootstrap being mobile first.
But seriously, it might be good to tear Index and Layout down and rewrite them from scratch to clear out the awful structure that it had out of the box.
Chris
@CF711
Mar 07 2015 18:02
we might want to use a little more stuff with bootstrap then in order to make it look better
Robert Warren Gilmore
@RobertWarrenGilmore
Mar 07 2015 18:03
Agreed.
Chris
@CF711
Mar 07 2015 18:06
probably do col-sm-4 on top of col-md-4
Robert Warren Gilmore
@RobertWarrenGilmore
Mar 07 2015 20:37
@mrm9084, could you document your deployment procedure?
Matt Metcalf
@mrm9084
Mar 07 2015 20:38
I could try. I am not 100% sure how I got it to work. Also I don't think half of the steps will need to be done again.
Robert Warren Gilmore
@RobertWarrenGilmore
Mar 07 2015 20:40
That's part of the reason for my asking. Documenting it will have the side effect of clarifying it. Also it would be nice to know in case someone has to do it without your help.
Matt Metcalf
@mrm9084
Mar 07 2015 20:43
@/all I sent everyone friend requests on facebook so I can add you as developers. Also only log in as test users to our app.
Christopher Eldridge
@celdridge91190
Mar 07 2015 20:48
@/all The development branch should be active now
Matt Metcalf
@mrm9084
Mar 07 2015 21:05
@RobertWarrenGilmore is your latest push working? I did a pull from master and it doesn't look like anything changed
Matt Metcalf
@mrm9084
Mar 07 2015 21:15
@/all Here is how you publish
Go to C:\inetpub\wwwroot\R1
do a git pull
check if the website is updated with your stuff
towhidabsar
@towhidabsar
Mar 07 2015 21:17
okk
Matt Metcalf
@mrm9084
Mar 07 2015 21:17
if you get a wierd error open the project in visual studio, select option to open as a different user. Run the program. Then go to the website and refresh it should work now
Make sure you get this last part
towhidabsar
@towhidabsar
Mar 07 2015 21:18
I pulled from the development branch, it's giving me build errors
Robert Warren Gilmore
@RobertWarrenGilmore
Mar 07 2015 21:50
@mrm9084, my latest commit was on 2015-03-01. What are you talking about?
Matt Metcalf
@mrm9084
Mar 07 2015 21:50
I thought you had commited something
Robert Warren Gilmore
@RobertWarrenGilmore
Mar 07 2015 21:51
No.
Not since 2015-03-01.
@towhidabsar, what version of VS are you using? I had trouble with 2015, but 2013 works just fine.
towhidabsar
@towhidabsar
Mar 07 2015 21:59
i have 2013
Robert Warren Gilmore
@RobertWarrenGilmore
Mar 07 2015 22:00
Weird.
Christopher Eldridge
@celdridge91190
Mar 07 2015 23:35
Try cleaning and rebuilding. Sometimes when you do a clean pull your references don't work correctly.