These are chat archives for CORE-POS/IS4C

7th
Oct 2016
danry25
@danry25
Oct 07 2016 20:58
Running into composer issues trying to install on raspbian on this raspberry pi 3 model B...
✘ ⚡ root@raspberrypi  /var/www/IS4C-test   master  /usr/local/bin/composer.phar update
Do not run Composer as root/super user! See https://getcomposer.org/root for details
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - Installation request for codeclimate/php-test-reporter ^0.2.0 -> satisfiable by codeclimate/php-test-reporter[v0.2.0].
    - codeclimate/php-test-reporter v0.2.0 requires satooshi/php-coveralls 0.6.* -> satisfiable by satooshi/php-coveralls[v0.6.0, v0.6.1].
    - satooshi/php-coveralls v0.6.0 requires psr/log 1.0.0 -> satisfiable by psr/log[1.0.0].
    - satooshi/php-coveralls v0.6.1 requires psr/log 1.0.0 -> satisfiable by psr/log[1.0.0].
    - Conclusion: don't install psr/log 1.0.0
danry25
@danry25
Oct 07 2016 21:10
@gohanman Hey, should I file an issue? This is on branch version-2.3 that I'm running into this
Shoot, nevermind, should've been doing composer install, not composer update...
Andy Theuninck
@gohanman
Oct 07 2016 21:15
That's what I thought but I was working on double-checking first
danry25
@danry25
Oct 07 2016 21:19
yea, sorry 'bout that!
Andy Theuninck
@gohanman
Oct 07 2016 21:19
Not a problem. I ran into almost the same error myself earlier today