These are chat archives for CZ-NIC/knot-resolver

18th
Nov 2018
vstath
@vstath
Nov 18 2018 16:32
I'm confused. How can I use Lua with knot-resolver? I want to accept queries and rewrite or redirect them if it matches specific queries (for example domain "foo.com"). I'm new to it and docs are kinda confusing. Any help?
vstath
@vstath
Nov 18 2018 16:47
never mind - I had installed default package from ubuntu 16.04 and it seems to be a version compiled in 500 BC :-/
Vladimír Čunát
@vcunat
Nov 18 2018 17:53
@vstath yes, Debian derivatives tend to have updating policies that are unfriendly to young projects. You can use our packages done by us from https://software.opensuse.org//download.html?project=home%3ACZ-NIC%3Aknot-resolver-latest&package=knot-resolver (linked from our homepage)
Query matching and actions are described in respective module docs: https://knot-resolver.readthedocs.io/en/stable/modules.html#query-policies
edoo
@ookangzheng
Nov 18 2018 18:29
So instead of Ubuntu or Debian distro, swith to Fedora or Arch linux will be better?
Debian9 sid still stuck at knot-resolver 3.0.0 version
vstath
@vstath
Nov 18 2018 18:37
@vcunat thanks - I have managed to make the examples work. I didn't manage to make the newest version run on my SmartOS LX ubuntu 16.04 but I will look into it (default one ran fine). For the time being I tested on a kernel-enabled VM. My target platform though is SmartOS LX zone
Vladimír Čunát
@vcunat
Nov 18 2018 18:39
@ookangzheng: our packages from the link above should be fine as well (include Debian 9 and three Ubuntu versions).
edoo
@ookangzheng
Nov 18 2018 19:26
Yap, I updated to lastest version . Thanks
Elctro
@Elctro
Nov 18 2018 20:54
Hello, docker file on the following URL seems to be broken. It can't run ./scripts/bootstrap-depends.sh for some reason. https://hub.docker.com/r/cznic/knot-resolver/~/dockerfile/
Elctro
@Elctro
Nov 18 2018 21:13
The other one is also unhealthy, failing on non-existent /etc/knot/knot.sample.conf. https://hub.docker.com/r/cznic/knot/~/dockerfile/