Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • 15:27
    GitLab | Libor Peltan pushed 1 commits to Knot DNS
  • 12:10
    GitLab | Daniel Salzman pushed 1 commits to Knot DNS
  • 12:01
    GitLab | Libor Peltan pushed 1 commits to Knot DNS
  • 08:20
    GitLab | Daniel Salzman pushed 1 commits to Knot DNS
  • Feb 25 16:21
    GitLab | Libor Peltan pushed 1 commits to Knot DNS
  • Feb 25 12:36
    GitLab | Libor Peltan pushed 1 commits to Knot DNS
  • Feb 25 11:51
    GitLab | Daniel Salzman pushed 3 commits to Knot DNS
  • Feb 24 18:28
    GitLab | Libor Peltan pushed 3 commits to Knot DNS
  • Feb 24 18:18
    GitLab | Libor Peltan pushed 3 commits to Knot DNS
  • Feb 24 15:38
    Daniel Salzman commented on issue #334 kdig: algorithm name for PRIVATEDNS in Knot DNS
  • Feb 24 15:37
    GitLab | Daniel Salzman pushed 1 commits to Knot DNS
  • Feb 24 15:36
    Jan Hák closed issue #334 kdig: algorithm name for PRIVATEDNS in Knot DNS
  • Feb 24 15:22
    GitLab | Jan Hák pushed 1 commits to Knot DNS
  • Feb 24 15:18
    GitLab | Daniel Salzman pushed 1 commits to Knot DNS
  • Feb 24 14:55
    GitLab | Jan Hák pushed 1 commits to Knot DNS
  • Feb 24 14:52
    GitLab | Daniel Salzman pushed 1 commits to Knot DNS
  • Feb 24 14:17
    GitLab | Jan Hák pushed 1 commits to Knot DNS
  • Feb 24 13:52
    GitLab | Jan Hák pushed 1 commits to Knot DNS
  • Feb 24 13:36
    GitLab | Jan Hák pushed 1 commits to Knot DNS
  • Feb 24 13:19
    GitLab | Jan Hák pushed 1 commits to Knot DNS
bleve
@bleve
I didn't have any problems before anycast dns service.
My own servers don't have issues with timeouts.
But those are all less than 10ms away.
bleve
@bleve
Hmh. I smell fresh software :)
In production, seem to work
bleve
@bleve
@salzmdan Back to tcp timeout. Increasing to 500ms did the trick and slaves don't get errors any more.
Micah
@micah_gitlab
hi, my slaves are having trouble refreshing one of my zones from my master, they say no usable master and I cannot see why
Daniel Salzman
@salzmdan
Hi, any logs? Try enabling debug verbosity level
Micah
@micah_gitlab
I only see refresh, remote owl not usable
and refresh, remote owl, address 0.0.0.0@53, failed (connection reset)
which is odd, the other zones between those machines are fine
Daniel Salzman
@salzmdan
Is the zone loaded on the master? Can you dig it?
Micah
@micah_gitlab
the master says, debug: TCP, send, address 0.0.0.0@45652 (connection timeout) (where the 0.0.0.0 is the ip)
I can do dig @127.0.0.1 and get a response
Daniel Salzman
@salzmdan
It sounds like the TCP timeout issue. Try increasing https://www.knot-dns.cz/docs/2.9/html/reference.html#tcp-io-timeout
on the master
Micah
@micah_gitlab
that would be weird, these machines are connected via a switch
Daniel Salzman
@salzmdan
I suspect the zone is bigger than the other ones?
Micah
@micah_gitlab
it is
huh, the tcp-timeout seemed to resolve it
bleve
@bleve
@salzmdan I really think default for tcp-io-timeout is too low :(
Daniel Salzman
@salzmdan
I understand your opinion, but you are influenced by your use case only.Probably you don't know how vulnerable TCP is :-)
There is no universal value for master servers. I can set the default to 500 ms. It will solve just your problem and will affect all other slave servers, which don't need it...
On the other hand, there is no significant difference between 200 and 500.
Micah
@micah_gitlab
I just noticed that I stumbled into the @bleve conversation about tcp timeouts with my tcp timeout problem :D
Daniel Salzman
@salzmdan
Yes :-D
Micah
@micah_gitlab
I swear I'm not a sock puppet account for @bleve :D
Jonathan Foote
@footePGH_twitter
Hi all. It looks like the oss-fuzz integration build broke due to gnutls requiring libev4: https://oss-fuzz-build-logs.storage.googleapis.com/log-8c57a29d-aecc-4537-9964-28f39ff6104e.txt
Step #4: configure: error: ***
Step #4: *** libev4 was not found.
I think this patch to the oss-fuzz integration will fix it
$ git diff
diff --git a/projects/knot-dns/Dockerfile b/projects/knot-dns/Dockerfile
index 22b1039..4977181 100644
--- a/projects/knot-dns/Dockerfile
+++ b/projects/knot-dns/Dockerfile
@@ -28,7 +28,9 @@ RUN apt-get update && apt-get install -y \
  make \
  pkg-config \
  texinfo \
- wget
+ wget \
+ libev4 \
+ libev-dev

 ENV GNULIB_TOOL $SRC/gnulib/gnulib-tool
 RUN git clone git://git.savannah.gnu.org/gnulib.git
I can submit a PR to oss-fuzz to fix it -- just wanted to run it past this group
PR is here: google/oss-fuzz#3199
Daniel Salzman
@salzmdan
@footePGH_twitter Thank you! :thumbsup:
azzamsa
@azzamsa
I never know and never find the link to this gitter channel but today. I also don't find it in knot docs.
all my problem for 3 months in google search just linked me to the docs and mailing list.
Daniel Salzman
@salzmdan
But it's on the project web page https://www.knot-dns.cz/development/ :-)
azzamsa
@azzamsa
Oh, I missed that :). which one do you recommend for asking issue, gitter or mailing-list?
Daniel Salzman
@salzmdan
I think gitter is better for simple questions
azzamsa
@azzamsa
Thank you. I really appreciate for all your hard work for knot and other knot teams. I love that it provides the socket via python, so that I can corporate with our project https://github.com/BiznetGIO/RESTKnot
Daniel Salzman
@salzmdan
Interesting! Thanks for the link :-)
azzamsa
@azzamsa
:-), I never thought my question in mailing-list/issues would be replied that fast considering this type of project. Turns out it so fast so that I don't have to wait too long to solve my problem :))
Daniel Salzman
@salzmdan
It's because of Knot DNS is so fast ;-)
azzamsa
@azzamsa
Thank you so much for knot teams! :-))
muellert
@muellert

I am trying to add the nic.cz archive to my system, but on import of the gpg key, I get this message:

gpg --recv-keys 8A0EFB02C84B1E9B

gpg: key 8A0EFB02C84B1E9B: new key but contains no user ID - skipped
gpg: Total number processed: 1
gpg: w/o user IDs: 1

Daniel Salzman
@salzmdan
Try a different keyserver gpg --keyserver hkps://keyserver.ubuntu.com --recv-keys 0x8A0EFB02C84B1E9B
muellert
@muellert
Knot does not seem to open a socket.
As a result, I can't send it any queries. It claims "warning: no zones loaded", which is driving me mad. Initially, it loaded zones very well, and "knotc conf-check" says the configuration is valid.
muellert
@muellert
On a different machine with the same OS and the same configuration, exept for the "listen" statement, works without any problems.
That it doesn't open any socket, I have verified with 'ss'.
Daniel Salzman
@salzmdan
It's difficult to help if you don't provide any logs, configuration, or other details. In general, Knot DNS doesn't require zones configured.