Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • May 26 23:21
    dependabot[bot] labeled #213
  • May 26 23:21
    dependabot[bot] opened #213
  • May 26 23:20

    dependabot[bot] on npm_and_yarn

    Bump dns-packet from 1.3.1 to 1… (compare)

  • May 12 00:31
    dependabot[bot] labeled #212
  • May 12 00:31
    dependabot[bot] opened #212
  • May 12 00:31

    dependabot[bot] on npm_and_yarn

    Bump codemirror from 5.41.0 to … (compare)

  • May 09 11:40
    dependabot[bot] labeled #211
  • May 09 11:40
    dependabot[bot] opened #211
  • May 09 11:40

    dependabot[bot] on npm_and_yarn

    Bump hosted-git-info from 2.7.1… (compare)

  • May 07 00:26

    dependabot[bot] on npm_and_yarn

    (compare)

  • May 07 00:26
    dependabot[bot] closed #200
  • May 07 00:26
    dependabot[bot] commented #200
  • May 07 00:26
    dependabot[bot] labeled #210
  • May 07 00:26
    dependabot[bot] opened #210
  • May 07 00:26

    dependabot[bot] on npm_and_yarn

    Bump lodash from 4.17.4 to 4.17… (compare)

  • May 06 22:38

    dependabot[bot] on npm_and_yarn

    (compare)

  • May 06 22:38
    dependabot[bot] closed #202
  • May 06 22:38
    dependabot[bot] commented #202
  • May 06 22:38
    dependabot[bot] labeled #209
  • May 06 22:38
    dependabot[bot] opened #209
Alex Arriaga
@alex-arriaga
I just updated the workbench too
Miguel Aragón
@MiguelAraCo
I'll check it out :+1:
Alex Arriaga
@alex-arriaga
Screen Shot 2016-11-01 at 18.29.05.png
Miguel Aragón
@MiguelAraCo
Ok, I just confirmed it
We'll open an issue to fix it
Alex Arriaga
@alex-arriaga
This is so nice!!!
Screen Shot 2016-11-01 at 18.34.25.png
:D
Miguel Aragón
@MiguelAraCo
Hahaha, you found the hidden error screen
Alex Arriaga
@alex-arriaga
Jajajaj yep
Miguel Aragón
@MiguelAraCo
We want to improve it later on to try to diagnose the error and give you better hints on how to fix them
Alex Arriaga
@alex-arriaga
:thumbsup:
Alvaro
@alvaro9210
We’ve opened an issue to track the bug.
Please, feel free to complement the description:
CarbonLDP/carbonldp-panel#30
Miguel Aragón
@MiguelAraCo
A new version of the workbench is available for download now!
The main changes are
  • New documents can be created using the Document Explorer
  • Documents can be deleted using the Document Explorer
  • Access points can be created using the Document Explorer
  • The Document Explorer won't show a twisty icon if a document doesn't have children or access points
  • Other minor improvements
Miguel Aragón
@MiguelAraCo

Version 0.7.1 is available for download now!
The main change is:

  • Application agents and roles can be managed under a new Security section

You can read more on how to upgrade the workbench here: https://carbonldp.com/documentation/quick-start-guide#update-your-instances-when-new-versions-are-released

Cody Burleson
@codyburleson
Did the URL change for the Workbench in release 0.7.1? As per the documentation, I navigate to localhost:8000, but now, I get a 404 Not found. It looks like that error page is being served by the web server in the container though.
What might I do to troubleshoot?
Alvaro
@alvaro9210
@codyburleson Which URL’s are you browsing? Even localhost:8000/login redirects you to the 404 page?
Alvaro
@alvaro9210
Are you accessing with a /src after the domain?
localhost:8000/src ?
Cody Burleson
@codyburleson
No
Alvaro
@alvaro9210
What’s the URL you’re requesting?
Cody Burleson
@codyburleson
OK, I see
I need to add /login.
Alvaro
@alvaro9210
hmmmm
So with:
http://localhost:8000/ —> 404
http://localhost:8000/login —> OK ???
Cody Burleson
@codyburleson
/login works. My notes are bad.
Alvaro
@alvaro9210
mmm ok, but it should be working withouth /login, though
Cody Burleson
@codyburleson
Nope.
Should I open an issue?
I opened one.
CarbonLDP/carbonldp-workbench#24
AlexSerrano22
@AlexSerrano22
Hi guys, I have a recommendation maybe it is not a big deal, but if the workbench is an SPA it will be cool that you could refresh your documents tree on the explorer without refresh the page or change to another and go back. I saw that you can refresh a document but you haven't a button to refresh the tree.
Cody Burleson
@codyburleson
That's a good suggestion. I'm pretty sure I had the same thought the other day. I might have even opened an issue for it (let me look)...
Yep: CarbonLDP/carbonldp-panel#58
AlexSerrano22
@AlexSerrano22
thanks Cody and another thing I see that on the dashboard page you have a couple of cards with information of your platform, like documents and triples, are you thinking on provide some mechanism to customise this cards? thinking that I'm interested to know how many documents of user type I have on the platform, I know that I could save my query in the SPARQL section but maybe could have a custom card with this query to have a card on the dashboard
Cody Burleson
@codyburleson
That's a pretty neat idea. I'll put that in the backlog for consideration.
CarbonLDP/carbonldp-panel#59
Rodolfo Aguirre
@roddolf
One can actually refresh the tree manualy without refreshing the entire page.
You just need to close and open the tree.
Screen Shot 2018-01-17 at 10.00.59 AM.png
AlexSerrano22
@AlexSerrano22
ooo ok thanks, I will keep in mind
daleewald
@daleewald
Hi all, installed the platform container and the workbench container. At host:8000 I keep seeing the message "No running platform"; yet in the Network tab I see it is communicating with the platform, with data responses
Then, when trying to create a non-admin user, I get "this.context doesn't exist" error in the UI
Alex Arriaga
@alex-arriaga
Did you install Carbon in your localhost or in FQDN?
Wait... which version of the docs are you reading?
It should be 1.0.x :)
daleewald
@daleewald
I installed carbon on a remote host (VM); set host mapping for that vm on my laptop, then address the workbench by the mapped fqdn
Alex Arriaga
@alex-arriaga
Could you paste your config.yaml file, please?
daleewald
@daleewald
I installed the alpha version; docs are the alpha