Where communities thrive

  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
  • 20:30
    hupling edited #386
  • 20:29
    hupling edited #374
  • 20:29
    hupling labeled #386
  • 20:29
    hupling labeled #386
  • 20:29
    hupling opened #386
  • Jun 24 16:35
    d95776 labeled #385
  • Jun 24 16:35
    d95776 labeled #385
  • Jun 24 16:35
    d95776 opened #385
  • Jun 23 16:04

    wgalanciak on v1.4.5


  • Jun 23 16:03

    GenuitecKanbot on master

    Helm chart for CodeTogether (compare)

  • Jun 23 15:59

    wgalanciak on master

    [Helm] Use public Docker reposi… (compare)

  • Jun 21 12:00

    wgalanciak on v1.4.3


  • Jun 21 11:59

    wgalanciak on v1.4.4


  • Jun 21 11:57

    GenuitecKanbot on master

    Helm chart for CodeTogether (compare)

  • Jun 21 00:01
    GenuitecKanbot commented #369
  • Jun 20 16:16

    wgalanciak on master

    Add db ssl secret checksum to s… (compare)

  • Jun 20 16:15

    wgalanciak on master

    Update appVersion in the Helm c… (compare)

  • Jun 20 16:11

    wgalanciak on 382-helm-simplify-ingress-configuration-in-the-helm-chart


  • Jun 20 16:11

    wgalanciak on master

    [Helm] Simplify ingress configu… (compare)

  • Jun 20 16:11
    wgalanciak closed #384
Riain Condon
Screenshot 2022-01-28 at 09.54.08.png
I've left out client id/oidc endpoint at the top of this ^
Brian Fernandes
Riain Condon
Screenshot 2022-01-28 at 15.19.30.png
@brianvfernandes the stats in the call look wrong
Riain Condon
Screenshot 2022-02-08 at 20.03.41.png
Riain Condon
Screenshot 2022-02-08 at 20.50.46.png
I'm very new to CodeTogether... Where would I go for some help with a STM32 project?
1 reply
I have an issue I can't run a java project on eclipse
1 reply
Trying to remove tabNine from eclipse. Not sure where to go
5 replies
Giulio Valentino Dalla Riva

Hi Everyone! I started using CodeTogether (on VS Code) for my class yesterday (it's a 4th year complex network analysis, we use R and Julia mostly). I had a flurry of glitches and errors popping up. Is there a good way of reporting and getting some assistance?


  • connection was jumpy (a lot of hanging connection, "session is no more available"...), especially if the session was started from a student
  • The students working from mac os x laptop had issues executing the code remotely (i.e., instead of being executed in the host instance, VS Code spawned a local repl and used that to run the code). They could copy and paste the code by hand in the Terminal and run it on the host, but not ctrl+enter it from the editor.
  • when trying to host the session from a Remote SSH instance rather then local, the codetogether clients were not able to see the files in the remote server (but would see the terminal). This is the most annoying, as it bars us to use the computational resources we have in that server.
9 replies
Hey, my friend and me tried to create a website with html and css. So he was the host and i wanted to join his session. My VS Code didn't show any files. I joined with google chrome and everything was fine. So i reinstalled CodeTogether and it didn't work. Same with my VS Code reinstallation. Could somebody help me please?
83 replies
Riain Condon

Hey - in our PoC some of our engineers came across an issue with running tests in IntelliJ - the issue from our engineer

"I was the host and when running the tests, colleague couldn’t see the Test results within IntelliJ. When he runs the test they do get executed in my IDE (the host) and I can see the results but he still cannot see them. We were looking the docs and supposedly we can set up a Run configuration using a “Remote Test (CodeTogether)” that could work. But when we tried setting it up to add our test the Select button would not work. Also, setting this up for every test seems a bit painful as it doesn’t show up as a default run configuration in the Test file."

A workaround for this is to just use the terminal window in IntelliJ and use gradle to run our tests but is there a way to fix the above?

50 replies
Is anybody know how to create a servlet in the new version of Eclipse dynamic web project (with the path src/main/java) ? I have looked for recent documentation, but found nothing !
i currently use vs code live share and it works fine, but it has one problem, that it reloads the localhost everytime a change has been made
i need a tool where each developer has its own local host
but work on one codebase
1 reply
hello everyone :)
i want to learn how to code plugins for minecraft someone that can help me
Hi, I subscribed CodeTogether Pro, but it is not activated in my IntelliJ.
1 reply
What is my account password if i signed up using the Educational License? How do I log in to my CodeTogetehr account when I
CodeTogether account when I received no password?*
PS: I also have nothing in my cart unlike mentioned in the mail that was sent to me can anyone help please? :(
24 replies
received yes
how do i activate it in eclipse?
Hi I'm evaluating CodeTogether for use in teaching a full stack course, it seems to be the only product that actually supports everything I want, but I can't even manage to get VS Code plugin to join a room
is there somewhere i can see logs or something?
it just silently does nothing when i click join, i get the approval box in the host IDE, click approve, then nothing else happens
1 reply
I would love to use CodeTogether with Intellij. However, after clicking on "Host New Session", the next screen shows "Connecting to CodeTogether..." and seems to hang (no changes for multiple minutes). Also, in the idea.log no error message is shown. I am behind an HTTP proxy and I have configured that proxy in the Intellij IDE (and a connection test was successful). Could you provide some help?
3 replies
Tony Truong

Hello @brianvfernandes after we finished the company wide test phase we gathered some feedback:
I would create github issues from those remarks, however I wanted to confirm with you beforehand, which one are actionable on your side.

Best regards, Tony

Testing (Intellij, Kotlin):

Session is project scoped:

  • Feature/Session is only scoped to project, people often have multiple projects open

Not all panels are visible:

  • (i.e terminal / run / debug panels)

Dependencies (Intellij, Kotlin):

  • Navigation through files and dependencies that are not part of the project

  • Especially third-party libraries often cannot be navigated into, has to be done manually by the host

Autocompletion and highlighting:

  • Does not consistently work for every project, especially in big projects with spring boot


  • Shortcuts dont work reliably (i.e. run debug, detect duplicate lines...)
31 replies
Hi is codetogether able to share JFrame with teams? or possible to run on their side through codetogether
3 replies
Hi, I'm evaluating CodeTogether for some use cases but am running into the same issue as a couple people above with test results/output only being visible to the host and not to the guests. If it matters, this is on a Java Spring Boot project, and I tried with tests written in both Java and Groovy. Are there any fixes/workarounds for this issue?
1 reply
hi, i want to share terminals that can write
but i don't how to set terminals
2 replies
in vscode env
17 replies
hello there. I just subscribed to CodeTogether but it can't detect my subscription.
Hello, I want to ask let's say I'm off my eclipse (I'm host). How can my team still code?
1 reply