Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • 20:38

    eggplantzzz on bump-inquirer

    (compare)

  • 20:38
    eggplantzzz closed #5468
  • 20:37
    eggplantzzz edited #5468
  • 20:36
    eggplantzzz synchronize #5468
  • 20:36

    eggplantzzz on bump-inquirer

    bump inquirer to 9.1.0 downgrade inquirer to 8.2.4 (compare)

  • 20:20
    shayzee removed as member
  • 19:20
    eggplantzzz synchronize #5468
  • 19:20

    eggplantzzz on bump-inquirer

    add node types to box (compare)

  • 19:04

    fainashalts on compiler-plugin-system

    Remove compiler interface for n… (compare)

  • 18:46

    fainashalts on compiler-plugin-system

    add command handling for '--ver… filter out inputOptions after t… Merge pull request #5395 from t… and 1 more (compare)

  • 18:27

    haltman-at on ether-gnose

    (compare)

  • 18:27

    haltman-at on develop

    Add gnosis network to etherscan… Merge pull request #5469 from t… (compare)

  • 18:27
    haltman-at closed #5469
  • 17:44
    haltman-at review_requested #5469
  • 17:44
    haltman-at review_requested #5469
  • 17:44
    haltman-at review_requested #5469
  • 17:44
    haltman-at review_requested #5469
  • 17:44
    haltman-at opened #5469
  • 17:44
    haltman-at review_requested #5469
  • 17:44
    haltman-at review_requested #5469
AzmuthSzym
@AzmuthSzym
Hi guys, I have a problem with a React Truffle Box. I deploy the contracts, the site runs I get a transaction but the gas is not set and no matter if I decline or change gas the number that should change does not
Wong Tao Zhe
@wongtaozhe:matrix.org
[m]
Hi I'm a new developer here. I got a transaction exited with an error (status 0) when running truffle migrate --network rinkeby to upgrade my smart contract.
Any idea what's the issue? Thanks in advance
Priyanshu Rajput
@pri_3x_twitter

Hi, I am having an issue while deploying my smart contract, When I use the command "truffle compile" on my terminal, it gives me error which is "cannot find module babel-register" Can someone please help me? Thanks

Same issue. Please help

Abcold
@Abcold

Hello, I am new to blockchain and am trying to walk through the PetShop tutorial. I have deployed Hyperedger Besu on an AWS machine and am trying to migrate my contracts over there,
https://github.com/dappuniversity/nft but it keep failing. The output error is :Error: Deployment Failed

"Migrations" -- Returned error: The method eth_sendTransaction is not supported. Use eth_sendRawTransaction to send a signed transaction to Besu..1_initial_migration.js

Deploying 'Migrations'

Error: Deployment Failed

"Migrations" -- Returned error: The method eth_sendTransaction is not supported. Use eth_sendRawTransaction to send a signed transaction to Besu..

at /usr/local/lib/node_modules/truffle/build/webpack:/packages/deployer/src/deployment.js:365:1
at processTicksAndRejections (internal/process/task_queues.js:95:5)
at Migration._deploy (/usr/local/lib/node_modules/truffle/build/webpack:/packages/migrate/Migration.js:70:1)
at Migration._load (/usr/local/lib/node_modules/truffle/build/webpack:/packages/migrate/Migration.js:56:1)
at Migration.run (/usr/local/lib/node_modules/truffle/build/webpack:/packages/migrate/Migration.js:217:1)
ShineDAO
@ShineDAO
Does anyone has any problems with avalanche deployments? I am having the same issue as the person here trufflesuite/truffle#4028 but updating the truffle hd provider doesn't work in my case
Kaufmannhardt
@Kaufmannhardt
<< everyone is optimistic about the rise and fall of the cryptos. personally, you can all agree with me that the bitcoin price is going to exceed its current value to $71,415 in February 2022, panelists have also predicted the bitcoin price to skyrocket to an average of $249,578 by the year 2024 which could also influence the price of altcoins. it's never too late to buy and hold of Ethereum/Bitcoin now is the right time. I personally have sustained over $567,000 since last year still now copying advance trade signals and indicating stop lost and manage risk following a mentorship and a blockchain specialist https://declanbrock.com/ his pattern are very lucrative with full of complex.
_
SunTeco
@SunTeco
Hallo
Eladio Robles
@eludius18

I just Tried to deploy Sushiswap fork in Harmony it shows the following error:
Error: Returned error: intrinsic gas too low

I just tried to modify the Gas limit and Gas Price but remains the same error

a
Lucas Vazquez
@lgvaz
Hi! When I use truffle console it automatically loads contracts from the current directory, is there a command to load contracts on other directories?
Eladio Robles
@eludius18
Hi Lucas,
truffle console and then truffle migrate —network xxx
DamirKrg
@DamirKrg
hi how can help me? when i try truffle compile , i get Error: ENOENT: no such file or directory, open '.secret'
DamirKrg
@DamirKrg
truffle compile
Error: ENOENT: no such file or directory, open '.secret'
ropstah
@ropstah
Hi all. I'm following a tutorial that inside a test validates a BigNumber instance using Chai. I can console log both variables console.log(decimals); and console.log(web3.utils.toBN(_decimals)); which results in the exact same string: BN { negative: 0, words: [ 18, <1 empty item> ], length: 1, red: null } and BN { negative: 0, words: [ 18, <1 empty item> ], length: 1, red: null }. However when I add the following check: decimals.should.be.bignumber.equal(web3.utils.toBN(_decimals)); the following exception is thrown: AssertionError: expected <BN: 12> to be an instance of string, number or BigNumber. Can anyone explain what I'm missing here?
Sandi Gec
@sandig_gitlab
Hi! I have an issue. Is it possible to integrate @truffle/contract library in Angular 13 project? At the moment I get the following error when I try to include "var contract = require("@truffle/contract");" into an component (*.ts file):
"BREAKING CHANGE: webpack < 5 used to include polyfills for node.js core modules by default.
This is no longer the case. Verify if you need this module and configure a polyfill for it."
Rashi Abramson
@roshkins
Is ganache ui supported anymore? I saw the last commit was in 2020
swkim109
@swkim109
@roshkins I think it is working in progress... in 2.6.0?
https://github.com/trufflesuite/ganache-ui/releases/tag/v2.6.0-beta.3
Ghost
@ghost~61a538076da03739848b8bff
Hello, I am having trouble with running 'truffle test' in the terminal on my contract. When I run a test I keep receiving the error "TypeError: pollInstance.createPoll is not a function." I am unsure of how to fix this given that I declared my artifacts variable at the beginning of the test file and I declared a deployment of my "PollFactory" contract before each test. Does anyone know how to deal with this error?
Aaron Boyd
@aaronmboyd

Hi all, getting this error during migrations rlp: value size exceeds available input length.

Is this a contract size issue? Network is Celo (Baklava testnet). Same migrations works perfectly fine on Celo (Alfajores testnet).

gghacxa1
@gghacxa1_twitter
Hi, i have an issue with truffle compile command, when i run it the build folder is created but it is empty, there is no abi inside. I tried to reinstall truffle but it doesnt help. Does anyone have same problem?
Ghost
@ghost~61ccdced6da03739848d43aa
Hi Everyone.
I want to study blockchain.
FMtoken
@fmtlol_twitter
Hi all
atang08
@atang08
hello
conflicted...do i stick with truffle or do i start a new project with hard hat.
Ryan Martin
@fintech_martin_twitter
hello all, i have been a accounting major for the past 3 years and only have till summer to graduate. How much progress on blockchain development is possible within a 6 month time frame?
Christian Peters
@d_avantgarde_twitter
hello

I'm trying to deploy to polygon with a config that is used to work. I'm already willing to pay a high fee, but nothing works.

matic: {
      provider: () => new HDWalletProvider({
        mnemonic: {
          phrase: process.env.MNEMONIC
        },
        providerOrUrl: 'https://rpc-mainnet.maticvigil.com/v1/<ny',
      }),
      network_id: 137,
      confirmations: 2,
      timeoutBlocks: 2000,
      gas: 10000000,
      gasPrice: 150000000000,
      networkCheckTimeout: 10000000,
    },

Is there something wrong here?

Chris Hughes
@hughes-ch
Hey everyone. I hope this is a quick question. I'm working on a personal project to use an ERC20 token to pay gas prices. I'm trying to use OpenGSN (find it here: https://opengsn.org/). OpenGSN works by wrapping the web3 provider, so I'll need to update the provider in truffle-config.js for my network. The problem is that the function OpenGSN provides to create a provider is asynchronous (returns a Promise). Does truffle-config.js support Promises for the provider setting?
CryptoBabies.com
@_cryptobabies_twitter
@d_avantgarde_twitter have you tried using Infura or alchemy instead of maticvigil ?
I had the same issues with truffle... I'd recommend switching to hardhat
the hardhat config for polygon is dirt simple...
polygon: {
url: POLYGON_MAINNET_RPC_URL,
accounts: [PRIVATE_KEY],
saveDeployments: true,
},
RPC_URL pointing at Alchemy API in my case..
works great!
depoyed to Eth, rinkeby, kovan, polygon and mumbai with hardhat.. i really struggled with truffle.
CryptoBabies.com
@_cryptobabies_twitter
oh, this is the truffle room, sorry to throw you under the bus.. just sharing my experience ;)
Suraj Nair
@suraj_rtistiq_gitlab

Hello all,

I am trying to deploy my contract to Polygon mainnet. But getting this error
Saving migration to chain.Error [ERR_UNHANDLED_ERROR]: Unhandled error. ({
code: -32603,
message: 'ESOCKETTIMEDOUT',
data: { originalError: { code: 'ESOCKETTIMEDOUT', connect: false } },
stack: 'Error: ESOCKETTIMEDOUT\n'
I can see the transaction in polygonscan, but the migration is not getting saved.

Benedict
@githubBenedict
hello
Benedict
@githubBenedict
nice site @_cryptobabies_twitter
CryptoBabies.com
@cryptobabies
@XMASdaycoin thanks ;)
Watson Ladd
@wbl
So I don't understand the decision to have truffle test require a separate migration step. Looking at the examples it seems that truffle has all the information it needs to deploy the contracts used by the test to local developer instance. I particularly don't understand how is supposed to work with constructors. Does my migration for testing need to call all constructors as would be used in the test
Benedict
@githubBenedict
hello im having an issue downloading and installing ganache, terminal is outputting that electron-webpack does not exist despite installing it from https://github.com/electron-userland/electron-webpack-quick-start
any thoughts?
mpoletiek:matrix.org @mpoletiek:matrix.org waves
:(
Can anyone help?
Duke Crypto
@DukeCrypter_twitter
hi guys, does anyone here knows how to fix this error? "Unable to generate Contract ByteCode and ABI" - BSC