Where communities thrive

  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
    Archimedes Trajano
    @StoreHost i may have resolved it on my plugins the concept is the information when doing a Create must be saved in the rootfs. However, the documentation does not make any specific mention about doing that.
    Jakir Patel
    Please check my PR
    that will resolve this issue.
    @gondor Could you please check my PR with docker-volume-netshare plugin? Please let me know if you get this message. I am not sure how active this group is.
    Abraham Calás
    Hello I need some help with netshare!!! I am using a swarm with three nodes. If the service start on the manager node, everythings works ok, but if I force the service to run on the workers, I recieve the following error:
    no suitable node (missing plugin on 2 nodes; scheduling constraints not satisfied on 1 node).
    On all nodes the netshare nfs is running as a service.
    Jakir Patel
    @dogcalas_gitlab Please share the logs
    of docker-volume-netshare
    Abraham Calás
    @jakirpatel where I can find the docker-volume-netshare logs, and in what node? I have 3 nodes on my swarm.
    Jakir Patel
    You can find it on /var/log/messages
    If you started docker-volume-netshare as systemd process
    Jakir Patel
    Jakir Patel
    @gondor Just want to update you about my PR hope you will find time to merge it
    Hi do you know how to install the docker-volume-netshare on a docker machine. It's a boot2docker
    Steve Grevemeyer
    Ok, I'm feeling really stupid... What's the trick to getting a CIFS file system mounted with a specific uid/gid (uid=48,gid=48)?
    @grevemes docker volume create -d cifs --name xxxx/dockervolumes/nexus --opt username=xxxx --opt password=xxxxx --opt fileMode=0777 --opt dirMode=0777 have you tried that
    Does ContainX/docker-volume-netshare have Windows support?
    Jeroen v/dr Schoot

    I managed to get a CIFS volume working when specifying credentials in .NetRC file.
    Is it also possible to configure credentials in docker compose file?

    driver: cifs
    share: cifshost/share

      #username: user
      #password: pass

    I tried but that doesn't seem to work.

    hey guys
    When looking for a solution to mount Windows shares to my containers, I found NetShare this afternoon. Have a question, though; please. My Docker host is Atomic (Fedora 28) therefore doesn't have dpkg or other common tools and didn't see an rpm release. I could use rpm-ostree to perhaps install tools to install/build it, but wanted to look to see what the suggested method of implementation would be. Any suggestions?
    Matt Beaney
    hey folks, I'm trying to create a volume from a cifs share, but for some reason netshare is trying to mount it using a docker 'hostname' as opposed to the actual name of the box:

    `INFO[0153] Mount: 62bb276888b9529cc919aaea35402cb91987308a35535b2d6c3dc46ae7b1e560, ID: 589049f82ab088274cdfefa5ec3a88a5a6b4fe5abb7f8d650faaecae54aadad0
    INFO[0153] Mounting CIFS volume //62bb276888b9529cc919aaea35402cb91987308a35535b2d6c3dc46ae7b1e560 on /var/lib/docker-volumes/netshare/cifs/62bb276888b9529cc919aaea35402cb91987308a35535b2d6c3dc46ae7b1e560
    DEBU[0153] GetCreds: host=62bb276888b9529cc919aaea35402cb91987308a35535b2d6c3dc46ae7b1e560, netrc=&{/home/x1um1n/.netrc [0xc420318210] []}
    DEBU[0153] Executing: mount -t cifs -o vers=1.0,noperm,fileMode=0777,dirMode=0777,guest,sec=ntlm,rw //62bb276888b9529cc919aaea35402cb91987308a35535b2d6c3dc46ae7b1e560 /var/lib/docker-volumes/netshare/cifs/62bb276888b9529cc919aaea35402cb91987308a35535b2d6c3dc46ae7b1e560

    2019/06/15 19:07:51 mount error: could not resolve address for 62bb276888b9529cc919aaea35402cb91987308a35535b2d6c3dc46ae7b1e560: Unknown error`

    I had this working earlier this evening, then I put a fresh install on my media server, with the intention of building a nice clean dockerised setup, but now it won't work
    I'm running docker-volume-netshare 0.36, on ubuntu 18.04, with docker installed from snap
    Mark van Rijbroek
    hello, i've successfully started the netshare plugin with the cifs option and a .netrc file, and I can start a container with a cifs share mounted to it, I can even list the contents of the share on the mount location on the docker host, but when I try to do anything on the mount location in the container I get a permission denied error
    event a simple ls -al is denied
    Mark van Rijbroek
    well, adding --privileged=true when starting seems to work, now to just figure out how to give less permissions
    Mark van Rijbroek
    i figured it out. Adding a context to the startup of the netshare service helps: ./docker-volume-netshare cifs -o context=system_u:object_r:svirt_sandbox_file_t:s0
    Mauricio Nunes

    this message is normal?

    2019/08/06 13:32:04 Entering go-plugins-helpers listPath

    Hello, i struggle with some issue of mapping windows10 share with docker-volume-netshare using parameters: security=ntlm -o cifsopts=vers=3.11 didn't work
    from windows machine it's ok and also windows7 share is working. Can someone have such issue?
    from logs: returned error: error while mounting volume '': VolumeDriver.Mount: exit status 32
    Victor Angelier CCX
    hi there
    can someone help out with mounting through docker-compose?
    driver: nfs
    share: <host>:/nfs-store
    what should "host" be?
    Victor Angelier CCX
    @kubex75 Try running: ./docker-volume-netshare nfs
    first. Then: ./docker-volume-netshare nfs -a 1.26 -o port=2049,proto=tcp,nolock --basedir=/home/nfs
    for example
    then you can run: docker run -i -t --volume-driver=nfs -v /home/nfs:/tmp/nfs ubuntu /bin/bash
    Spencer York
    @kubex75 I'm getting an exit status 32 as well, just came here to determine the potential cause
    @digitalhuman I'm running the plugin as a service and getting the the status 32
    @digitalhuman - thank you for advice, i think it was some other case
    @dsyorkd - this works for me: -o cifsopts=vers=2.0 (and without -o ntlm)
    Win10 has smb v1 blocked and ntlm v2 active so specified parameters need to be provided
    Stefan Züger

    Hello, I'm trying to install docker-volume-netshare as a systemd service on CentOs but it always returns "(code=exited, status=203/EXEC)"
    the service file looks the following:
    Description=Docker Volume Netshare Plugin

    ExecStart=/opt/netshare/docker-volume-netshare2 nfs


    do you have any help? thank you

    Salim Fadhley
    Does anybody know if the Netshare plugin works on Docker for Windows? I'm trying to run Windows containers on Docker for Windows. I need a solution for mounting various important windows shares into my containers.
    Salim Fadhley
    I just need a way to make a Windows SMB/CIFS volume available to a running a Windows container on a Windows host.