Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
Ross Mounce
@rossmounce
Ok, I'm here
probably have 5mins before we have to head off for lunch
Richard Smith-Unna
@blahah
ok
so first let's figure out the error with the update script
$ npm uninstall --global quickscrape
$ npm install --global quickscrape@0.3.2
Ross Mounce
@rossmounce
running... (sorry just had to tweet the selfie) ;)
Richard Smith-Unna
@blahah
:)
Ross Mounce
@rossmounce
GAH! still reporting 0.3.1 after running those 2 commands
Richard Smith-Unna
@blahah
goddamit
Ross Mounce
@rossmounce

Downloading https://bitbucket.org/ariya/phantomjs/downloads/phantomjs-1.9.8-linux-i686.tar.bz2
Saving to /home/workshop/tmp/phantomjs/phantomjs-1.9.8-linux-i686.tar.bz2
Receiving...
[========================================] 100% 0.0s
Received 13200K total.
Extracting tar contents (via spawned process)
Removing /home/workshop/.nvm/v0.10.24/lib/node_modules/quickscrape/node_modules/thresher/node_modules/phantomjs/lib/phantom
Copying extracted folder /home/workshop/tmp/phantomjs/phantomjs-1.9.8-linux-i686.tar.bz2-extract-1415902446219/phantomjs-1.9.8-linux-i686 -> /home/workshop/.nvm/v0.10.24/lib/node_modules/quickscrape/node_modules/thresher/node_modules/phantomjs/lib/phantom
Removing /home/workshop/tmp/phantomjs/phantomjs-1.9.8-linux-i686.tar.bz2-extract-1415902446219
Writing location.js file
Done. Phantomjs binary available at /home/workshop/.nvm/v0.10.24/lib/node_modules/quickscrape/node_modules/thresher/node_modules/phantomjs/lib/phantom/bin/phantomjs
npm http GET https://registry.npmjs.org/rimraf
npm http 304 https://registry.npmjs.org/rimraf
npm http GET https://registry.npmjs.org/bindings
npm http GET https://registry.npmjs.org/readable-stream
npm http GET https://registry.npmjs.org/domutils
npm http GET https://registry.npmjs.org/domhandler
npm http GET https://registry.npmjs.org/domelementtype
npm http GET https://registry.npmjs.org/nan
npm http GET https://registry.npmjs.org/entities
npm http 304 https://registry.npmjs.org/readable-stream
npm http 304 https://registry.npmjs.org/bindings
npm http 304 https://registry.npmjs.org/domutils
npm http 200 https://registry.npmjs.org/domelementtype
npm http GET https://registry.npmjs.org/domelementtype/-/domelementtype-1.1.3.tgz
npm http 200 https://registry.npmjs.org/nan
npm http 200 https://registry.npmjs.org/entities
npm http 200 https://registry.npmjs.org/domelementtype/-/domelementtype-1.1.3.tgz
npm http 200 https://registry.npmjs.org/domhandler
npm http GET https://registry.npmjs.org/domhandler/-/domhandler-2.3.0.tgz
npm http 200 https://registry.npmjs.org/domhandler/-/domhandler-2.3.0.tgz

contextify@0.1.9 install /home/workshop/.nvm/v0.10.24/lib/node_modules/quickscrape/node_modules/thresher/node_modules/jsdom/node_modules/contextify
node-gyp rebuild

make: Entering directory /home/workshop/.nvm/v0.10.24/lib/node_modules/quickscrape/node_modules/thresher/node_modules/jsdom/node_modules/contextify/build' CXX(target) Release/obj.target/contextify/src/contextify.o SOLINK_MODULE(target) Release/obj.target/contextify.node SOLINK_MODULE(target) Release/obj.target/contextify.node: Finished COPY Release/contextify.node make: Leaving directory/home/workshop/.nvm/v0.10.24/lib/node_modules/quickscrape/node_modules/thresher/node_modules/jsdom/node_modules/contextify/build'
/home/workshop/.nvm/v0.10.24/bin/quickscrape -> /home/workshop/.nvm/v0.10.24/lib/node_modules/quickscrape/bin/quickscrape.js
quickscrape@0.3.2 /home/workshop/.nvm/v0.10.24/lib/node_modules/quickscrape
├── which@1.0.5
├── commander@2.2.0
├── chalk@0.5.1 (supports-color@0.2.0, escape-string-regexp@1.0.2, ansi-styles@1.1.0, has-ansi@0.1.0, strip-ansi@0.3.0)
├── winston@0.7.3 (cycle@1.0.3, stack-trace@0.0.9, eyes@0.1.8, colors@0.6.2, async@0.2.10, pkginfo@0.3.0, request@2.16.6)
└── thresher@0.1.0 (underscore-deep-extend@0.0.5, set@1.1.1, eventemitter2@0.4.14, xpath@0.0.6, shelljs@0.3.0, request-progress@0.3.1, tough-cookie@0.12.1, lodash@2.4.1, spooky@0.2.5, request@2.42.0, casperjs@1.1.0-beta3, download@1.0.7, jsdom-little@0.10.5, phantomjs@1.9.12, jsdom@0.11.1)

Richard Smith-Unna
@blahah
bizarre - it seems to have worked
Ross Mounce
@rossmounce
oh okay
it works now
but the version is still 0.3.1
might be fixed
Richard Smith-Unna
@blahah
huh
Ross Mounce
@rossmounce
but not the latest version shrugs
Richard Smith-Unna
@blahah
ok - I will keep trying to figure it out
OK, I forgot to update the version string in the app itself
Ross Mounce
@rossmounce
going to lunch now
Richard Smith-Unna
@blahah
d'oh
Ross Mounce
@rossmounce
brb in 1hour
Richard Smith-Unna
@blahah
but it should work ok
Ross Mounce
@rossmounce
back now.
and yes, it works ok
:)
Richard Smith-Unna
@blahah
:)
Jack Park
@KnowledgeGarden
Where to ask questions about contentmine-app?