Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Dec 07 16:00
    PerhapsSomeone review_requested #277
  • Dec 07 16:00
    PerhapsSomeone opened #277
  • Nov 08 15:23
    iprisj edited #276
  • Nov 08 12:48
    iprisj opened #276
  • Nov 08 08:29
    Sharparam closed #275
  • Nov 08 08:29
    Sharparam commented #275
  • Nov 08 00:20
    iprisj opened #275
  • Sep 27 12:48
    MasterR8 closed #273
  • Sep 05 16:31
    MasterR8 commented #273
  • Sep 05 16:23
    Sharparam commented #273
  • Sep 05 16:07
    MasterR8 commented #273
  • Sep 03 09:46
    Sharparam commented #273
  • Sep 03 09:44
    Sharparam edited #273
  • Sep 03 09:44
    Sharparam edited #273
  • Sep 03 09:43
    Sharparam milestoned #274
  • Sep 03 09:43
    Sharparam commented #274
  • Sep 03 09:42
    Sharparam labeled #274
  • Sep 03 09:06
    poveden edited #274
  • Sep 03 09:06
    poveden opened #274
  • Aug 15 16:13
    MasterR8 opened #273
Adam Hellberg
@Sharparam
This is strange
Rudolf Frank
@RudolfFrank_twitter
ChromaLink.SetAllAsync and ChromaLink.ChromaLinkCustom both work fine. chroma.SetAllAsync only sets the keyboard.
Adam Hellberg
@Sharparam
ah, well i found the issue. chroma.SetAllAsync is missing a call to set all colors on the chroma link
@RudolfFrank_twitter 6.0.0-unstable151 is now available from MyGet which should fix the issue: https://www.myget.org/feed/coralestudios/package/nuget/Colore/6.0.0-unstable0151
Rudolf Frank
@RudolfFrank_twitter
thank you very much!
Adam Hellberg
@Sharparam
thank you for reporting the issue :)
Jack Morgan
@JackMorgan9_twitter
Hi folks, does this work with the razer emulator? I don't own razer devices myself, but would be nice to incorporate features for them. I've created a blank test form and added the exact sample code from the 5.2 guide, but emulator does not change colour. Thanks
Adam Hellberg
@Sharparam
@JackMorgan9_twitter i haven't looked into exactly how the emulator functions, but assuming it emulates the SDK DLLs in some way, it should work
Adam Hellberg
@Sharparam
@JackMorgan9_twitter i tested it now with the keyboard and it seems to work. I checked the checkbox for "Keyboard", then launched the window with "Show", and set colors via Colore, it updated the emulator. What steps are you taking when testing the emulator?
Jack Morgan
@JackMorgan9_twitter
Installed Colore with nuget, installed emulator, Created blank winforms, added button, on the buttons click event, put the sample code in to change all colours to red. Also have keyboard ticked and pressed show.
Jack Morgan
@JackMorgan9_twitter
@Sharparam On thinking about it, maybe it's because I don't have any razer devices. I do have the "RzChromaSDK64.dll" located in "Windows\System32" and "C:\Program Files\Razer Chroma SDK\bin"
Adam Hellberg
@Sharparam
the emulator should work without any devices as long as you have synapse installed (which installs the chroma sdk)
Jack Morgan
@JackMorgan9_twitter
How strange. I'll re-install everything and create a new winforms. Thanks for the help
Adam Hellberg
@Sharparam
@JackMorgan9_twitter focus on Colore is mostly on the 6.0 version now. 5.2 should work with the emulator, but just to rule out that as an issue, can you try with 6.0.0 from here? https://www.myget.org/feed/coralestudios/package/nuget/Colore
Jack Morgan
@JackMorgan9_twitter
@Sharparam Will do, i'll let you know
Adam Hellberg
@Sharparam
(note that the API changes quite a bit as everything is now async and the process of obtaining an instance of Chroma has changed)
Jack Morgan
@JackMorgan9_twitter
So if Synapse installs the SDK, I wont need to grab the .dll files on my own
Adam Hellberg
@Sharparam
that's right
the SDK doesn't need a separate install anymore
so you should just need synapse, the emulator, and colore from the above link
Jack Morgan
@JackMorgan9_twitter
Ok, cheers. I'll report back soon
Adam Hellberg
@Sharparam
an updated getting started guide for 6.0.0 can be found here: https://coralestudios.github.io/Colore/devdocs/articles/getting-started.html
Jack Morgan
@JackMorgan9_twitter
@Sharparam Unistalled everything Razer related. Reinstalled Synapse, then emulator, started a fresh winforms, added 6.0 getting started lines to change to all red. When running get this error - "ColoreException: Failed to dynamically load Chroma SDK library (Error 126)"
Adam Hellberg
@Sharparam
that's odd
you could try a restart in case it's some problem with PATH not updating (ensuring everything gets an updated PATH variable)
Jack Morgan
@JackMorgan9_twitter
Did a restart, still no luck. Checking PATH variables now
Jack Morgan
@JackMorgan9_twitter
Well, im stumped. Here is the full exception detail https://pastebin.com/UshhppWE
Adam Hellberg
@Sharparam
The error "126" means "module not found"
But that shouldn't happen if you installed synapse
Is it synapse version 2 or 3?
Jack Morgan
@JackMorgan9_twitter
version 2.21
Although this could have something to do with it "The latest SDK Core Files will be automatically downloaded and installed when a Razer Chroma peripheral has been detected on Razer Synapse"
and I have no peripherals, says I can download them as a standalone but I don't see it.
Adam Hellberg
@Sharparam
that could have something to do with it yeah
they seem to have removed the manual sdk download
Jack Morgan
@JackMorgan9_twitter
Guess I'll drop a post in their forum, see if they can offer one
Adam Hellberg
@Sharparam
i asked in skype as well
Jack Morgan
@JackMorgan9_twitter
Oh thanks :)
Rudolf Frank
@RudolfFrank_twitter
I've got another interesting behaviour regarding hue - just by starting my application the lights turn off automatically. At the same time, the keyboard only changes if I change something on it. Both REST and native implementations do this.
Adam Hellberg
@Sharparam
@RudolfFrank_twitter that's odd. the SDK should leave the last set synapse effect (or other chroma apps even) on devices that you haven't set any effects on yourself
Adam Hellberg
@Sharparam
@/all Colore's gitter has now moved to https://gitter.im/chroma-sdk/Colore as part of moving Colore to the chroma-sdk organization on GitHub!
Renato Marinho
@renatomarinho
This message was deleted
Roxas Keyheart
@roxaskeyheart
I just updated all my code in my app to 6.0 (develop) and I'm also getting a "Failed to dynamically load Chroma SDK library" when running ColoreProvider.CreateNativeAsync(); with error 193 :/
Renato Marinho
@renatomarinho
This message was deleted
Adam Hellberg
@Sharparam
@renatomarinho you have already sent this message twice now, so claiming it's not spam is not doing much for you. Moreover, as already noted in this channel it is no longer active.
Daniel
@Paladinleeds
What is no longer active? GitScrum?
Adam Hellberg
@Sharparam
this channel, it's part of the old "CoraleStudios" organization, we moved Colore to the new "chroma-sdk" organization: https://gitter.im/chroma-sdk/Colore
QIncarnate
@QIncarnate
hey, is this place still active?
wdblckmma
@wdblckmma_gitlab
no.
Adam Hellberg
@Sharparam
This is the new home: https://gitter.im/chroma-sdk/Colore