Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • May 01 17:29
    Sharparam closed #283
  • May 01 17:29
    Sharparam commented #283
  • May 01 17:28
    Sharparam milestoned #287
  • May 01 17:28
    Sharparam labeled #287
  • May 01 17:27
    Sharparam commented #287
  • May 01 17:24
    Sharparam labeled #286
  • May 01 17:24
    Sharparam closed #286
  • May 01 17:24
    Sharparam commented #286
  • Apr 21 10:18
    ViktorHofer edited #287
  • Apr 21 10:18
    ViktorHofer edited #287
  • Apr 20 21:28
    ViktorHofer opened #287
  • Mar 11 23:34
    JCKodel opened #286
  • Mar 03 01:50

    Sharparam on gh-pages

    [AUTOMATED] Documentation updat… (compare)

  • Mar 03 01:47

    Sharparam on develop

    Log all environment variables i… (compare)

  • Mar 02 16:22
    Sharparam closed #144
  • Mar 02 16:22
    Sharparam commented #144
  • Mar 01 21:04

    Sharparam on gh-pages

    Fix link to blog (compare)

  • Mar 01 20:54

    Sharparam on gh-pages

    Create 2021-03-01-colore-v6-0.m… (compare)

  • Mar 01 20:03

    Sharparam on gh-pages

    [AUTOMATED] Documentation updat… (compare)

  • Mar 01 19:53

    Sharparam on gh-pages

    [AUTOMATED] Documentation updat… (compare)

Adam Hellberg
@Sharparam
that's right
the SDK doesn't need a separate install anymore
so you should just need synapse, the emulator, and colore from the above link
Jack Morgan
@JackMorgan9_twitter
Ok, cheers. I'll report back soon
Adam Hellberg
@Sharparam
an updated getting started guide for 6.0.0 can be found here: https://coralestudios.github.io/Colore/devdocs/articles/getting-started.html
Jack Morgan
@JackMorgan9_twitter
@Sharparam Unistalled everything Razer related. Reinstalled Synapse, then emulator, started a fresh winforms, added 6.0 getting started lines to change to all red. When running get this error - "ColoreException: Failed to dynamically load Chroma SDK library (Error 126)"
Adam Hellberg
@Sharparam
that's odd
you could try a restart in case it's some problem with PATH not updating (ensuring everything gets an updated PATH variable)
Jack Morgan
@JackMorgan9_twitter
Did a restart, still no luck. Checking PATH variables now
Jack Morgan
@JackMorgan9_twitter
Well, im stumped. Here is the full exception detail https://pastebin.com/UshhppWE
Adam Hellberg
@Sharparam
The error "126" means "module not found"
But that shouldn't happen if you installed synapse
Is it synapse version 2 or 3?
Jack Morgan
@JackMorgan9_twitter
version 2.21
Although this could have something to do with it "The latest SDK Core Files will be automatically downloaded and installed when a Razer Chroma peripheral has been detected on Razer Synapse"
and I have no peripherals, says I can download them as a standalone but I don't see it.
Adam Hellberg
@Sharparam
that could have something to do with it yeah
they seem to have removed the manual sdk download
Jack Morgan
@JackMorgan9_twitter
Guess I'll drop a post in their forum, see if they can offer one
Adam Hellberg
@Sharparam
i asked in skype as well
Jack Morgan
@JackMorgan9_twitter
Oh thanks :)
Rudolf Frank
@RudolfFrank_twitter
I've got another interesting behaviour regarding hue - just by starting my application the lights turn off automatically. At the same time, the keyboard only changes if I change something on it. Both REST and native implementations do this.
Adam Hellberg
@Sharparam
@RudolfFrank_twitter that's odd. the SDK should leave the last set synapse effect (or other chroma apps even) on devices that you haven't set any effects on yourself
Adam Hellberg
@Sharparam
@/all Colore's gitter has now moved to https://gitter.im/chroma-sdk/Colore as part of moving Colore to the chroma-sdk organization on GitHub!
Renato Marinho
@renatomarinho
This message was deleted
Roxas Keyheart
@roxaskeyheart
I just updated all my code in my app to 6.0 (develop) and I'm also getting a "Failed to dynamically load Chroma SDK library" when running ColoreProvider.CreateNativeAsync(); with error 193 :/
Renato Marinho
@renatomarinho
This message was deleted
Adam Hellberg
@Sharparam
@renatomarinho you have already sent this message twice now, so claiming it's not spam is not doing much for you. Moreover, as already noted in this channel it is no longer active.
Daniel
@Paladinleeds
What is no longer active? GitScrum?
Adam Hellberg
@Sharparam
this channel, it's part of the old "CoraleStudios" organization, we moved Colore to the new "chroma-sdk" organization: https://gitter.im/chroma-sdk/Colore
QIncarnate
@QIncarnate
hey, is this place still active?
wdblckmma
@wdblckmma_gitlab
no.
Adam Hellberg
@Sharparam
This is the new home: https://gitter.im/chroma-sdk/Colore
iprisj
@iprisj
so this is a conversion from the usual C++ to C#
for sdk
Liu Chang Yen
@changyenOU
Hi, I would like to check that does Colore supports multiple keyboards color control? Please advice, thank you.
ronigrr
@ronigrr
there is any way that i can load ChromaEffects XML to Colors as a costume grid?
fsdsa sdsaasd
@Koekjes_boy_gitlab
Im following this basic guide "https://github.com/chroma-sdk/Colore/wiki/Getting-started" and im a pretty noob to programming but i know the basics so im struggling with this Grid thingy in the guide the code is 'var keyboardGrid = KeyboardCustom.Create();' but that KeyboardCustom is not recongized
Ghost
@ghost~5dc8e2ffd73408ce4fd09e73
is this cross platform?
rom4ster
@rom4ster
ok this lib is fucking weird,
whenever I debug it works but when i dont debug it just does not work
rom4ster
@rom4ster
Also WHY THE FUCK IS THIS MESSING WITH MY LOGITECH MOUSE
Adam Hellberg
@Sharparam
@rubiksmaster02 as far as i know, Razer's SDK is still Windows only so we're limited because of that
@rom4ster Colore only makes calls to Razer's SDK, so it affecting Logitech devices seems weird unless that's an issue in the SDK itself
things working in debug but not release and vice versa happens occasionally to people in various projects and for various reasons, so it's difficult to give advice on that without any information to go on, like what your project looks like.
rom4ster
@rom4ster

sure i can provide code

var chroma = await ColoreProvider.CreateNativeAsync();
Thread.Sleep(1000);
await chroma.SetAllAsync(ccolor.Green);

this works , remove Thread.Sleep thing, it no work. Both work when i set a breakpoint on await chroma.SetAllAsync

Adam Hellberg
@Sharparam
that sounds like it's the same issue described in #274 and #279
i'd say keep the Thread.Sleep workaround for now
or since you are in an async context, prefer await Task.Delay(1000);
rom4ster
@rom4ster
HOW specify alpha/brightness values