by

Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • 18:48
    Build #2959 passed
  • 18:48
    Build #2959 passed
  • 18:33
    Build #2958 passed
  • 18:33
    Build #2958 passed
  • 18:19
    Build #2957 passed
  • 18:19
    Build #2957 passed
  • 18:04
    Build #2956 passed
  • 18:04
    Build #2956 passed
  • 17:49
    Build #2955 passed
  • 17:49
    Build #2955 passed
  • 17:34
    Build #2954 passed
  • 17:34
    Build #2954 passed
  • 17:31
    charlesbetros synchronize #1473
  • 17:31

    charlesbetros on int_to_string

    Add DebugMode parameter Add debugmode to test runner ui Merge branch 'master' into debu… and 2 more (compare)

  • 17:29
    charlesbetros synchronize #1475
  • 17:29

    charlesbetros on add_issue_templates

    Add DebugMode parameter Add debugmode to test runner ui Merge branch 'master' into debu… and 2 more (compare)

  • 17:25
    charlesbetros assigned #1487
  • 17:24
    charlesbetros converted_to_draft #1493
  • 17:20
    charlesbetros opened #1493
  • 17:19

    charlesbetros on RemoveProcessorInformation

    Remove ProcessorInformation Clo… (compare)

fabiosarts
@fabiosarts
image.png
KM198912
@KM198912
that seems rather odd
if you hover over any error does it show you a correction solution?
fabiosarts
@fabiosarts
you mean hovering the mouse on the message?
KM198912
@KM198912
in the solution
fabiosarts
@fabiosarts
not at all, the project it's the bare new project and compiles just fine, i can even create an iso
KM198912
@KM198912
can you try something?
fabiosarts
@fabiosarts
yeah
KM198912
@KM198912
open vmware manually, then go into the VM settings and change the ISO path and check if it boots then, if you get a green debugger message (assuming it is still enabled) that is progress
fabiosarts
@fabiosarts
it does actually :)
KM198912
@KM198912
ok
this is good then
fabiosarts
@fabiosarts
could be my low memory availability?
my current pc has 4 GB of ram, which 800 mb is taken by the APU
KM198912
@KM198912
dont think so
fabiosarts
@fabiosarts
i see
KM198912
@KM198912
you error says that it could not launch the progress for vmware
process*
what happens when you restart VS?
fabiosarts
@fabiosarts
could be a missing path?
same thing, i even reinstalled visual studio, with c# and net core support
KM198912
@KM198912
let me try something then i tell you
fabiosarts
@fabiosarts
i'll check visual studio installer again
KM198912
@KM198912
that is not it
fabiosarts
@fabiosarts
i'm currently using windows 8.1
KM198912
@KM198912
with VS2019
fabiosarts
@fabiosarts
exactly
KM198912
@KM198912
after you installed VMWare did you restart your PC?
fabiosarts
@fabiosarts
yes, i had it installed a couple of weeks ago
VMs it's a must for me xD
KM198912
@KM198912
the fact that you can compile the iso and run vmware actually makes me doubt that there is something wrong
infact that is how i use it as i dont use the debugger
fabiosarts
@fabiosarts
i see, it came to my mind to do it this way, but didn't found a way to connect the debugger to the already running instance
KM198912
@KM198912
just disable the debugger
fabiosarts
@fabiosarts
i see
KM198912
@KM198912
if i want to debug i use a try catch and Console.WriteLine as i deploy to physical hardware and have no use for the debugger
fabiosarts
@fabiosarts
that's a good one :O
Matthijs ter Woord
@mterwoord
no use for debugger?
KM198912
@KM198912
i cant debug with it on pyhsical hardware xD
Matthijs ter Woord
@mterwoord
as long as your physical hardware has a (real) serial port, you can still debug
KM198912
@KM198912
it doesnt
its a very basic laptop
Matthijs ter Woord
@mterwoord
ah
fabiosarts
@fabiosarts
wouldn't an USB-RS232 adaptor work? or it would require an USB controller?
Matthijs ter Woord
@mterwoord
yes, real serial port is really low level. usb needs pci, usb implementation etc, all in assembler
KM198912
@KM198912
but so far everything, beside the HDD works on the laptop with cosmos so i cant complain
Matthijs ter Woord
@mterwoord
cool
in the early days of cosmos @czhower and me did a presentation with 3 computers and 2 beamers, showcasing real-hardware debugging
KM198912
@KM198912
i think i have seen pictures of that with some card danging around in the case
funny is that the laptop even detected the PS2 without any patches
but i might look into the routine to detect the hdd
just need to find a way to see if it detected the hdd, and not the volumes