Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • 18:33
    quajak labeled #1716
  • 18:33
    quajak labeled #1716
  • 18:33
    quajak labeled #1716
  • 18:33
    quajak labeled #1716
  • 18:33
    quajak labeled #1716
  • 13:14
    Build #3267 passed
  • 13:14
    Build #3267 passed
  • 12:59

    charlesbetros on quajak-patch-2

    (compare)

  • 12:59

    charlesbetros on master

    Increased output randomness of … Try fix build problems by chang… Missed the argument and 2 more (compare)

  • 12:59
    charlesbetros closed #1718
  • 12:50
    Build #3266 passed
  • 12:50
    Build #3266 passed
  • 12:34
    quajak synchronize #1718
  • 12:34

    quajak on quajak-patch-2

    Fixed types (compare)

  • 12:28
    quajak synchronize #1718
  • 12:28

    quajak on quajak-patch-2

    Missed the argument (compare)

  • 12:19
    quajak synchronize #1718
  • 12:19

    quajak on quajak-patch-2

    Try fix build problems by chang… (compare)

  • Apr 11 21:14
    hyperdawg commented #1683
  • Apr 11 08:56
    quajak review_requested #1718
fabiosarts
@fabiosarts
yes, i had it installed a couple of weeks ago
VMs it's a must for me xD
KM198912
@KM198912
the fact that you can compile the iso and run vmware actually makes me doubt that there is something wrong
infact that is how i use it as i dont use the debugger
fabiosarts
@fabiosarts
i see, it came to my mind to do it this way, but didn't found a way to connect the debugger to the already running instance
KM198912
@KM198912
just disable the debugger
fabiosarts
@fabiosarts
i see
KM198912
@KM198912
if i want to debug i use a try catch and Console.WriteLine as i deploy to physical hardware and have no use for the debugger
fabiosarts
@fabiosarts
that's a good one :O
Matthijs ter Woord
@mterwoord
no use for debugger?
KM198912
@KM198912
i cant debug with it on pyhsical hardware xD
Matthijs ter Woord
@mterwoord
as long as your physical hardware has a (real) serial port, you can still debug
KM198912
@KM198912
it doesnt
its a very basic laptop
Matthijs ter Woord
@mterwoord
ah
fabiosarts
@fabiosarts
wouldn't an USB-RS232 adaptor work? or it would require an USB controller?
Matthijs ter Woord
@mterwoord
yes, real serial port is really low level. usb needs pci, usb implementation etc, all in assembler
KM198912
@KM198912
but so far everything, beside the HDD works on the laptop with cosmos so i cant complain
Matthijs ter Woord
@mterwoord
cool
in the early days of cosmos @czhower and me did a presentation with 3 computers and 2 beamers, showcasing real-hardware debugging
KM198912
@KM198912
i think i have seen pictures of that with some card danging around in the case
funny is that the laptop even detected the PS2 without any patches
but i might look into the routine to detect the hdd
just need to find a way to see if it detected the hdd, and not the volumes
fabiosarts
@fabiosarts
as far i know, PS/2 it's the "default" keyboard input, as it connect directly to the cpu by using interrupts
by the other hand, i think most of the motherboards emulates an ps/2 keyboard from usb
KM198912
@KM198912
It doesnt work correctly in cosmos correctly yet
fabiosarts
@fabiosarts
doesn't it?
i assumed usb keyboards worked everywhere :O
KM198912
@KM198912
No my Computers apart from the Laptop all throw ps2 errors without patches
Kudzu
@czhower

@mterwoord I dont know which person you were responding to but:

https://www.youtube.com/watch?v=kXwlg-NN8NI

https://www.youtube.com/watch?v=d_1Bup3TR_M

KM198912
@KM198912
that was to me
because i said i wasnt able to debug on my laptop
Kudzu
@czhower
Cosmos has very limited hardware support and remote debugging on physical hardware requires a bus based serial connection
KM198912
@KM198912
yeah you told me that ages ago when my i7 was laying in its last breath
but now that i am back i am keeping my promise by helping where i can :P and if it is just writing wikis
Kudzu
@czhower
best for now is VM
KM198912
@KM198912
to debug yeah, but apart from that my laptop works perfectly with cosmos, the PS/2 is detected etc, only thing not working correctly is the HDD in Compability mode, but for that i am making AHCI talk active now to tell me what it detects @czhower
KM198912
@KM198912
anyone knows where i am going wrong here and why with 2 partitions they repeat on the second partition?
            int count = vFS.GetVolumes().Count;

            for (int i = 0; i < count; i++)
            {
                string label = vFS.GetFileSystemLabel(i.ToString());
                int UsedSpace = (int)vFS.GetTotalSize(i.ToString()) - (int)vFS.GetTotalFreeSpace(i.ToString());
                long intBytes = UsedSpace;
                m_log.InfoFormat("FILE SYSTEM", "Detected Partition Label for Partition: " + i.ToString() + " is " + label);

                m_log.InfoFormat("FILE SYSTEM", @"Total Size for Partition " 
                + i.ToString() +
                " is " + FormatBytes(vFS.GetTotalSize(i.ToString())) + 
                " Free: "+ FormatBytes(vFS.GetTotalFreeSpace(i.ToString())) + 
                " Used: "+ FormatBytes((long)intBytes));
            }
i think that it is because the for loop will only count to one less than is found?
Elia Sulimanov
@EliaSulimanov
image.png
tried your code, the count is 1 on first init of VFS
and it goes to this:
image.png
have you done anything oherwise then initing the VFS?
also while debugging your code, I noticed 2 additional problems of the debugger.
Elia Sulimanov
@EliaSulimanov
  1. I can't step into "m_log.InfoFormat("FILE SYSTEM", @"Total..." line, as there is blank line in between
  1. the IDE would crash each time I try to open the debugger "locals" tab
KM198912
@KM198912
    public void InfoFormat(string area,string text)
    {
        Console.ForegroundColor = ConsoleColor.Yellow;
        Console.Write("[" + area + "] ");
        Console.ForegroundColor = ConsoleColor.White;
        Console.WriteLine(text);

    }
but i figured it now