Where communities thrive

  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
    Has anyone here setup a dapr deployment with docker compose on which each microservice is in their own compose deployment?
    with different IPs and all?
    Kyle Housley
    @yaron2 I'm seeing the sidecar injector fail with this message:
    2020/09/04 00:02:52 http: TLS handshake error from remote error: tls: bad certificate
    It goes away for a while after restarting the deployment and then returns. Any idea what the problem could be? I saw the workaround here dapr/dapr#1621 (which is what was followed), but there was no link in that issue to the corresponding change in documentation. This is a version 0.8 installation.
    2 replies
    Eduardo Monteiro de Barros
    Hi.. I'm researching on Dapr and I have 2 questions that I haven't found answers for yet. Could anyone help?:
    1) With Dapr.Workflows is it possible to manage the workflow (LogicApp) in Azure? How do we go about getting usage details and princing?
    2) For Redis state store, does the current component support failover and/or Redis Sentinel? I saw that the go-redis library does.
    14 replies
    dapr/docs#774 Request a review about doc update. The update is about to remove the nats.md and add the nats-streaming.md in how to setup pub-sub message broker.
    @yaron2 Hi, Is there an example of service call from dapr service to dapr service with dotnet with grpc protocol?
    Arve Nygård

    Hi I'm having trouble getting service invocation from C# sdk to work.
    Even tried running the samples at https://github.com/dapr/dotnet-sdk/tree/master/samples/Client/DaprClient.

    I have "routing" up and running, and can invoke it successfully via dapr invokeGet -a routing -m 17 .

    However, when running the sample Client code (with the GET invocation uncommented), i get the following error:
    == APP == Unhandled exception. Grpc.Core.RpcException: Status(StatusCode=Unknown, Detail="context deadline exceeded")

    I get the same error when I try to invoke my own service code from another of my own services, which is what started me down this road. After getting the excact same error from sample code i figured it's time to ask for help :P Any ideas? Running on OSX if that matters.

    8 replies
    Yaron Schneider
    @amanbha can you assist @arvearve ?
    Gokhan Altinoren
    Asked a question about using Dapr and CAP together here: dotnetcore/CAP#662 . CAP automates outbox pattern for transactional messaging but talks directly to underlying bus, hence seems incompatible with Dapr pubsub. Comments are welcome.
    5 replies
    I just moved from 0.9.0 -> 0.10.0 with the C# sdk and it broke my pub/sub. Previously it took one string parameter and now it takes two (pubsubName and topicName). I don't know which one was there first and am struggling to find the documentation to describing how they are used. Can someone point me to the documentation on the change?
    20 replies
    Tugay Ersoy
    Hi, I have a question about pubsub component's metadata name, Is it a disadvantage that the same Pubsub component uses the same metadata name for many microservices? Is it affect performance etc. For example, I have 3 microservices they have 3 different methods and they are listening to 3 different topics(the same pubsub metadata name) and i used the same pubsub component(nats.streaming) YAML each of them. What is the best practices for this mechanism
    5 replies
    @piotrmsc Hi Piotr, Did you produce any documentation on how to get Istio working with Dapr, we are bumping into issues ourselves but getting into trouble with Redis and Dapr and the EnvoyProxy (Istio manages) seems to require more configuration. Any help or pointers would be appreciated, thanks , Anthony.
    Nghia Tran
    Tom Bern
    Hello @tcnghia
    Jens N.
    Hi, is it possible to get all keys/items from state for the azure blob storage component ? Can't seem to find it in the docs.
    1 reply

    Hi All!
    We are trying to POC dapr for our company, really like what its trying to achieve.
    We have it running in Kubernetes and want to setup dapr running on a VM.

    My question is
    How do i step these two locations to communicate with each other?
    How does service discovery work across hosts?

    7 replies
    Hi All! How can I inject DbContext in Actor?
    1 reply
    Matthew Cochran
    Hi, is it possible to create and register custom middleware components in C#? If so, is there an example I could look at? (ref https://github.com/dapr/docs/tree/master/concepts/middleware )
    2 replies
    Tugay Ersoy
    Hi guys , I have a question about the pub/sub mechanism. When I use nats as a service broker, I am publishing a event on topic. if subscribers are not alive, exception is throwing what should I do for preventing this problem? According to document ;
    • "Streaming server will store all messages published to the streaming API into a channel (no subscribers need yet to exist)"
    • "When a subscriber subscribes to a subject, messages in the channel are played back."
    5 replies
    Yavuz TÜRK
    Hi, I have sample .net core web api using Dapr and i make simple post request to another api ( 'http://localhost:3500/v1.0/publish/neworder') . I wanna attach running Dapr Application and Debug Dapr with VSCode. Is it possible? How can i? Thanks.
    when you run dapr, just debug your app like you always do.
    4 replies
    are there plans to add key expiration to the state store?
    Davide Bedin

    Not solving this (silly) issue by myself.
    Dotnet SDK 0.10, two ASP.NET http WebApi projects: app order-service has to invoke app reservation-service method via await daprClient.InvokeMethodAsync<object>("reservation-service", "reserve", data, httpExtension);.
    Both applications correctly appear in VS Code extension while debugging, their methods can be invoked via http or VS Code extension, the reservation-service can also be invoked with DaprClient client.InvokeMethodAsync by a console proj I launch as a Dapr app.
    Once order-service, in the scope of a method call, does attempt to invoke reservation-service method, I received the error: "Error starting gRPC call: No connection could be made because the target machine actively refused it."
    Any hint on the plausible cause?

    The full stack trace:

    Grpc.Core.RpcException: Status(StatusCode=Internal, Detail="Error starting gRPC call: No connection could be made because the target machine actively refused it.")
       at Dapr.Client.DaprClientGrpc.MakeGrpcCallHandleError[TResponse](Func`2 callFunc, CancellationToken cancellationToken)
       at Dapr.Client.DaprClientGrpc.MakeInvokeRequestAsync(String appId, String methodName, Any data, HTTPExtension httpExtension, CancellationToken cancellationToken)
       at Dapr.Client.DaprClientGrpc.InvokeMethodAsync[TRequest](String appId, String methodName, TRequest data, HTTPExtension httpExtension, CancellationToken cancellationToken)
       at sample.microservice.order.Controllers.OrderController.SubmitOrder(Order order, DaprClient daprClient) in C:\Repos\dapr-samples\chapter03\sample.microservice.order\Controllers\OrderController.cs:line 33
       at lambda_method(Closure , Object )
       at Microsoft.Extensions.Internal.ObjectMethodExecutorAwaitable.Awaiter.GetResult()
       at Microsoft.AspNetCore.Mvc.Infrastructure.ActionMethodExecutor.AwaitableObjectResultExecutor.Execute(IActionResultTypeMapper mapper, ObjectMethodExecutor executor, Object controller, Object[] arguments)
       at Microsoft.AspNetCore.Mvc.Infrastructure.ControllerActionInvoker.<InvokeActionMethodAsync>g__Awaited|12_0(ControllerActionInvoker invoker, ValueTask`1 actionResultValueTask)
       at Microsoft.AspNetCore.Mvc.Infrastructure.ControllerActionInvoker.<InvokeNextActionFilterAsync>g__Awaited|10_0(ControllerActionInvoker invoker, Task lastTask, State next, Scope scope, Object state, Boolean isCompleted)
       at Microsoft.AspNetCore.Mvc.Infrastructure.ControllerActionInvoker.Rethrow(ActionExecutedContextSealed context)
       at Microsoft.AspNetCore.Mvc.Infrastructure.ControllerActionInvoker.Next(State& next, Scope& scope, Object& state, Boolean& isCompleted)
       at Microsoft.AspNetCore.Mvc.Infrastructure.ControllerActionInvoker.<InvokeInnerFilterAsync>g__Awaited|13_0(ControllerActionInvoker invoker, Task lastTask, State next, Scope scope, Object state, Boolean isCompleted)
       at Microsoft.AspNetCore.Mvc.Infrastructure.ResourceInvoker.<InvokeFilterPipelineAsync>g__Awaited|19_0(ResourceInvoker invoker, Task lastTask, State next, Scope scope, Object state, Boolean isCompleted)
       at Microsoft.AspNetCore.Mvc.Infrastructure.ResourceInvoker.<InvokeAsync>g__Awaited|17_0(ResourceInvoker invoker, Task task, IDisposable scope)
       at Microsoft.AspNetCore.Routing.EndpointMiddleware.<Invoke>g__AwaitRequestTask|6_0(Endpoint endpoint, Task requestTask, ILogger logger)
       at Microsoft.AspNetCore.Authorization.AuthorizationMiddleware.Invoke(HttpContext context)
       at Microsoft.AspNetCore.Diagnostics.DeveloperExceptionPageMiddleware.Invoke(HttpContext context)
    10 replies
    HI, i'm new on dapr and facing some install issues, can add my questions here?
    first i installed dapr:
    and docker:
    now i'm facing dapr init issue:
    i' don't know it looks at the version v0.2.0 . the first script install has installed the version V0.10.0
    Yaron Schneider
    @hichamveo it tries to download version 0.2.0 of the dashboard, not Dapr. However we dont yet have an ARM image for the dashboard. Theres an issue tracking it here: dapr/dashboard#75
    @yaron2 thanks for your response. I faced a lot of problems to get start on win server 2016 and bought a raspberry to work with :(
    i wasn't aware that there is no ARM image
    so I cannot init dapr and work with without this dashboard?
    Yaron Schneider
    @hichamveo you should have Dapr installed just without the dashboard. Try it out.
    Andrea Tosato
    Hi, I'm starting to look dapr for a new project. I would need to process files in a folder, is there a trigger for the filesystem? Must I only use timer trigger?
    Davide Bedin
    I have a .NET grpc service (reservation-service) and exposed via Dapr with --app-protocol grpc.
    As expected, another ASP.NET service (order-service), once invoked via http://localhost:5010/v1.0/invoke/order-service/method/order, is in turn able to reach the reserve method of gRPC service reservation-service via DaprClient.
    Should I be able to reach reservation-service also with http requests to a Dapr sidecar, such as http://localhost:5010/v1.0/invoke/reservation-service/method/reserve?
    I receive back the error, therefore my question.
      "errorCode": "ERR_DIRECT_INVOKE",
      "message": "Message field is nil"
    3 replies
    Charlie Stanley
    @yittg You around? If you can validate that I implemented your recommended fix correctly? dapr/dapr#2039
    3 replies
    level=error msg="could not find active reminder with key:
    I basically activate an actor, add a reminder that fires every 5 sec, and that works fine ... then kill dapr
    then start dapr again ... and the reminder is NOT firing and I get the message above in the console
    I thought reminders persist, and will run even if the actor is not currently activated (ie will activate id) ... the fact that it is trying to find the reminder means it's persisted, but not sure why it can run it (as I type this, I wonder if I need to save the state of that actor for it to exist enough to be reminder activatable??? hmmm)
    Artur Souza
    @aktxyz Please, create an issue in dapr/dapr. Also give the exact commands you used to repro (if possible) and which Dapr runtime version and SDK you are using for Actors.
    tried the saving thing and that did not help ... will create an issue
    xavier geerinck
    Question: I am trying to persist a state value in one application and fetch it in another, how would I do that? Since the format is <App ID>||<state key> which means that the APP ID will be different :)
    6 replies
    are reminders per actor instance (actorid), or per actor type ... based on the docs it sounds like per actor instance, but looking at the code it sure looks like per actor type
    also, you can get/set/remove a reminder ... but does not seem you can get a list of reminders ... in the code there is a nice internal method for this, but seems like this should also be exposed?
    Hi! right now I can use Dapr for production environment? Dapr is ready for Apps on production? Thanks!
    2 replies
    looking thru the actor api specs ... is there a way to delete an actor?
    answering my own question from above ... reminders are definitely per actor instance (actorid)