These are chat archives for DevifyPlatform/devify-server

8th
Mar 2016
jollen chen
@jollen
Mar 08 2016 04:00
@rockly222 更新 devify-server 再試試。可以用 devigy new <dir> 下載新版本。
jollen chen
@jollen
Mar 08 2016 05:16
可以用 git 來跟 devify-server 同步程式碼,https://github.com/DevifyPlatform/devify-cli 有說明
或是,剛剛加了一個新的 update 命令 $ devify update <your_dir>
記得 npm install -g devify-cli 更新 devify 命令工具
終於可以在 Linux 上用 SQL Server 了,來寫個 SQL server 的 endpoint service
hata
@iamhata
Mar 08 2016 17:36

@jollen Hi 老師 ,請問一下,我使用Azure 的VM(ubuntu 14), 從下載devify-server,要啟動時發生如下的錯誤,抱歉請問這可能是什麼問題?

neil@iotvm:~/devify-server$ nodejs esp8266-websocket-server.js

/home/neil/devify-server/node_modules/wotcity.io/runtime/runtime.js:52
upproc,
^
SyntaxError: Unexpected token ,
at Module._compile (module.js:439:25)
at Object.Module._extensions..js (module.js:474:10)
at Module.load (module.js:356:32)
at Function.Module._load (module.js:312:12)
at Module.require (module.js:364:17)
at require (module.js:380:17)
at Object.<anonymous> (/home/neil/devify-server/node_modules/wotcity.io/index.js:36:15)
at Module._compile (module.js:456:26)
at Object.Module._extensions..js (module.js:474:10)
at Module.load (module.js:356:32)