Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Nov 26 14:15
    MunifTanjim commented #59
  • Oct 18 07:29
    kkfd008 commented #54
  • Jun 21 20:08
    umireon commented #64
  • Jun 21 19:58
    umireon commented #64
  • Jun 21 16:10
    Kazuo256 commented #64
  • Jun 21 15:35
    umireon commented #64
  • Jun 20 21:13
    Kazuo256 opened #64
  • Sep 23 2020 12:59
    rowanthorpe opened #63
  • Aug 10 2020 15:44
    umireon commented #62
  • Aug 10 2020 15:39
    jamesboehmer opened #62
  • Jun 22 2020 10:03
    rokkarinn commented #55
  • Jun 19 2020 14:42
    umireon commented #55
  • Jun 17 2020 17:59
    yourpalmark commented #55
  • May 18 2020 00:48
    cxw42 opened #61
  • May 17 2020 23:57
    cxw42 opened #60
  • Feb 12 2020 08:25
    sharpobject opened #59
  • Aug 14 2019 20:18
    doyousketch2 opened #58
  • Aug 08 2019 23:43
    locci opened #57
  • Jun 01 2019 06:15
    astadmistry commented #22
  • Jun 01 2019 05:54
    astadmistry commented #44
Abhishek Das
@abhshkdz
Glad you set this up
I had a few issues getting it to play well with zsh
And after installing, luaver prints fine
But when I do luaver install 5.2.4, it says __luaver_print:2: = not found
Dhaval Kapil
@DhavalKapil
Thanks for pointing out! Will fix it.
Dhaval Kapil
@DhavalKapil
@abhshkdz Replace your ~/.luaver/luaver with https://github.com/DhavalKapil/luaver/blob/zsh/luaver and try again. I tried to fix all the issues. Let me know if you face any.
Abhishek Das
@abhshkdz
Thanks @DhavalKapil. This works to some extent. It downloads and runs a bunch of commands
cd src && install -p -m 0644 lua.h luaconf.h lualib.h lauxlib.h lua.hpp /Users/abhshkdz/.luaver/lua/5.3.1/include
cd src && install -p -m 0644 liblua.a /Users/abhshkdz/.luaver/lua/5.3.1/lib
cd doc && install -p -m 0644 lua.1 luac.1 /Users/abhshkdz/.luaver/lua/5.3.1/man/man1
__luaver_install_lua:read:21: -p: no coprocess
^These are the last 4 lines of output
Dhaval Kapil
@DhavalKapil
Fixed @abhshkdz. Don't know how I missed this.
Abhishek Das
@abhshkdz
Seem to be getting there
install seems to get stuck on the last command, but when I press 'enter' it clears up
list prints 5-6 blank lines though
Dhaval Kapil
@DhavalKapil
screenshot?
I am not getting any such issue. Which os? zsh version?
Abhishek Das
@abhshkdz
I'll post a screenshot, wait
zsh 5.2 (x86_64-apple-darwin15.0.0)
Dhaval Kapil
@DhavalKapil
I see, it's an issue with the kind of print I'm using
No debug statement is getting printed
Thanks will look into it :)
Abhishek Das
@abhshkdz
cool :thumbsup:
Dhaval Kapil
@DhavalKapil
@abhshkdz a little question, do colors show up in your terminal when you use nvm list?
Dhaval Kapil
@DhavalKapil
And does printf "\033[1mSome Text\033[0m" print in bold?
Massimiliano Bertinetti
@eclecticlly
Hi @DhavalKapil . I'm writing the new docs for Sailor where I advise to use Luaver for having support for Lua 5.1 and 5.3. I do this personally on Mac and Ubuntu but I lack this experience on Arch based system. I know that Manjaro and Antergos comes with Lua 5.3 preinstalled because of some VLC plugin. How can I procede?