Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    Des Petrie
    @DesPetrie
    @surge-cmcgeorge Thanks. I'll take a look.
    Des Petrie
    @DesPetrie
    @eddiana we are unabel to get the worspaces to load anymore and get the following errors:ErrorSA1- Error after trying to open existing workspace.
    ErrorSA2- Error after trying to open SA.
    ErrorSA3- Error after trying to create new workspace.
    ErrorSA1.PNG
    ErrorSA2.PNG
    ErrorSA3.PNG
    Ed Diana
    @eddiana
    I was able to duplicate this as well. I believe its due to a missing firebird/interbase SQL dll for Qt. I've been trying to figure out what I need to do to build that.
    DavidD2
    @DavidD2
    ErrorSA5.PNG
    ErrorSA4.PNG
    DavidD2
    @DavidD2
    @eddiana Hi Ed, I got the following errors when trying to use SA:
    ErrorSA5- Error after trying to create a new workspace.
    ErrorSA4- Error after trying to load an existing workspace.
    Ed Diana
    @eddiana
    @DavidD2 ok, thanks for the info. I'll take a look at it.
    Ed Diana
    @eddiana
    blob
    Des Petrie
    @DesPetrie
    @eddiana does that mean you were able to create a new project ?!?
    Ed Diana
    @eddiana
    I was able to get it to load one of the test projects
    Des Petrie
    @DesPetrie
    !!!
    Ed Diana
    @eddiana
    :-)
    Under SaCommon/Plugins are several additional projects that build DLL's.
    The 'big' one is called CBase.dll and has that one assessment model feature as well as the database upgrade functionality (for migrating to the latest sql table layout in 3.2)
    I managed to get that built and put it into the right spot in the runtime. I'll zip that up for you to try out.
    Des Petrie
    @DesPetrie
    That's great news, thanks Ed
    Ed Diana
    @eddiana
    Oh, it also adds things to the Options window. Apparently there's an XML file in the dir of each Plugin that defines all the possible settings for that plugin.
    Ed Diana
    @eddiana
    @DesPetrie here's the updated runtime: http://www.eddiana.com/downloads/SignatureAnalyst_x64.zip
    Let me know how it works!
    Des Petrie
    @DesPetrie
    David and I both tested and get this error when opening:
    Des Petrie
    @DesPetrie
    sa_error1_on_launch.JPG
    @eddiana
    and the error for creating a new workspace:
    sa_error2_creating_new_workspace.JPG
    Ed Diana
    @eddiana
    I've seen those as well. The error creating a new workspace has something to do with the program not correctly copying the template database file (called TEMPLATE.FDB) into the new project dir. If you look at the directory above the directory you are making, you'll see a SignatureAnalyst.fdb file with the name of the path pre-prended to it (like projectsSignatureAnalyst.fdb - as if the "/" was added)
    *wasn't
    DavidD2
    @DavidD2
    I still get the error, 'Plugin Spadac.AssesmentModel.Fsp was not found' when trying to load an existing workspace.
    Des Petrie
    @DesPetrie
    We also get those .fdb files. But the .fdb default name should be SignatureAnalyst.fdb
    When we rename the .fdb to SignatureAnalyst.fdb and move it into the workspace fodler, we are able to open it in SA, but we only see this (we can't right click on the projects folder):
    sa_newworkspace.JPG
    DavidD2
    @DavidD2
    @eddiana I tried loading Levi's training data and got the same types of errors as before. I'm sending you a zipped folder over email for you to try to load into SA.
    Ed Diana
    @eddiana
    ok, thanks!
    Ed Diana
    @eddiana
    @DesPetrie I think the error messsages about missing resources are due to missing shape files. SA seems to be looking for this shape file when I load the Florida test project: C:/Users/dr004028/Desktop/Sinkhole/Events/Sinkhole.shp
    Any chance you can get the shape files for that project?
    Wes Hildebrandt
    @WesHildebrandt
    @eddiana @DesPetrie -- have we tried creating a project from scratch? that may be easier than trying to get a previous one to load
    Ed Diana
    @eddiana
    @WesHildebrandt I did try that, but there's a problem with the context menus not showing. So I switched over to try to load an existing project because I didn't know if the context menus (in general) weren't showing, or if they weren't showing because something was missing in the newly created projects.
    Wes Hildebrandt
    @WesHildebrandt
    nothing's ever easy! :-)
    when you say the context menus don't show, does that mean there was an error, or they're empty/invisible/underneath other layers, or just nothing happens when you right click?
    DavidD2
    @DavidD2
    I can send you the shapefiles
    @eddiana
    Ed Diana
    @eddiana
    lol, no, it never is. Nothing is showing right now when you right click over items in the project explorer. It doesn't look like its responding to the right click. But I'm not sure if thats due to a GUI problem, or if there's something that needs to be set when adding the items in the project explorer so that it knows to respond to the event.
    Thanks @DavidD2 ! I think that will help. I'll set up the same local path on my machine and see if the program will load them.
    Mitul Patel
    @mv003348
    @/all - Is anyone using this instance in AWS:
    Instance: i-84aa1317 (sa_temp_gitsvn_swingbox)
    Public DNS: ec2-54-145-245-34.compute-1.amazonaws.com
    Wes Hildebrandt
    @WesHildebrandt
    I'm not
    Ed Diana
    @eddiana
    No, I don't think so. Only using the Build VM, ip 54.165.77.101
    Christopher McGeorge
    @surge-cmcgeorge
    I'm not either.
    Mitul Patel
    @mv003348
    Okay - I will stop the instance for now