Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
  • May 20 22:02
    dependabot[bot] labeled #66
  • May 20 22:02
    dependabot[bot] opened #66
  • May 20 22:02

    dependabot[bot] on maven

    Bump gson from 2.6.2 to 2.8.9 i… (compare)

  • May 18 20:42
    doggie1989 starred DominoKit/domino-jackson
  • May 18 19:09
    doggie1989 starred DominoKit/domino-ui
  • May 17 18:40
    vegegoku commented #58
  • May 17 18:30
    foal commented #58
  • May 15 12:10
    mfreeman-xtivia starred DominoKit/domino-ui
  • May 14 18:28
    vegegoku commented #58
  • May 14 18:27
    vegegoku milestoned #58
  • May 14 18:27
    vegegoku labeled #58
  • May 14 18:27
    vegegoku assigned #58
  • May 14 18:23
    vegegoku edited #59
  • May 14 17:19
    foal opened #59
  • May 14 17:14
  • May 14 17:05
    foal opened #58
  • May 13 08:58

    vegegoku on master

    Fix sample code about tree menu… (compare)

  • May 13 08:58
    vegegoku closed #20
  • May 13 08:58
    vegegoku closed #19
  • May 13 08:52
    stockiNail opened #20
howudodat
@howudodat
I need to clean up the code and figure out what I did to get it working, then I'll post the code
howudodat
@howudodat
ok, here is the code that gets it to work, but I suspect that it's still not right
public class PnlHomes extends FlexLayout {
    protected Map map = null;
    protected MapView mapview = null;

    public PnlHomes() {
        initUI();
    }

    protected void initUI() {
        mapview = new MapView("homesmap");
        mapview.setWidth("100%");
        mapview.setHeight("100%");

        this.setHeight("900px");

        this.appendChild(FlexItem.create().appendChild(mapview).setFlexGrow(1));
//        this.appendChild(mapview);

        Scheduler.get().scheduleDeferred(new Command() {
            @Override
            public void execute() {
                map = MapPresets.getOsmMap("homesmap");
                map.updateSize();
            }
        });
    }
}
1: whether I wrap the view in flexitem makes no difference
2: nothing is visible unless I call setHeight with PIXELS. Why should I have to dictate pixel height? every screen could be different sizes. I just want the layout to handle this. it should be 100% of the viewport
howudodat
@howudodat
@TDesjardins what's the difference between ol.layer.Vector and ol.source.Vector? I'm trying to add some markers to the panel
Ahmad K. Bawaneh
@vegegoku
@TDesjardins you are right ..I didnt update the sample
Tino Desjardins
@TDesjardins

@TDesjardins what's the difference between ol.layer.Vector and ol.source.Vector? I'm trying to add some markers to the panel

OpenLayers distinguish between the type of layer and the type of datasources connected to layers (see https://openlayers.org/en/latest/doc/tutorials/concepts.html).

Do you know the example application of the domino map integration?
Tino Desjardins
@TDesjardins
By the way I have to update the example applications to new versions.
Jan
@HAC-jh
Hi @vegegoku Using the RC9 I've stumbled on an issue regarding a Select. Calling the select method with an existing SelectOption produces a "Maximum call stack size exceeded" exception because the Selects getValue method is called recursively
Ahmad K. Bawaneh
@vegegoku
yes there was a regression and I published an RC10
Jan
@HAC-jh
Ok, haven't seen this on the releases page of github. It mentiones still the RC9 as the last one. Thx for the info
Ahmad K. Bawaneh
@vegegoku
updated the github repo
Jan
@HAC-jh
:satisfied: thx
Jan
@HAC-jh
@vegegoku sorry to bother you again, just found another issue. The expand/collapse all icons aren't working anymore. This could be reproduced also with the demo. Just a short confirmation and I will create an issue
Ahmad K. Bawaneh
@vegegoku
I didnt update the demo yet too, plus I am runing a sample application with latest domino-ui and all works fine
Jan
@HAC-jh
https://demo.dominokit.org/components/tree?theme=indigo the expand icons expand only the childs of the selected parent, after collapsing all the expand all expands nothing anymore
Ahmad K. Bawaneh
@vegegoku
ok you mean the tree expand all/ collapse all
I thought you mean all collapse/expand functionality is broken
hmm.. I cant see any errors ..I will investigate
Jan
@HAC-jh
my fault, "the tree" was missing at my first message
Tino Desjardins
@TDesjardins

1: whether I wrap the view in flexitem makes no difference
2: nothing is visible unless I call setHeight with PIXELS. Why should I have to dictate pixel height? every screen could be different sizes. I just want the layout to handle this. it should be 100% of the viewport

Actually you don't have to dictate the pixel height but you have to ensure that the map container has a size when the map will be rendered. Especially with responsive layouts the height of containers and or it's parents is initially 0. If the map is drawn at this time the map also have a size of 0.

Maybe also this resource is interesting for you: https://www.freecodecamp.org/news/html-page-width-height/
Ahmad K. Bawaneh
@vegegoku
Yes also the size is 0 if the element is not attached yet and you draw the map before that, so always make sure the element is attached first, domino-ui has a nice way to do things on attach/detach
Tino Desjardins
@TDesjardins

Yes also the size is 0 if the element is not attached yet and you draw the map before that, so always make sure the element is attached first, domino-ui has a nice way to do things on attach/detach

@vegegoku Good point!

Ahmad K. Bawaneh
@vegegoku
@/all a new domino-mvp sample have been upload, find it here https://github.com/DominoKit/bookstore
the wiki should be updated by the end of next weekend
Ahmad K. Bawaneh
@vegegoku
@/all a new release of domino-cli have been released https://github.com/DominoKit/domino-cli/releases/tag/1.0.0-RC5
please follow the instructions in the readme to create gwt/domino project. looking forwrd for your feedback
Nick Gaens
@NickGaens

Hey guys.

@vegegoku It seems like the RC8 issue DominoKit/domino-ui#582 has come back in RC9 or 10:

Screen Shot 2021-10-20 at 2.03.07 PM.png
Initially the tree is totally fine, but after using the search function, it gets a bit messed up like shown in this screenshot.
Also, there are various gaps in the tree at times after clearing the search filter box.
I'll try to screenshot those.
It's ... weird .... perhaps you can make something out of it.
Frank Hossfeld
@FrankHossfeld
@NickGaens Just checked the demo app. It uses Domino-UI version 1.0.0-RC10. Doing a search inside the navigation tree works as expected. Please, can you check, that there is no additional coding from your side, that causes the error. As far as I can see fro your video, it looks like an element did get inivisible inside a tree item (that should be invisible) Please can you chek the generate code for that element.
Nick Gaens
@NickGaens
@FrankHossfeld Sure, I'll reiterate my code, but I'm quite sure no such custom code exists inside my project. I'll post my findings here later today.
Jan
@HAC-jh

ok you mean the tree expand all/ collapse all

Hi @vegegoku , did you have the chance to investigate regarding that problem?

Frank Wynants
@FrankW76

@FrankHossfeld Did you run the demo app on your own pc? Or are you talking about https://demo.dominokit.org/home?

In the latter case how do you know this is RC10?
Cause the online demo states : Last build on : 2021-10-10T07:04:46Z

Which is before RC10 was released.

Ahmad K. Bawaneh
@vegegoku
Demo is now updated to the latest and I can only confirm the expand all issue for tree component
Frank Hossfeld
@FrankHossfeld
Ah, ok, expected the demo is uptdate. Sorry, my fault.
Frank Hossfeld
@FrankHossfeld
@FrankW76 I took a look at your video. Thought, your were talking about the empty entries inside the tree when searching ...
Frank Wynants
@FrankW76

@FrankW76 I took a look at your video. Thought, your were talking about the empty entries inside the tree when searching ...

It is not my video.
I think @NickGaens is seeing a cache issue (and is in fact using RC10 with old domino css files)

Nick Gaens
@NickGaens
That seems to be the case.
I cleared the .m2/org/dominokit directory and (so I thought) the browser cache, but somehow there must have been cached CSS files still present. The issues I showed above in the screenshot and the recording are no longer.
Frank Hossfeld
@FrankHossfeld
sorry ... was confused, cause both of you are talking about tree issues ... :-)
Frank Wynants
@FrankW76
Do you guys have any hint on how to avoid some domino css files to get cached by the webserver.
image.png
For our own css files, everytime we compile we append a different ?version=1234 to the <link href tags in the index.html file