by

Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    Sven
    @SirWindfield
    Small question. Is it possible to deploy the Drombler application bundled with an jre as a zip using your maven plugin?
    Florian Brunner
    @puce77
    @SirWindfield Sorry for the late answer. I missed it and somehow also didn't get any notification. Currently there is no special support for this Drombler FX. I filed an enhancement issue here: Drombler/drombler-fx#137
    If you find any issues using one of the mentioned tools, it would be great if you could add a comment to the issue or file a new issue.
    jasons2000
    @jasons2000
    doesn't look like much is happening here?
    Florian Brunner
    @puce77
    @jasons2000 Gitter isn‘t much used currently, yes, but feel free to discuss things here anyway
    Dmitry Eliseev
    @Madzi
    Hi Florian, seems you use snapshot versions softsmithy libs which not publish in maven repo yet
    I'm change version in 'drombler-oss-parent' to latest available. It's build without errors, but when I try to run application it fails with:
    Dmitry Eliseev
    @Madzi
    ERROR: bundle org.drombler.fx.drombler-fx-core-status [46] Error starting file:.../drombler-fx-core-status-0.13.jar...
    Do you have any idea, how it's can be fixed?
    Ok. Error fixed. It was my fall. But snapshot libraries can be a problem.
    Florian Brunner
    @puce77
    Hi @Madzi , did you use a released version of 'drombler-oss-parent' or the SNAPSHOT version from the develop branch?
    My release setup should actually prevent released components from depending on other SNAPSHOT versions, so if this was the case it would be great to know the exact artifact you were using.
    SNAPSHOT versions on the other hand might dependend on other SNAPSHOT versions of Repos I'm managing, such as Repos from Drombler and SoftSmithy.
    If you don't want to build dependend SNAPSHOT projects as well, please make sure to define a proxy in your Maven Repository Manager to the following Maven Repository: https://oss.sonatype.org/content/repositories/snapshots/
    I'm deploying SNAPSHOT versions to this Repository when branches get merged to develop.
    Florian Brunner
    @puce77
    I will make this more clear in the README file of the projects.
    Florian Brunner
    @puce77
    I've updated the README files of the various projects, e.g.: https://github.com/Drombler/drombler-oss-parent
    Dmitry Eliseev
    @Madzi
    Hi Florian, thank you for the explanation. I'm use 0.14-SANPSHOT version. Only rollback SoftSmithy dependencies from snapshots to latest releases. It's work fine under Mac, and I have some problems with Windows (but I think it's my local problems).